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1 Introducing the OpticalRF 
OpticalRF is a digital spectrum analyzer that displays power spectrum, 
persistence, and/or waterfall graphs derived from the IQ data carried over 
a CPRI link. 

Technical Specifications
To obtain this product’s technical specifications, visit the EXFO Web site at 
www.exfo.com.
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Introducing the OpticalRF
Conventions
Conventions
Before using the product described in this guide, you should understand 
the following conventions:

WARNING
Indicates a potentially hazardous situation which, if not avoided, 
could result in death or serious injury. Do not proceed unless you 
understand and meet the required conditions.

CAUTION
Indicates a potentially hazardous situation which, if not avoided, 
may result in minor or moderate injury. Do not proceed unless you 
understand and meet the required conditions.

CAUTION
Indicates a potentially hazardous situation which, if not avoided, 
may result in component damage. Do not proceed unless you 
understand and meet the required conditions.

IMPORTANT
Refers to information about this product you should not overlook.
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2 Safety Information
Laser Safety Information 

WARNING
Do not install or terminate fibers while a light source is active. 
Never look directly into a live fiber and ensure that your eyes are 
protected at all times.

WARNING
The use of controls, adjustments and procedures, namely for 
operation and maintenance, other than those specified herein may 
result in hazardous radiation exposure or impair the protection 
provided by this unit.

WARNING
If the equipment is used in a manner not specified by the 
manufacturer, the protection provided by the equipment may be 
impaired.

WARNING
Use only accessories designed for your unit and approved by EXFO. 
For a complete list of accessories available for your unit, refer to its 
technical specifications or contact EXFO.
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Safety Information
Laser Safety Information
IMPORTANT
When you see the following symbol on your unit , make sure 
that you refer to the instructions provided in your user 
documentation. Ensure that you understand and meet the required 
conditions before using your product.

IMPORTANT
When you see the following symbol on your unit , it indicates 
that the unit is equipped with a laser source, or that it can be used 
with instruments equipped with a laser source. These instruments 
include, but are not limited to, modules and external optical units.

IMPORTANT
Other safety instructions relevant for your product are located 
throughout this documentation, depending on the action to 
perform. Make sure to read them carefully when they apply to your 
situation.
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Safety Information
Additional Laser Safety Information
Additional Laser Safety Information 
This product employs Class 1 Laser transceivers. 

Note: Refer to the module user guide for additional test equipment safety 
information and ratings. 

 

WARNING
When the LASER LED is on or flashing, the module is transmitting an 
optical signal on the SFP+ transceiver ports.
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3 Getting Started 
Supported Modules and Software Option 

The OpticalRF application is supported on the following modules having 
the CPRI-Spectrum software option enabled: 8870 and 8880. 

Software Installation 
If the OpticalRF application is not already installed, refer to the platform 
user guide for more information on how to install this application through 
Update Manager. 

Starting the OpticalRF Application 
From the SkyRAN Element Management System (EMS), request an 
OpticalRF interactive session. 
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Getting Started
Connecting to the RAN
Connecting to the RAN 
For simplex mode the module’s SFP+ P1 port is used to connect to the 
RAN (Radio Access Network). For duplex mode the module’s SFP+ P1 and 
P2 ports are respectively used to connect to the RAN for the UpLink and 
DownLink. Supported rates are: CPRI 1.2, 2.4, 3.1, 4.9, 6.1, 9.8, and 
10.1 Gbit/s. 

Plug the SFP/SFP+ transceiver into the P1/P2 slot. Refer to the module user 
guide for connector/port location purposes. 

Note: In order to avoid signal corruption issues that might affect your results, it is 
strongly recommended that the SFP/SFP+ inserted into the module’s SFP+ 
port is identical to the one on the optical splitter side. Similarly, the 
specification of the optical splitter and optical cable should be identical to 
the ones used in the CPRI link. 

CAUTION
To prevent exceeding the maximum input power level, please refer 
to the module technical specifications at www.exfo.com. 

WARNING
Refer to www.exfo.com for the list of supported transceivers. Using 
non-supported transceivers can affect the performance and 
accuracy of the test. 
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Getting Started
Connecting to the RAN
RF Spectrum Connection Diagram 

To the Optical Switch

P1-RX for Simplex mode or Duplex mode (UpLink)

P2-RX for Duplex mode (DownLink)
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4 Graphical User Interface 
Overview 

This chapter describes the OpticalRF graphical user interface. 

Title Bar 
Displays OpticalRF related information. 

Menu 

RF Spectrum Graph

Title Bar

Monitoring 
Configuration 
Digital Spectrum Analyzer for SkyRAN 11



Graphical User Interface Overview
RF Spectrum Graph
RF Spectrum Graph 

RF Spectrum
Graph View

Graph Settings

Graph Tools

Globall
Status 
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Graphical User Interface Overview
RF Spectrum Graph
Graph Settings 

The graph settings is a live area from which it is possible to set/change 
values by clicking on individual fields. 

 Source indicates the selected trace and allows either setting the basic 
trace, replacing a trace, or adding an overlay. Choices are 
Port1/2-AxCn the live connected test port-antennas (AxCn from port 1 
in simplex mode or UL-AxCn from port 1 and DL-AxCn from port 2 for 
respectively UpLink and DownLink in duplex mode). It is possible to 
display multiple AxCn simultaneously as well as the average, 
minimum, and maximum values (refer to Trace on page 39 and 
Overlay on page 40). 

 To display a single basic source, click Source, click Basic, and 
select the trace source. The basic trace is now displayed and all 
other overlays are deleted at the exception of Minimum and 
Maximum. 

 To replace a source, click the overlay to be replaced from the 
graph, click Source > Replace, and select another trace. 

 To add an overlay, click Source > Overlay, and select the trace 
overlay. 

 Mapping is the configuration (Manufacturer and Bandwidth) defining 
the parameters used by the application to decode and display the RF 
data. Clicking on this field allows the mapping selection and 
configuration; refer to Mapping on page 23. 

 Link1 indicates either if traffic is present on the input port 
(LossOfSignal or Active with RX power), RateScan while detecting 
the signal rate when Link Rate is set to Auto, or NoSFP (if the SFP is 
not detected). Clicking on this field displays the SFP information, 
which includes its power range and the measured RX optical power 
(current, minimum, and maximum values). 

1. Only available when the graph is from a live input source. 
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Graphical User Interface Overview
RF Spectrum Graph
The RX power is displayed using the following colors: 

 Rate1 indicates and allows selecting the CPRI link rate. Refer to Link 
Rate on page 23. 

 Channel BW indicates the channel bandwidth based on the selected 
mapping. Refer to Mapping on page 23. 

 Center indicates and allows selecting the center frequency. Refer to 
Center on page 33. 

 Span indicates and allows selecting the frequency span. Refer to Span 
on page 33. 

 RBW indicates and allows selecting the resolution bandwidth. Refer to 
RBW on page 34. 

 VBW indicates and allows selecting the video bandwidth. Refer to VBW 
on page 33. 

 Ref Level indicates and allows selecting the position of the power 
maximum value on the screen. Refer to Ref Level on page 31. 

 Scale indicates and allows selecting the spacing between power 
values on the screen. Refer to Scale on page 31. 

Overlay

Displays real time or average overlays, antennas and/or playback files, 
simultaneously; refer to Overlay on page 40. 

Color Description 

Green Power level is within the power range. 

Yellow Power level is out-of-range. 

Red LOS or power level close-to-damage.

Gray Pending state. 
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Graphical User Interface Overview
RF Spectrum Graph
RF Spectrum Graph View 

A traditional graph displaying amplitude against frequency for Spectrum, 
Waterfall, or Persistence type. 

The following actions are available when right-clicking on a graph:

 Barriers mark indicates the upper and lower frequencies of the signal 
as defined by the selected mapping. Refer to Barrier on page 29. 

 Grid displays the grid lines. Refer to Grid on page 29. 

 Snap Marker finds a peak close to the current cursor location on the 
screen. Move the cursor close to the desired peak, right click, select 
Snap Marker, and the marker number. 

 Enable Zoom enables the capability to zoom the graph. Refer to 
Enable Zoom on page 30. 

 Crosshairs draws a set of crosshairs on the screen centred on the 
cursor. Refer to Crosshair on page 30. 

 UnZoom clears the zoomed view. Refer to UnZoom on page 30. 

 Type allows selecting the graph type. Refer to Type on page 28. 

 PIM allows enabling PIM measurement and pass/fail verdict. Refer to 
Measures Menu on page 43. 

 Close View closes the current graph view. Only available when more 
than one graph is displayed. 

 Move View allows repositioning any graph on the screen. Right-click 
on the graph, select Move View, and click on a blue positioning bar 
where the graph will be moved in relation with the other graph(s). 
Only available when more than one graph is displayed. 

 Toggle Full Screen allows displaying the selected graph in full screen 
or normal. 
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Graphical User Interface Overview
RF Spectrum Graph
Graph Tools 

Global Status 

Indicates the current and history alarm status for each port when 
applicable. Clicking over the global status area gives access to the Logger 
(refer to Global Status, Alarms, and Logger on page 53). 

Icon Description

Record the trace 

Record a trace file to be replayed later.

Refer to Record on page 25.

Take screen snapshot 

Takes and saves screen shots of values/graphs that can be viewed later. The icon 
briefly displays the number 1 to indicate a screen shot has been taken.

Refer to Snapshots on page 17. 

Maximize current view 

This icon is displayed when multiple graphs are available on the screen. 

To view any of the individual graphs, select the graph then click this icon. 

Double-click a desired graph also maximize its view. 

Show all views 

This icon is displayed when multiple graphs are available while only one is 
displayed (maximized) and allows returning to multiple graphs view. 

Double-click on the graph also returns to multiple graphs view. 
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Graphical User Interface Overview
RF Spectrum Graph
Monitoring Configuration 

Allows enabling and configuring all antennas1 for monitoring in simplex 
mode on Port1 and in duplex mode on Port1 UpLink. In addition, duplex 
mode allows configuring all antennas1 on Port2 DownLink. 

Note: Simplex versus duplex mode is selectable from the EMS (Element 
Management System). 

 Port1, Port1 UpLink, and Port2 DownLink 

Port1 available with simplex mode, allows the configuration for each 
antenna for simplex mode. 

Port1 UpLink and Port2 DownLink available with duplex mode, allow 
respectively the uplink and downlink configuration for each antenna. 

1. The number of AxC depends on the interface rate and its mapping. 
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Graphical User Interface Overview
RF Spectrum Graph
The following configuration settings are available for each antenna: 

 Monitored check box when selected enables the monitoring of 
the antenna. Not available with Port2 DownLink. 

 Name indicates and allows the edition of the antenna‘s name. 

 AxC indicates the antenna‘s number. 

 Undo clears the configuration changes for the antenna; returns to 
the last exported configuration for the antenna. 

 Export saves and sends the new monitoring configuration to the 
SkyRAN EMS. 

 Undo clears the configuration changes for all antennas; returns to the 
last exported configuration for all antennas. 

IMPORTANT 
Make sure to set the Center Frequency for each enabled antenna 
(AxC). An antenna having its Center Frequency set to 0 will be 
ignored (not monitored) by the SkyRAN EMS for RF-PWR 
monitoring. 
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5 System Menu 
This section describes each item of the System menu. 

Snapshots 
 Snap allows capturing and saving screen shots of values/graphs that 

can be viewed later. 

Click System > Snapshots > Snap, the camera icon briefly displays 
the number 1 to indicate a screen shot has been taken. Alternatively, 
use the camera icon (Take Screen Snapshot) to do a snapshot (refer 
to Graph Tools on page 16). 

Screen shot images are saved in JPEG (.jpg) format in the 
Documents\OpticalRF\ScreenCapture folder. File names start with SC 
followed by the date, an underscore, time, and 3-digit number 
(e.g. SC20160819_084539_695.jpg). 

 View allows opening a previously saved screen shot. 

Click System > Snapshots > View, select a file, and click OK. 

Load Profile 
Allows opening a previously saved configuration profile. 

Click System > Load Profile, select a previously saved configuration file, 
and click OK. 

Save Profile 
Allows saving the configuration settings that can be loaded later.  

Click System > Save Profile, enter the name of the file or select an existing 
file, and click OK. 

Preferences...
There are no preferences to set. 
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System Menu
Exit
Exit 
Closes the OpticalRF application. 

Click System > Exit (Alt-F4). 

Restore Default 
Returns the OpticalRF application to its factory default settings. It is 
sometimes easier to reset the application to its defaults than work through 
a number of configuration settings. 

Click System > Restore Default and Yes to confirm; the OpticalRF returns 
to default settings. 

Note: The new configuration needs to be exported to the SkyRAN EMS to be 
effective. 
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6 View Menu 
This section describes each item of the View menu. 

Layout 
Allows changing the resolution of the menu graph settings and all opened 
pop-up windows. This can be useful when operating the system remotely 
on a different resolution screen. 

Click View > Layout, and select the desired setting: Extra_Large, Large, 
Normal, Small, or Extra_Small. 

Trace Config 
Allows overlaying Maximum, Minimum, Real-Time, and Average spectra.

Click View > Trace Config. Refer to Traces Menu on page 39. 

Marker Config 
Allows defining up to five optional markers that can be used to track 
frequency offsets on the spectrum. 

Click View > Marker Config. Refer to Markers Menu on page 35. 

Ref Level 
Sets the position of the power maximum value on the screen. 

Click View > Ref Level. Refer to Ref Level on page 31. 

Scale 
Sets the spacing between power values for the power spectrum. 

Click View > Scale. Refer to Scale on page 31. 
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View Menu
Center
Center 
Sets the center frequency for the currently displayed spectrum. 

Click View > Center. Refer to Center on page 33. 

Span 
Sets the frequency span of the currently displayed spectrum. 

Click View > Span. Refer to Span on page 33. 

Full Span 
Returns the currently displayed spectrum span to maximum value. 

Click View > Full Span. Refer to Full Span on page 33. 

VBW 
Modifies the Video Bandwidth. 

Click View > VBW. Refer to VBW on page 33. 

All Controls 
Displays all control pop-up windows: Traces, Markers, Ref Level, Scale, 
Center, Span, VBW, and CalLevel. 

Click View > All Controls. 

Toggle Full Screen 
Allows displaying the selected graph in full screen or normal. 
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7 Source Menu 
This section describes each item of the Source menu. 

Calibrate 
Allows setting the dBm scale (to the left of the power graph) to accurately 
reflect the power of the signals being displayed. Only available with the live 
port sources. Not available when full scale is enabled (refer to Full Scale on 
page 31). 

Click Source > Calibrate, and select the value. 

Link Rate 
Allows selecting the CPRI link rate. 

Click Source > Link Rate, and select Auto, Rate2 -1.228 Gpbs, 
Rate3 - 2.456 Gpbs, Rate4 - 3.072 Gpbs, Rate5 - 4.915 Gpbs, 
Rate6 - 6.144 Gpbs, Rate7 - 9.830 Gpbs, or Rate8 - 10.1376 Gbps. Auto 
automatically detects the CPRI link rate; the discovered link rate is 
displayed once detected. 

Mapping 
In order to extract RF data from a CPRI data stream, information for the 
specific manufacturer's equipment is required. RF Spectrum configuration 
mappings contain various parameters, such as bandwidth, used by the 
application to decode and display the RF spectrum from the CPRI data 
stream. 

Click Source > Mapping. 

 Description displays and allows the edition of the mapping name. The 
mapping name is not editable for preset mappings. 

 AxC# and Bandwidth (MHz) table lists each AxC number and its 
bandwidth in MHz. All is displayed when all AxC have the same 
bandwidth. 
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Source Menu
Mapping
 Auto-Detect1 allows automatic detection of the mapping from the live 
CPRI link. The detected mapping information is displayed when the 
detection succeeded and a mapping description is automatically given 
but editable: Auto-Detect_<date and time>. 

 Preset allows the selection of pre-defined mappings. 

 Aggregation, available for auto-detected mappings, allows aggregating 
component carriers together. 

 Component Carriers indicates the bandwidth of each individual 
carrier and allows aggregating carriers together. 

 Resulting Bandwidth indicates either the bandwidth of a single 
carrier or the total bandwidth of aggregated carriers (group of 
carriers). 

 AxC# indicates the AxC number for either a single carrier or a 
group of carriers. 

1. Available with CPRI-AUTODETECT software option. 

Button Description 

Aggregates two adjacent carriers having the same bandwidth together. 
Aggregation of several carriers is possible up to a maximum bandwidth 
of 20 MHz. 

Separates previously aggregated carriers. 

Aggregation is not possible between these two adjacent carriers since 
the bandwidth will exceed 20 MHz. 

- Absence of the button indicates that the two adjacent carriers cannot 
be aggregated together. 
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Source Menu
Record
Record
Records graphs that can be replayed later. Record is only available when 
using the live source port. 

Click Source > Record then either use the auto-generated name or enter a 
new one, select the record duration in milliseconds (16, 32, ..., 2048), and 
click OK. 

Recordings are saved in the proprietary .iqs format to the 
Documents\OpticalRF\IqsTraces folder. File names start with the date, an 
underscore, and the time (e.g. 20160819_084539.iqs). 

Note: It is also possible to start a record using the Record the trace icon. Refer to 
Graph Tools on page 16. 

Playback

Note: Not available. 
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8 Graph Menu 
This section describes each item of the Graph menu. 

Source 
Indicates the trace selected allowing its configuration. Clicking on the 
Source button, allows either setting the basic trace, replacing a trace, or 
adding an overlay. Choices are the live test port-antennas (AxCn for 
simplex mode, UL-AxCn and DL-AxCn for duplex mode). It is possible to 
simultaneously display AxCn overlays as well as the average, minimum, 
and maximum values (refer to Trace on page 39 and Overlay on page 40). 

 To add a single basic source: 
Click Graph > Source, click Basic, and select the trace source. The 
basic trace is now displayed and all other overlays are deleted with the 
exception of Average, Minimum, and Maximum. 

 To replace a source:
Click the overlay to be replaced from the graph, click Graph > Source, 
click Replace, and select another trace. 

 To add an overlay: 
Click Graph > Source, click Overlay, and select the trace overlay. 
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Graph Menu
Type
Type 
Allows selecting the graph type or a combination of graph types. Each type 
supports a different aspect of signal analysis. 

Click Graph > Type, and select the graph type. 

 Spectrum: The power magnitude of the input signal is displayed across 
the set frequency range. 

 Waterfall: Spectrogram giving a visual representation of frequency in 
the X axis against time in the Y axis. It is useful for seeing small 
changes in signal amplitude as well as picking out intermittent 
interferers. 

To the top left of the graph, there is a scale indicating the power values 
related to each color on the waterfall. 

To the right of the color chart is the current Refresh value setting in 
milliseconds (ms). The refresh rate sets the period between lines being 
added to the top of the waterfall. Reducing the period has the effect of 
speeding the waterfall up and can be useful when monitoring for short 
period interferers. Click on this field to select a new value. 

Moving the cursor over the waterfall displays at the top right of the 
screen the frequency offset at the current location. This gives a quick 
frequency reading for the current location and allows identifying short 
period or intermittent interferers. 

 Persistence: Power magnitude is plotted against frequency, with color 
denoting the percentage of time a plot point is placed at the current 
location. 
28 OpticalRF



Graph Menu
New
New 
It is possible to display multiple live or recorded graphs on the same 
screen. This can be useful when comparing a live graph against saved 
examples, or inspecting different aspects of the same source. 

To add a new graph:

1. Click Graph > New. 

2. Select the Type: Spectrum, Waterfall, or Persistence.

3. Select the Source, either the live connected test port-antennas (AxCn). 

4. Click OK. 

5. Click on a blue positioning bar where the new graph will be inserted in 
relation to the other graph(s). 

Note: A new button Show all views / Maximize current view is displayed. Refer 
to Graph Tools on page 16.

Grid 
Displays the grid lines when enabled (On). 

Click Graph > Grid to display/hide grid lines. 

Barrier 
Barrier, when enabled (On), marks the upper and lower frequencies of the 
signal as defined by the selected mapping. Only available with spectrum 
graph. 

Click Graph > Barrier to display/hide the barriers.
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Graph Menu
Crosshair
Crosshair 
Draws a set of crosshairs on the screen centred on the cursor. Values for 
frequency and power are displayed at top right of the screen. 

Click Graph > Crosshair to enable/disable the crosshair. 

Enable Zoom 
Enables the capability to zoom the graph. Once enabled, point and drag 
the mouse pointer over the graph region to be zoomed. Only available with 
spectrum graph. 

Click Graph > Enable Zoom and drag the mouse pointer over the graph 
region to be zoomed. 

UnZoom 
Clears the zoomed view. 

Click Graph > UnZoom.

Close All 
Closes all graphs. 

Click Graph > Close All and Yes to confirm. 

Note: To close a single graph, right-click on the graph and select Close View. 
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9 Amplitude Menu 
This section describes each item of the Amplitude menu. 

The spectrum graph can be set to display the aspect of the signal to 
observe. 

Full Scale 
On sets the currently displayed spectrum's amplitude to maximum (dBFS).

Off disables the full scale (dB or dBm). 

Click Amplitude > Full Scale to enable/disable full scale. 

Ref Level
Ref Level sets the position of the power maximum value on the screen. 
This has the effect of moving the base of the graph vertically on the screen. 

Click Amplitude > Ref Level and select the reference level value. 

Scale 
Scale sets the spacing between power values for the power spectrum. This 
has the effect of condensing or expanding the graph vertically on the 
screen. 

Click Amplitude > Scale and select the scale value. 
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10 Frequency Menu 
This section describes each item of the Frequency menu. 

Center
Center sets the center frequency for the currently displayed spectrum. 

Click Frequency > Center and enter the center value.

Span
Span sets the frequency span of the currently displayed spectrum. It has 
the effect of expanding or contracting the width of the graph. 

Click Frequency > Span and select the frequency span value.

Full Span
Full Span returns the currently displayed spectrum span to maximum 
value. 

Click Frequency > Full Span to display the maximum frequency span 
value.

VBW
VBW modifies the Video Bandwidth. Reducing the bandwidth smooths the 
waveform and produces a thinner trace by decreasing the amount of 
noise. This is useful when identifying a weak interferer which would 
otherwise be lost in the noise. 

Click Frequency > VBW and select the video bandwidth.
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Frequency Menu
RBW
RBW
RBW (Resolution Bandwidth) balances the amount of detail against the 
scan speed of the signal. On a signal that takes time to settle, increasing the 
resolution bandwidth reduces the number of points displayed allowing 
faster signal refresh. 

Click Frequency > RBW and select the resolution bandwidth value.
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11 Markers Menu 
This section describes each item of the Markers menu. 

Up to five optional markers can be used to track frequency offsets on the 
spectrum. Only available with Power Spectrum graphs. 

Configure 
The Configure sub-menu allows the configuration of the following marker 
parameters: Marker, Frequency, Active, Ref, Go Peak, and Next Peak. 

Click Markers > Configure and select the marker parameters.

Marker
Displays the marker number: 1 to 5.

Click Markers > Marker and select the marker value.
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Markers Menu
Active
Active
Activates/deactivates the corresponding marker. 

Click Markers > Active to activate/deactivate the selected maker.

Frequency
Frequency: Sets the frequency of the corresponding marker. Setting the 
frequency of a marker automatically activates this marker. 

Click Markers > Frequency and enter the frequency of the selected 
marker.

Ref 
Selects the marker to be used as the reference in the marker table. See 
Show Table on page 38. 

Click Markers > Ref and select the marker value.
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Markers Menu
Go Peak
Go Peak 
Moves the corresponding marker to the point of greatest amplitude. 

Click Markers > Go Peak to move the selected marker to the point of 
greatest amplitude. 

Next Peak
Moves the corresponding marker to the next peak on the spectrum graph.

Click Markers > Next Peak to move the selected marker to the next peak.

All Off
Deactivates all markers. 

Click Markers > All Off to deactivate all markers. 
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Markers Menu
Show Table
Show Table 
Displays the marker table as follows: 

Click Markers > Table / Show Table to display/hide the marker table. 

The following information is displayed for each marker: 

 Number indicates the marker number. 

 Active indicates that the marker is activated (Yes) or not (No).

 Frequency indicates the current frequency value. 

 Power indicates the current power values. 

  Power indicates the difference between the power value of the 
reference marker and the power value of this marker.

 The  Frequency displays the difference between the frequency of the 
reference marker (see Ref on page 36) and the frequency for this 
marker. 
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12 Traces Menu 
This section describes each item of the Traces menu. 

The OpticalRF can display more than just the default real-time spectrum. It 
is possible to overlay Maximum, Minimum, Real-Time, and Average 
spectra. Only available with Spectrum graph type. 

Configure
The Configure sub-menu allows the configuration of the Minimum, 
Maximum, RealTime, and Average trace parameters. 

Click Trace > Configure and select the trace parameters. 

Trace
Allows selecting an overlay in order to configure and enable it. Minimum, 
Maximum, and the Source traces are available by default. When using 
overlay graphs, the Minimum and Maximum graphs report the values 
based on all active overlays. 

Click Overlay > Trace and select an overlay. 
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Traces Menu
Overlay
Overlay 
Allows setting real time or average overlays, antennas and/or files, to be 
displayed simultaneously. 

To add a trace overlay on the graph:

1. Click Trace > Overlay.

2. Select the signal source: the live connected test port-antennas (AxCn). 

3. Select the Type as RealTime. 

4. Click Add. 

5. Repeat above steps to add additional trace overlays. 

6. Click Done. 

To delete an overlay trace from the graph: 

1. Select the check box of the trace overlay to be deleted. 

2. Click Delete. 

3. Click Done. 

Enable
Allows displaying/hiding the current selected trace overlay on the graph. 

On indicates that the current selected Trace overlay is displayed on the 
graph. 

Off indicates that the current selected Trace overlay is not displayed on the 
graph. 

Click Trace > Configure to display/hide the selected trace overlay. 
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Traces Menu
Refresh Rate
Refresh Rate
Sets the millisecond interval between the graph being redrawn on the 
screen: 0, 25, 50, 100, 200, 500, or 1000. 

Click Trace > Refresh Rate and select the refresh rate. 

All Off
All Off deactivates all spectra (Minimum, Maximum, RealTime, and 
Average). 

Click Traces > All Off to deactivate all spectra. 
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13 Measures Menu 
This section describes each item of the Measures menu. 

RF-PWR 
The RF-PWR alarm monitors the signal and checks for power level spikes 
that could be interferences and compares them to a threshold mask. 
Power level spikes usually come from interference sources. The RF-PWR 
threshold is configurable individually for each monitored AxCn. 

Power Spectrum Graph 

The graph of the Source trace power versus frequency is displayed as well 
as the mask. 

 Amplitude indicates the amplitude at the cursor point. 

 Frequency indicates the frequency at the cursor point. 
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Measures Menu
RF-PWR
Source 

Source allows selecting the source to apply the RF-PWR alarm to. Choices 
are the displayed AxCn graphs and overlays.  

PWR Threshold 

The RF Power Threshold (PWR Threshold) is a mask that is formed from a 
single or multiple contiguous segments (up to 20) that encompass the RF 
signal mapping bandwidth. The RF signal power level is monitored and 
compared to the PWR threshold to declare an alarm  when power level 
spikes are detected (refer to RF-PWR on page 56). The mask is compared 
with the live source graph only; not applicable for average, minimum, and 
maximum overlays. 

 Mask check box when selected (cleared by default) enables and 
allows the configuration of the mask alarm threshold. A basic default 
mask is created based on the average of the signal. 

 View Mask in Graph check box when selected (cleared by default) 
displays the defined mask on the graph of the selected source. 

 Edit Segment allows choosing the mask segment for edition by either 
using the left and right arrows or directly selecting the segment. The 
chosen segment is highlighted in blue. 

 Left Point selects the left-end point (highlighted in red) of the chosen 
segment for amplitude and frequency adjustments. Clicking on the left 
amplitude or frequency field automatically selects the Left Point. 

 Right Point selects the right-end point (highlighted in red) of the 
chosen segment for amplitude and frequency adjustments. Clicking on 
the right amplitude or frequency field automatically selects the 
Right Point. 

 Amplitude (dB) adjusts the left or right amplitude point of the chosen 
segment by either entering the amplitude value or using the slider to 
increase or decrease the amplitude value. 
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Measures Menu
RF-PWR
 Frequency (MHz) adjusts the left or right frequency point of the 
chosen segment by either entering the amplitude value or using the 
slider to increase or decrease the amplitude value. 

 Split creates a new segment by splitting the chosen segment in two. 

 Merge Left combines the chosen segment with the one to the left. 

 Merge Right combines the chosen segment with the one to the right. 

 New Mask restores the mask to its default settings with the ability to 
select the number of segments to be created. 

 Move Mask allows moving the mask on the graph. Use the arrow keys 
to respectively move the mask up, down, left, or right. 

 Copy Mask creates a mask based on another monitored source mask 
(Source Mask) while adapting the calibration and center frequency to 
the target source configuration parameters. 

Apply 

Applies the mask parameter changes for the selected source; the pop-up 
remains open. 

Close 

Closes the pop-up. A confirmation is required when changes are 
unapplied. 
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Measures Menu
PIM
PIM 
PIM (Passive Intermodulation) measurement gives the value in dB of the 
flatness of the signal excluding the edges: 
(rightmost value) - (leftmost value) = (PIM value) 

Click Measures > PIM. 

 Source allows selecting a source AxCn for PIM measurement 
configuration. Not available when the Apply to All check box is 
selected since all settings apply to all sources. 

 PIM check box when selected, measures the PIM value. 

The PIM value is displayed in the top right corner of the graph using the 
following colors: 

 Threshold (dB) check box when selected enables the PIM pass/fail 
verdict for the configured threshold absolute value (default is 6 dB). 

Text Color Description

White No verdict: the threshold is not enabled. 

Green Pass verdict: the PIM value is within the defined threshold. 

Red Fail verdict: the PIM value is outside the defined threshold. 
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Measures Menu
Show Table
 Apply to All check box when selected applies the PIM and Threshold 
settings to all traces.  

 Done closes the pop-up menu. 

Show Table 
Displays the measures table as follows: 

Click Measures > Table / Show Table to display/hide the measurement 
table. 

The following information is displayed for each trace overlay having PIM 
enabled: 

 Source indicates the source of the signal. 

 PIM indicates the measured slope value in dB. The PIM value is 
displayed using the following colors: 

Text Color Description

White No verdict: the threshold is not enabled. 

Green Pass verdict: the PIM value is within the defined threshold. 

Red Fail verdict: the PIM value is outside the defined threshold. 
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Measures Menu
RF Link Viewer
RF Link Viewer 

Note: RF Link Viewer is available through the SkyRAN Element Management 
System (EMS). 

The RF Link Viewer gives RF monitoring results and a summary of the 
configuration for each AxC. 

To access the measurements from the EMS: 

1. From the EMS, Active Diagram, click on a RF Link. 

2. Click Edit. 

3. Click the Measures tab. 

4. From the table, View column, click on Open of the desired alarm event 
and the RF Link Viewer pop-up opens. 

Results 

 Link Status: the status of the CPRI link. 

 LOS: loss of signal (Present) or not (Absent). 

 LOF: loss of frame (Present) or not (Absent). 

 Sync Header1: sync header violations (Present) or not (Absent). 

 66B Block1: errored block condition (Present) or not (Absent). 

 Min RX Power: the lowest received optical power value in dBm. 

 Max RX Power: the highest received optical power value in dBm. 

 Power Range: the power range of the transceiver in dBm. 

 Start Time2: date and time the monitoring started. 

 Stop Time2: date and time the monitoring ended. 

1. Available with rate 10.1G. 

2. Date and time are reported using the time zone of the PC that initiated the EMS session.
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Measures Menu
RF Link Viewer
AxC Results 

List the following results for each AxC: 

 Number: The AxC number. 

 PIM 

 Value (dB): the measured PIM value in dB. 

 Alarm Status: PIM alarm (Present) or not (Absent). 

 RF-PWR 

 Threshold Crossing: the details of the RF-PWR alarm 
(AxC Number, Frequency in MHz, Amplitude in dB, and 
Threshold in dB). 

 Alarm Status: RF-PWR alarm (Present) or not (Absent). 

Link Rate and Radio Configuration Name 

 Link Rate: the CPRI link rate. 

 Radio Configuration Name: the selected mapping. 
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Measures Menu
RF Link Viewer
AxC Configurations 

List the following configuration parameters for each AxC: 

 Number: the AxC number. 

 Name: the AxC name. 

 Monitored: the AxC is monitored (True) or not (False). 

 Bandwidth (MHz): the AxC bandwidth in MHz. 

 PIM 

 Enabled: PIM is enabled (True) or not (False). 

 Threshold: PIM threshold is enabled (True) or not (False). 

 Threshold Value: the configured PIM threshold value in dB. 

 Calibration Level: an adjustment factor to obtain real power values (dBm) 
instead of relative value (dB). 

 Center Frequency: the signal center frequency in MHz. 

 Resolution Bandwidth: the spectrum resolution bandwidth in Hz. 

 Video Bandwidth the spectrum video bandwidth in MHz. 

 Power Spectrum Mask 

 Number: the AxC number. 

 Mask Enabled: RF-PWR mask enabled (True) or not (False). The 
mask is graphically displayed when enabled. 
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14 Help Menu 
This section describes each item of the Help menu. 

View Help 
View Help opens the OpticalRF application help information. 

Click Help > View Help (F1). 

Report 
Report generates a test report.  

 Job Information parameters are used to identify the source of the 
report and are not mandatory. Enter the following job information if 
required: Job ID, Contractor Name, Customer Name, Operator 
Name, Circuit ID, and Comment. Up to 30 characters are allowed for 
each parameter at the exception of Comment for which 256 characters 
are allowed. 

 Generate creates, saves, and opens the report in PDF format. 

 Reports are saved in PDF format in the Documents\OpticalRF\Reports 
folder. File names start with OpticalRFReport followed by the date, an 
underscore, and the time 
(e.g. OpticalRFReport_20160819_102314.pdf). 

 Close exits the report window. 
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Help Menu
Save Logs
Save Logs 
Click Help > Save Logs. 

Save Logs contains background information collected during the running 
of your system and can reveal underlying detail that will help diagnose 
problems or identify system components. If requested by EXFO technical 
support, 

Click Help > Save Logs, select a name or enter a name for the log and 
click OK. A confirmation message is displayed indicating the location of 
the file on disk. 

About 
About displays the version of the OpticalRF application and software 
options. 

Click Help > About. 

 Software Options button displays the list of software options installed 
on the module. 

Note: For information on how to install and activate software options, refer to the 
platform User Guide. The OpticalRF application must be restarted once a 
new software option is installed in order to activate it. 

 Done closes the About page. 
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15 Global Status, Alarms, and 
Logger 

This section describes the global status, alarms, and logger. 

Note: Alarms are reported for all monitored AxC sources; they are not reported 
against Minimum/Maximum/Average traces and playback files. 

Global Status 

Current and history alarms are displayed using different background colors 
as follows: 

Background 
color Alarm Description

Gray Current No test result available.

History

Green Current No alarm has occurred in the last second. 

History No alarm has occurred during the monitoring period. 

Red Current An alarm occurred in the last second. 

History

Amber History At least one alarm has occurred during the monitoring period. 

AlarmPort

Current status 

History status 
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Global Status, Alarms, and Logger
Alarm and Logger
Alarm and Logger 
Click over the global status area (Refer to Global Status on page 16) to 
open the alarms and logger pop-up. 

 Alarms displays detailed alarm status, see Alarms on page 55. 

 Logger lists the test events, see Logger on page 57. 

 Reset clears the test alarms and logger events. 

 X closes the alarms and logger pop-up.  
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Global Status, Alarms, and Logger
Alarms
Alarms 
Current and history alarms are displayed using different background 
colors; see Global Status on page 53. 

Note: An alarm block title containing the magnifier (+) icon allows zooming this 
block which displays alarms for each AxC. To zoom-in, tap the magnifier 
(+) icon or anywhere on the title bar of the block. To zoom-out, tap on the 
magnifier (-) icon or anywhere on the title bar of the block. 

 Interface 

 LOS (Loss Of Signal) 

Absence of an input signal or at least 16 8B/10B code violations 
occur in one hyperframe. 
Digital Spectrum Analyzer for SkyRAN 55



Global Status, Alarms, and Logger
Alarms
 Sync Header 

For rate 10.1G, indicates sync header violations. 

 66B Block 

For rate 10.1G, indicates that frames are received with errored 
block condition. 

 CPRI 

 Link Down 

Absence of an input signal (LOS) or a LOF alarm.  

 LOF (Loss Of Frame) 

The hyperframe alignment cannot be achieved or is lost. 

Note: The following alarms that are based on a defined threshold are 
automatically re-evaluated upon changing any of the following 
parameters: PWR Threshold (Measures), Center / RBW / VBW 
(Frequency), Calibrate (Source), and Full Scale (Amplitude). 

 RF-PWR 

A RF-PWR alarm reports the highest event for each monitoring slice 
associated to the signal mapping, one event per 1 MHz is reported. The 
alarm is raised when interference(s) on a real-time trace cross the 
defined threshold mask, in the monitoring slice, for 70 percent of the 
monitoring interval. The alarm is cleared when the interference(s) on 
a real-time trace are below the threshold mask for more than 50 
percent of the monitoring interval. 

 PIM 

Indicates that the measured PIM (Passive Intermodulation) absolute 
value is bigger than the defined threshold. 
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Global Status, Alarms, and Logger
Logger
Logger 
The Logger lists color-coded test events.

Sort By 

Select the sorting order of the event logger entries: 

 ID/Time (default) displays the event logger entries in numeric 
ascending order based on the ID number. 

 Event displays the event logger entries in alphanumeric ascending 
order based on the Event type. 

Logger Full 

The logger table can display up to 5000 event entries. Once the logger table 
reports 5000 event entries, a log full indicator appears and no further 
entries are possible. However, the events in the Pending state will be 
updated while monitoring.  
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Global Status, Alarms, and Logger
Logger
Table 

The logger table provides the following event logger information.

 ID: Indicates the event identification number. The events are 
sequentially numbered. 

 Time: Indicates when the event has been detected. 

 Event: Provides the event type and threshold crossing information 
when applicable. 

 Duration: Indicates the number of seconds within which the event 
occurred. 

 Details: Provides additional information adapted to the event type. 

The Event Logger information will be cleared when: 

 the logger is reset. 

 the unit is restarted. 

Note: An entry event remains in the Pending state as long as the event is not 
completed and is highlighted using a yellow background color. 
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16 RF Spectrum Graph - Quick 
Test Setup Procedure 

The following procedure is a simple test sequence using a live source. 

Quick Test Setup Procedure 
To setup a quick test: 

1. Connect the module to the radio access network (RAN). Refer to 
Connecting to the RAN on page 8. 

2. From the SkyRAN Element Management System (EMS), request an 
OpticalRF interactive session. 

3. Click Link Rate from the Source menu and select either the link rate or 
Auto for automatic detection. The Link icon from graph settings 
displays Active if the link rate is active and matches the selection; 
RateScan indicates that the unit is scanning to discover the link rate 
when Auto is selected. 

4. Click Select Mapping from the Source menu and select the desired 
mapping for the system under test. RF Spectrum mappings contain 
information on frequency, bandwidth and other information required 
to decode the spectrum from the CPRI stream. 

5. From Monitoring Configuration, select the Monitored check box for 
an AxC to be monitored then click over the enabled AxC row to select 
it (the row is highlighted). The power spectrum is displayed and its 
configuration is possible: 

5a. Click Center from the Frequency menu and set the center 
frequency for the selected AxC. 

5b. Click VBW from the Frequency menu and set the video 
bandwidth for the selected AxC. 

5c. Click RBW from the Frequency menu and select the resolution 
bandwidth for the selected AxC. 
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RF Spectrum Graph - Quick Test Setup Procedure
RF-PWR Monitoring
5d. Click Calibrate from the Source menu and set the dBm scale 
value to accurately reflect the power of the selected AxC. 

5e. Repeat steps 5 to 5d for all AxC to be monitored. 

RF-PWR Monitoring 
To monitor and compare the RF power to a mask threshold: 

1. Click Measures > RF-PWR.

2. Select the source of the trace.

3. Select the Mask and View Mask in Graph check boxes. 

4. Define the mask threshold. Refer to PWR Threshold on page 44 for 
more information.

5. Click Apply. 

6. Repeat steps 2 to 5 for all enabled AxC. 

7. Click Close. 
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RF Spectrum Graph - Quick Test Setup Procedure
PIM Measurement
PIM Measurement 
To measure the PIM value: 

1. Click Measures > PIM. 

2. Select the source of the trace. 

3. Select the PIM and Threshold check boxes. 

4. Set the threshold value. Refer to PIM on page 46 for more information.

5. Repeat steps 2 to 4 for all enabled AxC. 

6. Click Done. 

To send the configuration settings to SkyRAN Element 
Management System: 

From Monitoring Configuration, click on the Export button. 

Close the OpticalRF Interactive Session 
From the EMS, close the OpticalRF interactive session then the 
monitoring automatically begins. 
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17 Troubleshooting 
Solving Common Problems

Before calling EXFO’s technical support, please read the following 
common problems that can occur and their respective solution.

Problem Possible Cause Solution

Input signal not received or not 
compatible.

Dirty fiber connection. Ensure that the fiber and SFP are 
clean. Refer to the module user 
guide for more information. 

There is a configuration mismatch 
between the inserted SFP/SFP+ and 
the rate selected in OpticalRF.

Ensure that the SFP/SFP+ is 
supporting the rate used by 
OpticalRF.

The SFP/SFP+ is not compatible 
with the OpticalRF.

Ensure to use a compatible 
SFP/SFP+. Refer to 
www.exfo.com.
Digital Spectrum Analyzer for SkyRAN 63



Troubleshooting
Contacting the Technical Support Group
Contacting the Technical Support Group
To obtain after-sales service or technical support for this product, contact 
EXFO at one of the following numbers. The Technical Support Group is 
available to take your calls from Monday to Friday, 8:00 a.m. to 7:00 p.m. 
(Eastern Time in North America).

 

For detailed information about technical support, and for a list of other 
worldwide locations, visit the EXFO Web site at www.exfo.com.

If you have comments or suggestions about this user documentation, you 
can send them to customer.feedback.manual@exfo.com.

To accelerate the process, please have information such as the name and 
the serial number (see the product identification label), as well as a 
description of your problem, close at hand.

Transportation
Maintain a temperature range within specifications when transporting the 
unit. Transportation damage can occur from improper handling. The 
following steps are recommended to minimize the possibility of damage:

 Pack the unit in its original packing material when shipping.

 Avoid high humidity or large temperature fluctuations.

 Keep the unit out of direct sunlight.

 Avoid unnecessary shocks and vibrations.

Technical Support Group
400 Godin Avenue
Quebec (Quebec) G1M 2K2
CANADA

1 866 683-0155 (USA and Canada)
Tel.: 1 418 683-5498
Fax: 1 418 683-9224
support@exfo.com
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18 Glossary 
Acronym List 

A

B

C

D

E

F

? Help 

AxC Antenna System Container 

BBU Base-Band Unit 

BW Bandwidth 

CPRI Common Public Radio interface 

dB Decibels 

dBFS Decibels relative to Full Scale 

EMS Element Management System 

EVM Error Vector Magnitude 

FCC Federal Communications Commission 
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Glossary
G

H

I

L

M

N

P

Gbps Gigabit per second

GUI Graphical User Interface

Hz Hertz

ID Identification

IEC International Electrotechnical Commission

IEEE Institute of Electrical & Electronics Engineers

LOF Loss Of Frame 

LOS Loss Of Signal 

MHz Mega Hertz 

NATO North Atlantic Treaty Organization

PIM Passive Intermodulation
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Glossary
R

S

U

V

RAN Radio Access Network 

RBW Resolution Bandwidth

Ref Reference

RF Radio Frequency 

RRH Remote Radio Head 

RX Receive

SFP Small Form Factor Pluggable 

SNR Signal to Noise Ratio 

USA United States of America 

VBW  Video Bandwidth
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