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Licence Agreement and Warranty
IMPORTANT: CAREFULLY READ THE FOLLOWING LICENSE AGREEMENT BEFORE OPENING THIS INSTALLATION PACKAGE. 
BY OPENING THIS PACKAGE AND USING THE SOFTWARE WHETHER INCORPORATED OR NOT IN AN EXFO INC. ("EXFO") 
PRODUCT, YOU INDICATE YOUR ACCEPTANCE TO BE BOUND BY THE TERMS AND CONDITIONS OF THIS AGREEMENT. IF 
YOU DO NOT ACCEPT THE TERMS AND CONDITIONS OF THIS LICENSE AGREEMENT, DO NOT OPEN THIS PACKAGE AND 
PROMPTLY RETURN THE PRODUCT OR SOFTWARE WITH YOUR PROOF OF PAYMENT, WHEREUPON YOUR MONEY WILL 
BE REFUNDED.

THE PRODUCT OR SOFTWARE YOU ORDERED MIGHT INCLUDE SOURCE CODE AND/OR SOFTWARE COMPONENTS, IT IS 
PROVIDED FOR YOUR CONVENIENCE IN MODIFYING THE PRODUCT OR SOFTWARE TO SUIT YOUR SPECIFIC NEEDS, OR 
TO CREATE DERIVATIVE WORKS INCLUDING SOURCE AND LIBRARY FILES IF APPLICABLE. 

THE PRODUCT AND THE SOFTWARE MUST BE USED ONLY FOR YOUR INTERNAL BUSINESS OPERATION AND ITS INTENDED 
APPLICATION. YOU MAY NOT COPY OR USE THE SOURCE CODE OR THE SOFTWARE COMPONENTS TO PRODUCE OTHER 
SOFTWARE DEVELOPMENT TOOLS FOR DISTRIBUTION AND RESALE WITHOUT EXPRESS WRITTEN PERMISSION FROM 
EXFO. EXFO RETAINS ALL RIGHTS TO THE SOURCE CODE, THE SOFTWARE COMPONENTS AND ALL MODIFICATIONS 
THEREOF. YOU SHALL RESPECT AND COMPLY WITH ANY OF THE PROVISIONS LISTED BELOW WHICH MAY ALSO BENEFIT 
ANY GIVEN THIRD PARTY BENEFICIARY AS DEFINED HEREIN.

1. DEFINITIONS: The following definitions apply to the terms in the Agreement.

"Documentation" means the user’s manual and other printed materials accompanying the Software.

"Product" means the EXFO instrument designed for use with the Software, as the case may be.

"Software" means the computer programs, source code and software components contained therein and all updates and 
upgrades thereto. The term also includes all copies of any part of the computer program, source code or software 
components.

2. GRANT OF LICENSE: EXFO grants to you, the purchaser of the enclosed Software, a limited, restricted, non-exclusive 
license. You shall  use the Software only in conjunction with its purpose or in conjunction with the Product, subject to the 
limitations on use and disclosure contained herein and in the Documentation. You may:

 Use the Software on a network, file service or virtual disk; provided that access is limited to one user at a time and that 
you have the original copy of the Documentation and Software media.

 Make one (1) copy of the Software for backup or modification purposes in support of the use of the Software on a single 
computer.

 Merge the Software or incorporate the same into another program provided that such a program will, for so long as the 
Software is included therein, be subject to all of the terms and conditions of this Agreement.

You may not:

 Make copies of the Documentation.

 Assign, give or transfer the Software, any services or interests in the Software, to another individual or entity. Sublicense, 
lease, time-share, service bureau, lend, use for subscription service or rental use any portion of the Product, the Software, 
or your rights under this Agreement.

 Reverse engineering, disassemble or decompile in whole or in part the Software or the Product. 

 Publish any result of benchmark tests run on the Software or the Product.

YOU RECOGNIZE THAT THE SOURCE CODE AND THE SOFTWARE COMPONENTS COMPRISING THE SOFTWARE ARE 
HIGHLY VALUABLE TRADE SECRETS OF EXFO OR ANY GIVEN THIRD PARTY BENEFICIARY AND THAT EXFO WISHES TO 
PREVENT THEIR DISCLOSURE TO YOU, OR ANY THIRD PARTY.

3. SOFTWARE OWNERSHIP: The Software is licensed, not sold. Title to the Software shall not be passed to you or to any other 
party. All applicable rights to patents, copyrights, trademarks and trade secrets in the Software, or any modifications made at 
your request, are and shall remain the property of EXFO.

4. AUDITS: EXFO reserves its right to audit, at its convenience, your use of the Software. 

5. TERMS OF TERMINATION: This Agreement shall remain in full force and effect until you discontinue use of the Software or 
the Product, until the end of the life of the Product or Software or until this Agreement is terminated, whichever occurs earlier. 
Without prejudice to its other rights, EXFO may terminate this Agreement if you fail to comply with the terms thereof. In such 
event, you must destroy or return all copies of the Software and Documentation as requested in writing by EXFO. You shall be 
liable for all damages to EXFO as a result of the breach whether or not you were notify of the likelihood of such damages. 

EXFO retains all rights to the Software not expressly granted hereunder. Nothing in this Agreement constitutes a waiver of the 
rights of EXFO or any Third Party Beneficiary.
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6. LIMITED WARRANTY: EXFO warrants the media on which the Software is distributed to be free from defects in material 
and workmanship and that the Software will perform substantially in accordance with the Documentation. EXFO will replace 
defective media or Documentation at no charge, provided you return the item with dated proof of payment to EXFO within 
(60) days of the date of delivery. THESE ARE YOUR SOLE REMEDIES FOR BREACH OF WARRANTY. EXCEPT AS SPECIFICALLY 
PROVIDED ABOVE, EXFO MAKES NO WARRANTY OR REPRESENTATION, EITHER EXPRESS OR IMPLIED WITH RESPECT TO 
THE SOFTWARE OR DOCUMENTATION INCLUDING THEIR QUALITY, PERFORMANCE, MERCHANTABILITY, OR FITNESS FOR 
A PARTICULAR PURPOSE.

7. LIMITATIONS OF LIABILITY: Because software is inherently complex and may not be completely free of errors, you are 
advised to verify your work. IN NO EVENT WILL EXFO, ITS DEALERS, DISTRIBUTORS, RESELLERS, OR THIRD PARTY 
BENEFICIARY, BE LIABLE FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INCLUDING LOST 
PROFITS, DOWNTIME OR DAMAGES TO PROPERTY ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE 
OR DOCUMENTATION, even if advised of the possibility of such damages. THE WARRANTY AND REMEDIES SET FORTH 
ABOVE ARE EXCLUSIVE AND IN LIEU OF ALL OTHERS, ORAL OR WRITTEN, EXPRESS OR IMPLIED. No dealer, distributor, 
agent or employee is authorized to make any modification or addition to this warranty. Some US States or applicable local 
legislation do not allow the exclusion or limitation of implied warranties or limitation of liability for incidental or 
consequential damages, so the above limitation or exclusion may not apply to you.

8. U.S. GOVERNMENT RESTRICTED RIGHTS: The Software and Documentation are provided with RESTRICTED RIGHTS. Use, 
duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of The Rights in 
Technical Data and Computer Software clause at 52.227-7013. EXFO headquarters are located at 400 Godin Avenue, Quebec, 
Quebec, G1M 2K2, Canada. 

9. EXPORT AND IMPORT LAWS: You must comply fully with all applicable export and import laws including, but not limited 
to, export laws and regulations of the United States of America.  No Programs, Products or Software shall be exported, directly 
or indirectly, in violation of laws.

10. THIRD PARTY BENEFICIARY: EXFO may designate, from time to time, any Third Party Beneficiary, with respect to any 
Product or Software, which has duly executed a prior writing agreement with EXFO. Third Party Beneficiaries may include, 
but are not limited to, namely ORACLE, Business Objects, Advance Fiber Optics, and MapInfo. The terms of this Agreement 
also governs any source code that may be provided in some programs by Third Party Beneficiary, such as the one mentioned 
above. This Agreement is not intended to be for the benefit of and shall not be enforceable by any given Third Party 
Beneficiary without a prior written agreement duly executed with EXFO. 

11. GENERAL: This Agreement constitutes the entire agreement between you and EXFO as concerns the subject matter 
hereof and supersedes any prior agreement as to such subject matter. If any provision of this Agreement shall be deemed to 
be invalid, illegal or unenforceable, the validity, legality and enforceability of the remaining portions of this Agreement shall 
not be affected or impaired thereby. This Agreement shall be governed by and construed in accordance with the laws 
applicable in the province of Quebec, Canada without regards to its conflict of laws provisions.

BY USING THE SOFTWARE, YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU UNDERSTAND IT, 
AND YOU AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. 

If you have any questions regarding this Agreement, you may contact the Legal Department at EXFO at (418) 683-0211.
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1 Introducing FastReporter 2
FastReporter 2 is an advanced management, analysis, and reporting tool for 
many types of optical tests, including the following:

 optical loss

 optical return loss (ORL)

 optical time-domain reflectometry (OTDR)

 polarization mode dispersion (PMD)

 chromatic dispersion (CD)

 optical and PON power meters (OPM/PPM)

 fiber inspection probe (FIP)

 intelligent optical link mapper (iOLM)

Note: Depending on the platform you are using, some test modes may not be 
available.
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Introducing FastReporter 2
Available Features
Available Features
There are two application levels: Basic and the advanced version, which 
includes the fiber characterization option (FR2-FC) and the loopback 
option (FR2-LB). Depending on which version you are using, the features in 
the table below are available or not.

Note: A feature with an “*” mark indicates that the modification is allowed for 
single measurements.

Global Features

Feature Basic FR2-FC

Viewing and sorting files or measurements X X

Applying sorting to other windows X X

Saving measurement files* X X

Viewing measurement summary information X X

Managing reports and report templates  X

Using the clipboard  X

Adding and removing measurement files*  X

Managing projects and project templates  X

Editing measurement identification and summary information* X X

Generating reports  X

Matching files  X

Setting a reference file or measurement  X
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Introducing FastReporter 2
Available Features
OTDR

Note: Files coming from older OTDR modules may not be compatible with the 
64-bit version.

Automatically documenting measurement files  X

Using the duplicated measurements tool  X

Exporting data for postprocessing  X

Setting auto refresh in a specific folder  X

Managing files using EXFO Connect  X

Filtering files using the Identifiers Tab X X

Feature Basic FR2-FC

Changing OTDR settings* X X

Setting OTDR event table options X X

Editing OTDR event properties X X

Adding OTDR event with one marker position X X

Adding OTDR event with manually positioned markers X X

Modifying event markers position on existing events X X

Retrieving marker position from file X X

OTDR graphic display options X X

Using the zoom functions X X

Applying an OTDR reference as a template  X

Changing the main measurements  X

Analyzing or reanalyze measurements* X X

Feature Basic FR2-FC
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Introducing FastReporter 2
Available Features
OLTS

Note: Not available for FTB-1. Files earlier than those coming from the MAX-900 
series may not be compatible with the 64-bit version.

Viewing failed measurements only X X

Setting spans position with absolute length* X X

Setting the spans position to modify the IOR value* X X

Changing fiber core size*  X

Creating bidirectional OTDR files  X

Saving an OTDR file in a new file format* X X

Generating text file from OTDR measurement  X

Performing loopback tests (with the FR2-LB option).  X

Creating unidirectional files from a bidirectional file  X

Modifying the space between traces on the graph X X

Generating reports using the OTDR application format. X X

Using the Auto template mode.  X

Feature Basic FR2-FC

Changing OLTS settings X X

Using custom identifiers X X

Changing the fiber type X X

Changing the number of connections in the link definition X X

Changing the number of splices in the link definition X X

Feature Basic FR2-FC
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Introducing FastReporter 2
Available Features
CD

Note: FTB-5800 files are not available for FTB-1.

PMD

Note: FTB-5500 files are not available for FTB-1 or compatible with the 64-bit 
version.

Setting FasTesT pass/fail thresholds X X

Viewing FasTesT results X X

Setting ORL pass/fail thresholds (singlemode only) X X

Viewing power meter result files X X

Feature Basic FR2-FC

Changing CD settings X X

Changing CD fiber type X X

Changing analysis range X X

Changing the fiber length X X

Toggling between curve types X X

Feature Basic FR2-FC

Changing PMD settings X X

Changing fiber length X X

Working with PMD statistic measurements X X

Feature Basic FR2-FC
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Introducing FastReporter 2
Available Features
FIP

OPM/PPM

iOLM

Feature Basic FR2-FC

Setting FIP thresholds table options X X

Setting FIP results table options X X

FIP graphic display options X X

Generating reports using the FIP application format. X X

Feature Basic FR2-FC

Managing power meter results X X

Changing correction factor  X

Feature Basic FR2-FC

Viewing iOLM thresholds X X

Modifying iOLM thresholds  X

Viewing iOLM settings  X

Modifying iOLM settings  X

Modifying identifier labels  X

Adding element  X

Modifying Element Types  X

Deleting Elements  X

Setting Launch Fiber and Receive Fiber on new or existing Element*  X
6 FastReporter 2



Introducing FastReporter 2
Available Features
Analyzing measurements  X

Viewing failed measurements only X X

Generating SOR file from iOLM measurement  X

Creating configuration files  X

Managing power meter results X X

Viewing measurement identification information X X

Creating a bidirectional iOLM file X X

Working with multimode fibers X X

Matching link elements with and without a reference X X

Changing core size  X

Performing loopback tests (with the FR2-LB option).  X

Generating reports using the iOLM application format. X X

Viewing files in FTTx mode  X

Using the Auto template mode.  X

Feature Basic FR2-FC
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Introducing FastReporter 2
Conventions
Conventions
Before using the product described in this guide, you should understand 
the following conventions:

WARNING
Indicates a potentially hazardous situation which, if not avoided, 
could result in death or serious injury. Do not proceed unless you 
understand and meet the required conditions.

CAUTION
Indicates a potentially hazardous situation which, if not avoided, 
may result in minor or moderate injury. Do not proceed unless you 
understand and meet the required conditions.

CAUTION
Indicates a potentially hazardous situation which, if not avoided, 
may result in component damage. Do not proceed unless you 
understand and meet the required conditions.

IMPORTANT
Refers to information about this product you should not overlook.
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2 Getting Started with 
FastReporter 2

If you are using FastReporter 2 on a platform, it is usually pre-installed on 
your unit. If it is not already installed, you can install it yourself through 
Update Manager. Refer to the Update Manager documentation for details.

If you are using FastReporter 2 on a computer, the latter needs to meet 
minimum requirements, depending on which operation system you are 
using:

System 
Element Windows 7 Windows 8.x Windows 10

Processor Pentium

(1.6 GHz or higher)

Pentium

(1 GHz with support 
for PAN, NX, and 

SSE2)

1 GHz

RAM 1 GB (32-bit) or 2 GB 
(64-bit), 4 GB 

recommended

1 GB (32-bit) or 2GB (64-bit), 4 GB 
recommended

Disk Space 8 GB 16 GB (32-bit) or 20 GB (64-bit)

Monitor One super VGA (800 X 
600) monitor

(two 1024 X 768 
monitors 

recommended)

Microsoft DirectX 9 graphics device with WDDM 
driver

Other 
requirements

 Network adapter

 Microsoft Internet Explorer version 8.0 or later

 Microsoft Office 2007 or later to open .xls files
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Getting Started with FastReporter 2
Installing and Uninstalling FastReporter 2 on a Computer
Installing and Uninstalling FastReporter 2 on a 
Computer

The installation wizard will guide you through the installation step by step. 
The application is available in two versions:

 32-bit: Contains all test modes and file formats.

 64-bit: Allows you to process more measurements and reports, but 
older files formats, such as CD and PMD (FTB-5500, FTB-5700 and 
FTB-5800) are not supported.

Note: You can let the wizard install the complete package, or you can select a 
custom installation if you want to skip installing the USB key management 
system.

To install FastReporter 2:

1. Insert the installation DVD in the DVD drive. The installation should start 
automatically. If the installation does not start automatically after 
inserting the DVD, locate the setup.exe application and double-click on 
it to start the process.
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Getting Started with FastReporter 2
Installing FastReporter 2 on an EXFO Platform
2. Click Next to start the installation and follow the on-screen 
instructions. When asked to, select the type of installation you want to 
use.

To uninstall FastReporter 2:

Use the Add/Remove Programs utility in Windows’ Control Panel as you 
would for any other application.

Installing FastReporter 2 on an EXFO Platform
To install your application on any platform other than a standard computer, 
use Update Manager.
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Getting Started with FastReporter 2
Using the Software Customization Wizard
Using the Software Customization Wizard
The Software Customization Wizard helps you to set the application 
according to your needs. For each user, you can change the following 
settings:

 Language

 Field of application

 Supported measurement types

 Distance units

 Additional product information

Note: The Software Customization Wizard is displayed only once when the 
application is started by the current Windows user for the first time.

Note: At any time while configuring the application using the Software 
Customization Wizard, you can apply the default settings by clicking 
Cancel. To apply the changes you have made, click Finish. To return to the 
previous page, click Back.
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Getting Started with FastReporter 2
Using the Software Customization Wizard
To customize the FastReporter 2 application:

1. In the first step, select whether you want to use the default system 
language, or select the desired language from the list, then click Next.

2. As desired, select the field or fields of application you are involved in, 
then click Next.
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Getting Started with FastReporter 2
Using the Software Customization Wizard
3. Select the measurement types that you want the application to 
support, then click Next.

4. Select your preferred unit for displaying distances, then click Next.
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Getting Started with FastReporter 2
Starting FastReporter 2
5. In the case of the PC version, for more details on additional product 
information, technical support, multimedia and training, and EXFO 
blog, click on the required link.

6. Click Finish to apply the changes and go to the main application 
window.

Note: These settings can also be modified in the Tools menu, under Display 
Options.

Starting FastReporter 2
Once installed, all you need to do is double-click the FastReporter 2 
shortcut corresponding to the version you want to use.

Note: You can also access FastReporter 2 through the start menu of Windows, 
under the EXFO folder. The access path differs depending on the operating 
system you are using.
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When you run the application for the first time, the application allows you 
to activate the trial version of the application or basic options of the 
application.

 To activate the trial version, click Start Trial.

 To activate the basic options of the application, click Start 
FastReporter 2.

 To activate the options you have purchased, click Activate Option 
Keys.

Note: For more information to activate the option keys, see Activating the 
FastReporter 2 Software Options on page 18.
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Once the trial period is over, you will have the possibility to renew it for 10 
additional days.

To extend the trial period:

1. On the window that appears when the trial period is over, click Renew 
Trial.

2. Enter your My EXFO account information, then click OK.
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Activating the FastReporter 2 Software 
Options

Some features of the application are grouped and named as FastReporter 2 
Fiber Characterization (FR2-FC) and FastReporter 2 Loopback (FR2-LB). 
They are available only in the complete version of the product, but you can 
use them during the 30-day trial period of the product.

If you wish to continue using the features after the trial period, you must 
activate them using the activation wizard.

Note: To view the options, you have to activate them from the trial window or 
from the Help menu. If the trial period is over, you can also activate the 
options by clicking the required option.

Note: You can view which options are activated for your products in the About 
window of the Help menu.

There are two types of licenses you can obtain for your application:

 Fixed: You have one license for one computer.

 Floating: You have one license that you can use on several computers, 
but on only one at a time. Such a license is contained on a USB dongle 
key. The dongle key also features some storage space for your data.

In the case of a floating license, FastReporter 2, it will verify if a valid dongle 
key is connected, and if so, will continue to validate the presence of said 
key every 10 minutes. If no dongle key is installed, you can only use what is 
available on your unit (for example, no options are enabled, or you revert 
to the trial mode).
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To generate and send the Identification file for a fixed license:

1. From the trial window, click Activate Option Keys.

OR

From the main window, select the Help menu, then Activate Options.

2. Click the Generate and Send Identification File button.
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3. Select which option or options you want to activate.

4. Under Customer Information, enter the required details.

Note: All fields are mandatory.

5. Click Browse to save the file in the desired location.

Note: The identification file name is automatically generated and is not editable.
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6. Click Generate and Send Identification Information. A new e-mail 
window is displayed with the identification information file as an 
attachment. The e-mail displays the information entered in the 
Identification File window and the recipient e-mail address is 
softwarekeys@exfo.com.

Note: If the e-mail software is not configured in your computer, an error message 
is displayed to configure an e-mail option. You can send identification file 
from any other e-mail address with the required details.

To apply the Identification file:

Note: This step is not necessary if you are using floating licenses.

1. From the Product Activation window, click Apply Software Options 
Key.

2. Select the Software key file from the required location and click Open.

3. Your option is now installed. Click Exit to close the window.
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Customizing the Main Window
When you start FastReporter 2, the main window appears. In the graphics 
area of the main window, the application displays the EXFO Web page with 
information related to FastReporter 2.

You can access any other Web page by entering the URL in the address 
bar; you can also select any other website as the default opening page.

For more information, see Changing FastReporter 2 Options on page 28.

Note: FastReporter 2 was meant to be operated to its full potential using a mouse 
and keyboard. Therefore the instructions herein imply that both peripherals 
are connected to your unit.

Note: The appearance of your application may differ from the illustrations in this 
user documentation depending on the resolution and platform you are 
using.

This window can be customized. You can add or remove toolbars, resize 
the panes as needed and move them around, or even auto-hide panes 
when they are not in use and reopen them later for as needed.

Data graph
(available
for some

measurements
only)

Toolbars
Menu bar

Selection 
tabs

Results
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To display the various toolbars and panes:

1. In the main window, select the View menu.

2. Point to Toolbars and select or clear options according to what you 
want to display.

To resize a pane:

Use the split bars enclosing the pane you want to resize.

To close a pane:

Click the X button in the upper right corner.

Note: If you hide a toolbar, you can access the same commands on the menu 
bar.

Split bars
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To move a toolbar:

1. Select the toolbar handle.

2. Click and drag the toolbar to the new location.

To auto-hide a pane or tab:

Click the vertical pushpin ( ) in the upper right corner of the pane.

To show the pane again, move the mouse pointer over the desired hidden 
pane or tab. Select the tab containing its name.

To turn off the auto-hide feature, click the horizontal pushpin ( ).
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To move a pane or tab:

1. Click and hold the selected pane title bar or tab to select it.

Anchor points indicate where the selected item can be moved. The 
purple area represents the item you are currently moving.

2. Drag the item from its current location to the desired anchor point, 
then release the mouse button.
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Working with Two Monitors (PC Version)
If your computer is equipped with two monitors, you can use one of the 
monitors to view the trace files, and the other monitor to view the results or 
the tabs you work most with. For more information on setting two monitors 
on your computer, refer to the instructions provided with your monitors, 
computer and video card.

To move an item to the other monitor:

Drag the item and release it when it appears on the desktop of the 
secondary monitor.

FastReporter 2 will remember the size and position of the window the next 
time you start the application.

Another way of increasing workspace is to open Windows Explorer and 
drag it onto the desktop of the secondary monitor. You can then use the 
FastReporter 2 drag-and-drop feature to add measurement files to your 
projects simply by dragging them into the main FastReporter 2 window and 
releasing the mouse button.
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Selecting Items From Lists and Menus
When selecting items in a list or menu, you can in many cases use the Ctrl 
and Shift keys on your keyboard to make multiple selections, as you would 
in other Windows-based applications.

Also, the same command can often be performed from the Toolbar, the 
menus on top of the window, or by right-clicking into the pane where you 
want to perform an action. For readability reasons, the menu method is 
privileged in the explanations in this user documentation.

Displaying Menu Items on the FTB-1 Platform
By default, the toolbars and some menu items are hidden in the FTB-1 
platform to optimize the screen space. If you want to display them, select 
the View menu, then Toolbars.
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Changing FastReporter 2 Options
You can change the general options including the user interface language, 
field of application and supported measurement types, or the display 
options including date and time formats. You can also narrow down the 
supported measurement types to simplify the user interface.

To change the user interface language:

1. On the Tools menu, click Options.

2. Click the General tab.

3. Select whether you want to use the default system language, or specify 
the desired language in the list.

IMPORTANT
You cannot open files corresponding to a file type that you have not 
selected as supported.
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4. Click Apply to save your change and continue configuring FastReporter 
2 or OK to save your changes and exit the window.

Note: Any changes made to the user interface settings will be applied only when 
you restart the application.

To select the field of application:

1. On the Tools menu, click Options.

2. Click the General tab.

3. Select which fields of application that you want the application to 
support.

4. Click Apply to save your changes and continue configuring 
FastReporter 2 or OK to save your change and exit the window.
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To change supported measurement types:

1. On the Tools menu, click Options.

2. Click the General tab.

3. Select the measurement types that you want the application to 
support.

4. Click Apply to save your change and continue configuring FastReporter 
2 or OK to save your change and exit the window.

Note: Any changes made to supported measurement types will only take effect 
after you exit and restart FastReporter 2.
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To change display options:

1. On the Tools menu, click Options.

2. Click the Display tab.

3. Select the time setting you want to use, either local or universal.
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4. If needed, select Display time difference from GMT / UTC to display 
the difference between local time and GMT (Greenwich Mean Time), 
or UTC (depending on the option you selected in step 3).

5. Select Display a visual clue (*) for manually modified result values 
to easily locate them in the result tables.
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6. If you do not want to see the menu items that are not activated for your 
application, select the corresponding option.

7. Select if you want to be notified of when new versions of your 
application are available (PC version only).
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8. Select your preferred distance unit.
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9. If you want a Web page to appear in the graphic pane, you can enable 
the option here.

When you start the application for first time, this option is enabled and 
the EXFO FastReporter 2 related URL is entered. You can enter another 
URL if you want to view another page.

Note: In the standard toolbar of the application, you can click the  icon to 
switch between the graph view and the Web view. You can access this 
option only if the Display webpage in graphics option is enabled. You can 
use Ctrl+W from the keyboard to switch between the graph view and the 
Web page view.
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10. Select wether you want the links from the graphics pane to open in the 
default browser or in the graphics pane.

11. Click Apply to save your changes and continue configuring 
FastReporter 2 or OK to save your changes and exit the window.

To revert to the default settings, click Default Settings, then OK to apply 
the default settings and exit the window.

Exiting FastReporter 2

Note: If there are unsaved changes to the project or project files, you will be 
prompted to save them when you exit the application.

To exit FastReporter 2:

On the File menu, click Exit.

OR

Click the  in the top right corner of the main window.
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Mode)

Projects are the files that you require in your analysis or post-processing 
activity. You can select one or many files, from different sources, and save 
the project for later consultation.

You can also manage project templates, to help you quicken your work.

Managing Projects
Each time you start FastReporter 2, a project is created automatically using 
the default project template. You can also create a new project from 
scratch.

Once a project is created, you can add files to it, or remove them.

When you save a project in FastReporter 2, the project settings and 
references to the files you added to the project are saved. When you open 
the project file, the project settings you modified and the files you added 
will still be part of the project file, unless you moved or renamed any of the 
files. Any changes to the measurement files themselves, however, are not 
saved in the project file.

To create a project from scratch:

1. On the File menu, point to New, and click Project.

2. In the list, click the template you want to use.

3. Click OK.

4. On the File menu, click Open File.
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5. Select the desired files to include in the project.

6. Click Open to add the files to the project.

7. On the File menu, click Save Project.

8. Click the folder where you want to save the project file.
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9. In the File name box, type a name for the project file.

Note: FastReporter 2 automatically adds the .prj extension to the file name when 
you save the file.

10. Click Save.

To open an existing project:

1. On the File menu, click Open Project.

2. Select and open the folder where your project file is located.

3. Select the project file and click Open.

Note: If your project includes files that come from the EXFO Connect server, you 
will be prompted to either check them out, or view them in read-only mode. 
See Managing Files on page 103 for details.
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To save a project file:

On the File menu, click Save Project.

To save the project file and the measurement files in the project, click 
Save All.

Note: If your project includes files that come from the EXFO Connect server, you 
will be prompted to either check them in, or discard them. See Managing 
Files on page 103 for details.

To save a project file under a new file name:

1. On the File menu, click Save Project As.

2. Type a new file name for the project.

3. Click Save.

To import a Fiber Characterization (FC) project:

1. From the File menu, click Import, then FC Project (settings + files).

2. Select the file you want to import and its original location.
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3. Select the destination where you want to import the file.

4. If you want to delete the file from the original location once the import 
is complete, select the corresponding option.

5. Click Import to confirm your action.

The project is opened as the default project and all of the 
corresponding settings are displayed accordingly.

Note: When you import a project, all of the files included in it are copied to the 
selected location as well.
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To export a Fiber Characterization (FC) project:

1. From the File menu, select Export, then FC Project (settings + files).

2. If needed, enter a name for your project, and select a location.

3. Click Save to confirm your action.

Note: Exporting the project also exports the corresponding project files. The 
default name for the exported project is the name of the project.
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Adding and Removing Measurement Files

A FastReporter 2 project can contain files from different tests, and different 
formats. For more information about the available formats, see the sections 
corresponding to the format you want to use.

To add measurement files to a project:

1. From the File menu, click Open File.

2. If needed, select a desired file type to filter the available choices.

Note: You can set the direction in OTDR and FIP files by selecting the direction 
when you add the files. For example, to set the direction of the selected 
OTDR files to A->B, select OTDR A->B in the Files of type list.
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3. Select the measurement files to add.

4. Click Open to add the selected files to the project.

When you open an OTDR file generated using the iOLM application, or a 
file received from an OTDR manufacturer other than EXFO, a warning 
message appears with the file name, indicating possible limitations or 
consequences. You can choose not to see the message again, if you 
already are aware of those limitations.

Note: When you open any read-only file in the application, it is indicated in the 
Attributes column of the Files tab.

To remove measurement files from a project:

1. In the Files window, select the files you wish to remove.

2. On the Edit menu, click Delete.

3. Confirm your choice by clicking OK.
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Changing General Project Properties

You can provide a descriptive title for a project and identify the author, 
company and customer.

To change general project properties:

1. On the Settings menu, click Project Settings.

2. Under the Identification tab, click in the column to the right of the 
property you want to change and enter the information.

Note: The template file name for the project is displayed automatically according 
to the template you selected when you created the project.

3. Click Apply to apply the changes without closing the dialog box.

4. Click OK to close the Project Settings window.
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Managing Project Templates
You can save the properties and settings you often use when creating 
projects in a project template.

To create a project template:

1. On the File menu, point to New, and click Project.

2. In the list, select a template. If there is an existing template that already 
has properties and settings that you want to use in the new template, 
you can use it as a starting point.

3. Click OK.

4. Change the properties and settings to suit the projects you want to 
create with the new template.

Note: Changes made to the display (for example, showing/hiding windows and 
toolbars using the View menu) or to program options (Options on the 
Tools menu) are saved when you end your work session. They are not 
saved in project templates.

5. On the File menu, click Save Project As Template.
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6. In the File name box, type a name for the project template file.

FastReporter 2 automatically selects the folder where to save the 
project template.

7. Click Save.

IMPORTANT
FastReporter 2 automatically saves project templates in the Project 
Template folder. If you change the location, the template will not be 
available for selection in the New Project dialog box when you start 
a new project.
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To change the default template file:

1. On the File menu, point to New, and click Project.

2. To set the new project template as the default template, click the file 
name, and click Set as Default.

3. Click OK to start a new project or Cancel if you do not wish to start a 
new project at this time.

To rename a project template:

To rename a project template, rename the project template file as you 
would any other file while leaving the .prjt file extension intact. The 
template will be listed on the New Project dialog box with the new name.

To remove a project templates:

To permanently remove a project template, simply delete the project 
template file in the Project Template folder. To remove a project template 
so that it is no longer listed on the New Project dialog box, remove it from 
C:\ProgramData\EXFO\FastReporter  2\Standard\Project Template, and put 
it in another folder.

If you later need to use the template, you can simply move it back to the 
Project Template folder.
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To display the project template name in the application title bar:

1. On the Settings menu, click Project Settings.

2. Under the Identification tab, select the corresponding option at the 
bottom of the identification table.

3. Click Apply to apply the changes without closing the dialog box.

4. Click OK to close the Project Settings window.
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Changing File Direction
Changing the direction for your measurement is useful when you create 
your reports. For OTDR and iOLM test files, changing the file direction can 
be useful to create bidirectional and virtual bidirectional files.

Note: You cannot change the direction on MAX-900 series OLTS files or iOLM FTTx 
files.

To change the direction of the measurement or file:

1. Select the required measurement or file from the Measurement or 
Files window.

Note: You can select multiple measurements change the direction if the direction 
is supported by the measurements.

2. On the File menu, point to Direction, and click A->B or B->A to set the 
direction.
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Matching Files
FastReporter 2 provides three options for matching files in projects:

 File matching based on information present in the file (for example, 
matching fiber IDs and cable IDs). This is the default setting for 
projects.

 File matching based on file name. You can have FastReporter 2 ignore 
expressions in the file names. For example, if you select “A_B” as the 
expression to ignore, a file named fiber1A_B.trc and a file named 
fiber1.trc are considered as matching.

 Manual file matching.

Matching Files Based on Information

Depending on which identifiers you select, the automated matching 
process will look for the corresponding information in your file to pair the 
measurements.

The application allows you to add custom identifiers for iOLM, OPM, and 
PPM measurements. This option is available only if the iOLM, OPM/PPM 
plug-in is selected from Tools > Options.

Note: Only the selected identifiers are displayed in the Measurements window 
and Matched Files window. By default, the custom identifiers added in the 
Identification tab are considered for file matching, even if they are not 
available in the identifiers list under the File Matching window.
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For this type of file matching, the file type is the first priority for each 
measurement and the direction of the file is the second priority. The file 
type priority and the direction priority is listed in the following tables.

Note: The matching function is not case sensitive and will match actual numbers 
(for example, 001 and 1 are both considered as the same number).

File Type Priority

iOLM 1

OTDR 2

FIP 3

OLTS 4

OPM 5

PPM 6

PMD 7

CD 8

Direction Priority

A -> B 1

B -> A 2

Bidir 3

None 4
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To automatically match files based on information:

1. On the Settings menu, click Project settings.

2. Under the File Matching tab, select By information present on file.

3. If you want to perform inverted matching for your iOLM and power 
meter files, select the corresponding option.

IMPORTANT
If you want to perform inverted matching for the iOLM and power 
meter measurements, you must select Support Inverted Identifiers. 
Otherwise, this action will not be possible.
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4. Select the required identifiers type to use them for file matching.

5. To apply the changes without closing the dialog box, click Apply.

6. Click OK to close the Project Settings window.

To add an identifier:

1. On the Settings menu, click Project settings.

2. Under the File Matching tab, click .

3. Enter a name for your identifier.

4. Click OK.
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To delete identifiers:

1. On the Settings menu, click Project settings.

2. Select the required identifiers that you want to delete.

3. Click  to delete the identifiers. The application displays the 
confirmation message to delete the identifiers.

Note: You cannot delete the default identifiers.

Matching Files Based on their File Names

The automated matching based on file name can be optimized by adding 
expressions or terms to ignore, so that the matching is as specific as 
possible.

To automatically match files by file name:

1. On the Settings menu, click Project settings.

2. Click the File Matching tab.
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3. Select By filename.

4. If needed, add or remove items.

 Click , then type the expression to add to the list and click OK.

 Select an expression from the Ignored Expression list, then click 
 to remove it.

5. Click OK to exit the window.
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Matching Files Manually

The manual file matching mode allows you to decide which files to match 
in your list.

To match files manually:

1. On the Settings menu, click Project settings.

2. Click the File Matching tab.

3. Click None (Manual).

4. Click OK.
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5. In the Matched Files window, select a file in the File 1 column and 
drag it into the File 2 column beside the file to match it to.

OR

Click in the File 2 column and click  to display the File Selection 
dialog box, which lists the files that have not yet been matched.

If you attempt to match files manually when one of the two automated 
modes are selected (by information or by file name), FastReporter 2 
will ask if you want to change the matching mode.
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Setting Auto Refresh in a Specific Folder
The auto refresh option updates the Files and Measurement tabs for a 
specified duration whenever you add files to a specified auto refresh folder. 
You can specify the auto refresh folder on your computer, platform, USB 
storage, or network drive.

Note: When the application is running, if the specified auto refresh folder is 
modified or deleted, the application displays a warning message and the 
default folder is selected.

To specify the auto refresh folder:

1. On the Settings menu, click Project Settings.

2. Under the Auto Refresh tab, enable the Auto refresh option.

3. Click  to locate the desired folder.

4. Select the auto refresh duration that suits your needs.

5. Click Apply to apply the changes without closing the dialog box.

6. Click OK to close the Project Settings window.
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Working in Loopback Mode (FR2-LB)
The loopback mode allows you to test both A -> B and B -> A, and 
Tx and Rx at once, which saves time and manipulations. You can set the 
loop length yourself, or let the application find it automatically with a 
default loop length.

This mode is available for both OTDR and iOLM measurement files.

If you have activated the loopback option for your application, it is ready to 
use when needed. You can use the loopback mode that fits your needs:

 Unidirectional: Will split the measurement file into two directions, with 
the corresponding verdict.

 Bidirectional: Will split two unidirectional files set as a virtual 
bidirectional file each their two directions.

Note: Files created using the loopback mode cannot be used again to perform a 
bidirectional loopback, but you can redo a loopback with the unidirectional 
mode result files.

Note: You cannot perform bidirectional loopback tests on iOLM multimode files.
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Performing Unidirectional Loopback 
Measurements

The unidirectional loopback mode is available as soon as you select one 
file. The steps are quite similar for the iOLM and OTDR modes; the iOLM 
steps will be shown here for illustration purposes.

To perform a unidirectional loopback measurement:

1. Select the file or files that will be included in the test.

2. From the Tools menu, select OTDR or iOLM, then Create Loopback 
Unidirectional Files.

3. If needed, rearrange the files in the list. Since they appear in the same 
order as they are in the Files tab, they may not be in the order that you 
need them. You can sort the files using the headers in the table, or you 
can drag the files manually in the list. Once you are done, click Next to 
proceed to the next step.
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4. Set the automated documentation for your resulting files. If you have 
done a loopback operation on them before, you may keep the 
documentation information you had set then by selecting the 
corresponding option.
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If you want to use new information, proceed as follows:

4a. Select which identifiers will be used for the documentation. In 
OTDR mode, you cannot change the identifier types. In iOLM 
mode, you need at least two identifiers, either from the list of 
available choices, or you can enter a new identifier of your 
choice. The first identifier will be the one with the highest 
occurrence rate in the corresponding identifiers of the selected 
files. If no values were set, the first two default identifiers are 
Cable ID and Fiber ID.

Note: You can have four identifiers for OTDR files, and up to five identifiers for 
iOLM files.

To use the identifiers in the file name, select the corresponding 
option.
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4b. Set the value you want to show for each identifier.

 Enter how many digits you want to use to increment the second 
identifier automatically. The numbers will be incremented 
automatically.
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 If you are using identifiers 3 and 4, you can have the application to 
automatically invert them for the second file of the loopback. 
Select the Inverted by Pairs option to use the automatic inversion. 
The Overview page will reflect your choice as follows:

Inverted by Pairs 
Status

Corresponding Locations A and B 
Information

Not selected Row 1: Fiber 0001, Location A, Location B

Row 2: Fiber 0002, Location A, Location B

Row 3: Fiber 0003, Location A, Location B

Row 4: Fiber 0004, Location A, Location B

And so on.

Selected Row 1: Fiber 0001, Location A, Location B

Row 2: Fiber 0002, Location B, Location A

Row 3: Fiber 0003, Location A, Location B

Row 4: Fiber 0004, Location B, Location A

And so on.
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 In the case of identifier 3 for iOLM, you can set a predefined list of 
two or four items to use for each section of the measurement. The 
items must be separated by a semi-colon (for example, “RX;TX”). 
If you are using four items, they must all be different, or inverted 
pairs (“AA;BB;CC;DD” or “AA;BB;BB;AA”). Depending on your 
sequence for identifier 3, the output in the Overview page will 
change.

Identifier 3 Sequence Corresponding Fiber ID and Direction in 
the Overview Page

RX;TX Row 1: Fiber 0001, RX

Row 2: Fiber 0001, TX

Row 3: Fiber 0002, RX

Row 4: Fiber 0002, TX

And so on.

AA;BB;CC;DD Row 1: Fiber 0001, AA

Row 2: Fiber 0001, BB

Row 3: Fiber 0001, CC

Row 4: Fiber 0001, DD

Row 5: Fiber 0002, AA

Row 6: Fiber 0002, BB

Row 7: Fiber 0002, CC

Row 8: Fiber 0002, DD

And so on.
66 FastReporter 2



Working with Projects (FR2-FC Mode)
Working in Loopback Mode (FR2-LB)
 If you are testing iOLM files, you can use a configuration file to set 
the threshold values by enabling the corresponding option. Click 
Select to open the Apply Configuration File window, where you 
can select the desired configuration. Click OK when you are done 
and the selected configuration will be applied.

For more information about configurations files, see Managing 
Configuration Files (FR2-FC Mode) on page 305.

Once you are done, click Next to proceed to the next step.
Post-Processing Software 67



Working with Projects (FR2-FC Mode)
Working in Loopback Mode (FR2-LB)
5. Set how you want the resulting files named.

5a. If desired, change the location where the files will be saved.
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5b. Select which items to use in the file name. If you include the 
measurement direction, select which nomenclature to use 
(AB, BA; BA, AB; RX, TX or TX, RX).
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5c. Select which type of separator you want to use between the 
items. Click Next to proceed to the next step.
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6. In the Overview step, you can see the resulting files. The remaining 
identification and threshold data other than the identifiers will be from 
the original file.

7. Click Next to select the test mode.
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8. Select whether the loop will be automatically detected, or if you want 
to do so manually. If you select the automated mode, enter a length 
value for the loop.
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9. If you are in Manual mode, set the loopback start and end elements:

 Click on the element that you want to use as the start element, 
then click Set Loop Start. The selected elements will bear LS to 
indicate their statuses.

 Click on the element that you want to use as the end element, then 
click Set Loop End. The selected elements will bear LE to indicate 
their statuses.

 If you want to use a section to set the loop start and end values, 
select it, then click Set Loop Section. The loop start and end will 
be placed on the event before and after the section.

Note: If you select an item in the cable view, all of the corresponding items in the 
links are set as loop start or end at once.
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Set loop
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10. If needed, you can change the tolerance levels by clicking the 
corresponding button, and you will be taken to the iOLM or OTDR Set 
Tolerance window to set the new value. Click OK to close the window, 
and the values will be updated accordingly in the Loop Localization 
window.

Note: For more information about setting tolerances, see Setting Event Matching 
Tolerances on page 136.

11. Click Next to proceed to the Summary step.

OTDR

iOLM
Post-Processing Software 75



Working with Projects (FR2-FC Mode)
Working in Loopback Mode (FR2-LB)
12. The result files and their statuses appear in the Summary step. If there 
was something preventing the file from being generated, you can see 
an explanation in the corresponding line.

You can select to keep the original files in your current project by 
selecting the corresponding option at the bottom of the window.

You also have the opportunity to change the tolerance settings in this 
window, as explained in step 10.

If you want to generate a report of your results, click the Report button 
to open the corresponding window.

13. Click OK to complete the loopback process. The resulting files appear 
in the Files tab.

If you have selected to keep the original files in your project, they will 
stay in the Files list. Otherwise, all of the files for which the loopback 
was successfully created will be removed from the list. The resulting 
OTDR loopback files will have the same number of measurements as 
the original files.
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Performing Bidirectional Loopback Measurements

The bidir loopback mode is available when you select at least two files. 
The steps are quite similar for the iOLM and OTDR modes; the iOLM steps 
will be shown here for illustration purposes.

To perform a bidirectional loopback measurement:

1. Select the files that will be paired up.

2. From the Tools menu, select either the iOLM or OTDR menu, then 
select Create Loopback Bidirectional Files.

3. If needed, rearrange the files in the list. Since they appear in the same 
order as they are in the Files tab, they may not be paired as you need 
them. You can sort the files using the headers in the table, or you can 
drag the files manually in the list. Once you are done, click Next to 
proceed to the next step.

If you swap a pair, the application will ask you if you want to 
automatically swap the other pairs in the same way.
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4. Set the automated documentation for your resulting files. If you have 
done a loopback operation on them before, you may keep the 
documentation information you had set then by selecting the 
corresponding option.

If you want to use new information, proceed as follows:

4a. Select which identifiers will be used for the documentation. In 
OTDR mode, you cannot change the identifier types. In iOLM 
mode, you need at least two identifiers, either from the list of 
available choices, or you can enter a new identifier of your 
choice. The first identifier will be the one with the highest 
occurrence rate in the corresponding identifiers of the selected 
files. If no values were set, the first two default identifiers are 
Cable ID and Fiber ID.

Note: You can have four identifiers for OTDR files, and up to five identifiers for 
iOLM files.
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To use the identifiers in the documentation, select the 
corresponding Use in file name option.
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4b. Set the value you want to show for each identifier. Enter also how 
many digits you want to use to increment the second identifier 
automatically. The numbers will be incremented automatically.
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If you are testing iOLM files, you can use a configuration file to set 
the threshold values by enabling the corresponding option. Click 
Select to open the Apply Configuration File window, where you 
can select the desired configuration. Click OK when you are done 
and the selected configuration will be applied.

For more information about configurations files, see Managing 
Configuration Files (FR2-FC Mode) on page 305.

5. Click Next to proceed to the next step.
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6. Set how you want the resulting files named.

6a. If desired, change the location where the files will be saved.
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6b. Select which items to use in the file name.

Note: The Use the measurement wavelength option is available for the OTDR 
files only.
Post-Processing Software 83



Working with Projects (FR2-FC Mode)
Working in Loopback Mode (FR2-LB)
6c. Select which type of separator you want to use between the 
items. Click Next to proceed to the next step.
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7. In the Overview step, you can see the resulting bidirectional files. The 
remaining identification and threshold data other than the identifiers 
will be of the first file in the pair.

Note: In the case of OTDR files, a different file is displayed for each matched 
wavelength.

8. Click Next to select the test mode.

9. Select the perspective from which you want to display the link view 
using the corresponding radio buttons. At this point in the loopback 
process, the bidirectional traces shown are virtual and created from 
two measurements composed of the two links that are not cut yet.

When you select one of the links as the view direction, that link will be 
considered as the A -> B unidirectional trace and the application 
ensures that the resulting unidirectional elements of the selected link is 
correctly aligned. The resulting unidirectional file on the other link will 
however remain uncertain.
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Switching from one view to the other makes sure that you can verify 
that the two resulting unidirectional traces are adequate with perfectly 
aligned elements after the traces are cut. It is important to perform this 
verification before proceeding to the Overview step, where the final 
results are produced and you cannot go back.
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10. Select whether the loop will be automatically detected, or if you want 
to do so manually. If you select the automated mode, enter a length 
value for the loop.

11. If you are in Manual mode, set the loopback start and end elements:

 Click on the element or section that you want to use as the start 
element, then click Set Loop Start. The selected elements will 
bear LS to indicate their statuses.

 Click on the element or section that you want to use as the end 
element, then click Set Loop End. The selected elements will bear 
LE to indicate their statuses.

 If you want to use a section to set the loop start and end values, 
select it, then click Set Loop Section. The loop start and end will 
be placed on the event before and after the section.
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In OTDR mode, you can display the error table at the bottom of the 
window using the corresponding button. This table indicates if there 
are problems with the selected measurement files, and provides 
information about the errors.

Note: If you select the element in the cable view, all of the corresponding 
elements in the links are set as loop start or end at once.
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12. If needed, you can change the tolerance levels by clicking the 
corresponding button, and you will be taken to the iOLM or OTDR Set 
Tolerance window to set the new value. Click OK to close the window, 
and the values will be updated accordingly in the Loop Localization 
window.

Note: For more information about setting tolerances, see Setting Event Matching 
Tolerances on page 136.

OTDR

iOLM
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13. Click Next to proceed to the Summary step.

14. The result files and their statuses appear in the Summary step. If there 
was something preventing the file from being generated, you can see 
an explanation in the corresponding line.

You can select to keep the original files in your current project by 
selecting the corresponding option at the bottom of the window.

You also have the opportunity to change the tolerance settings in this 
window, as explained in step 12.

If you want to generate a report of your results, click the Report button 
to open the corresponding window.
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15. Click OK to complete the loopback process. The resulting files appear 
in the Files tab.

The result files and their statuses appear in the Summary step. If there 
was something preventing the file from being generated, you can see 
an explanation in the corresponding line.

In the case of iOLM files, separate bidirectional files will be created for 
each wavelength with a matching measurement pair.

If you have selected to keep the original files in your project, they will 
stay in the Files list. Otherwise, all of the files for which the loopback 
was successfully created will be removed from the list.
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4 Using EXFO Connect with 
FastReporter 2 (FR2-FC Mode, 
PC Only)

You can use FastReporter 2 conjointly with EXFO Connect to manage your 
files. This active link let you check out the files you need using specific 
search criteria, work on them, then check them in back into your server.

You can also download copies of your files if you want to work on them 
without modifying your source files.

Note: When you log in to the EXFO Connect server for the first time, you will be 
asked to read and accept the licence agreement and change the default 
password to one of your choice. 
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Setting Up the Connection to the Server
You can have the connection to the server done automatically, or you can 
connect manually as needed.

To set up the connection information:

1. From the main window, select the Settings menu, then Project 
Settings.

2. Select the EXFO Connect tab.

3. Under Login, enter the server and identification information to 
connect the application to the server. You can have the application 
remember your credentials and connect automatically to the server for 
quicker access. This connection is automatic for that user only.
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To log in to EXFO Connect:

Use the EXFO Connect menu in the main window

OR

Use the corresponding button in the toolbar ( ).

When you are logged in successfully, you will notice your identifier at the 
top right part of the main window.

To log out of EXFO Connect:

Use the EXFO Connect menu in the main window.

OR

Use the corresponding button in the toolbar ( ).

Using the EXFO Connect Browser
The EXFO Connect browser features the search tools you need to retrieve 
the files required for your analyses. As it is the case for the full EXFO 
Connect application, you can check in and check out files, as well as work 
on copies of your files so as not to compromise your data.

Note: The files you can process with this browser include optical test types only. 
The transport and datacom, or access type files are not available.

Note: The browser included with FastReporter 2 only have limited features. For a 
complete use of the EXFO Connect features and options, use the actual 
application.

You can have the list of files in the server refresh automatically at set 
intervals of time to make sure that you have the latest data to work with.
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To display the browser on-screen:

From the main window, click the corresponding tab on the left part of the 
screen.
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To activate the automatic refresh for the browser:

1. From the main window, select the Settings menu, then Project 
Settings.

2. Select the EXFO Connect tab.

3. Select the Refresh browser automatically option to activate it.

4. Set the desired refresh rate, in minutes. The minimum value is 5 
minutes, and the maximum value is 60 minutes.
Post-Processing Software 97



Using EXFO Connect with FastReporter 2 (FR2-FC Mode, PC Only)
Using the EXFO Connect Browser
Searching for Files in the Browser

You can include different file types in your search, but any advanced search 
on a specific file type has to be done individually.

To search for files in the browser:

1. In the browser window, select which types of files you want to include 
in your search.
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2. Select the period for which you want to perform your search. You can 
select a preset value, or select the Custom range item and enter your 
own value.
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3. If desired, select the business unit or units from where you want to 
retrieve the data. The list of available business units will vary 
depending on which business unit is available on the EXFO Connect 
server.

4. If you want to add additional search criteria, select the corresponding 
file type, then select more details.

Note: The available criteria will change depending on the type you select.

5. Select if you want to show a display view specific to the type of files 
you are listing. This view will give you access to specific columns for 
each type and help you in your search.

Note: You can only show one type of viewer at a time, or use the general view

6. Click Search to start the search.
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Applying Filters to Your Search Results

You can use filters in your browser so as to only see the files you want. Both 
the column of the table and the actual contents of the columns can be 
filtered.

You can also stretch or narrow the column width as needed.

To filter the columns you want to see:

1. In the browser, right-click on the columns.

2. Select which headers you want to display.
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To filter the items in each column:

1. In the browser, click in the column for which you want to use a filter.

2. Select which items you want to view.

3. To perform an even more detailed filter search, you can type a term 
directly in the search box to reduce the list of available choices, and 
click OK.
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Managing Files

Managing the files is achieved through the available actions below:

 Checking out files: allows you to retrieve files from the server where 
they are stored, and perform analyses and modifications on them. 
When files are checked out, they are “reserved” by the user and 
cannot be modified by another user.

 Discarding checked out files: If you change your mind about working 
on some files and want to free them for other users, you can undo your 
check out. Any change done to the files will be lost.

 Checking in files: Once you are done working with the files, you must 
check them back in the server so that other users can consult them. 
Any change done to the files you are checking in is saved into the 
database.

 Uploading files: You can add new files to the server.

 Viewing files: You can get a read-only copy of the files from the server 
for consultation purposes.

 Exporting files: You can obtain a local copy of a file that is not linked 
with the server. This file is writable.

You can perform those actions directly in the browser, or by right-clicking 
in the Files tab, then selecting EXFO Connect.
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To check out files:

1. In the EXFO Connect browser, select which files you want to check 
out. You can select more than one file.

2. From the EXFO Connect menu, select Check Out and Edit.
104 FastReporter 2



Using EXFO Connect with FastReporter 2 (FR2-FC Mode, PC Only)
Using the EXFO Connect Browser
3. Once the check-out operation is complete, click Close to open the 
files.

You can see the progress as the files are downloaded to their local folder. If 
there was a problem with any of the files, you will be notified with an icon 
next to the file and a description of the problem. The selected files are now 
identified as checked out in the browser and are added in the Files tab.
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To undo a check out of your files:

1. In the EXFO Connect browser, select which files for which you want to 
remove the check out. You can select more than one file.

Note: You can only remove a check-out status on files that you have checked out.

2. From the EXFO Connect menu, select Discard Check Out.
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3. Confirm that you want to discard your checked out file from your local 
folder.

You can see the progress as the files are removed from the local folder. If 
there was a problem with any of the files, you will be notified on-screen.
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To check in files:

1. In the EXFO Connect browser, select which files you want to check in. 
You can select more than one file.

Note: To find all of the files with a check-out status, you can use a filter search. 
See Applying Filters to Your Search Results on page 101 for details.

2. From the EXFO Connect menu, select Check In. If your files were 
modified, you will be prompted to save them.
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3. If desired, enter a comment for your check-in.

You can see the progress as the files are uploaded to the server. If there 
was a problem with any of the files, you will be notified on-screen. The 
selected files are removed from the application as they are successfully 
uploaded.
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To upload files:

1. In the Files tab, select which files you want to upload to the server. You 
can select more than one file.

2. From the EXFO Connect menu, select Upload Files.

3. If desired, enter a comment for your upload.
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4. Select which business unit the uploaded files belong to in the list, if 
desired.

5. Click Upload to complete the transfer.

You can see the progress as the files are uploaded to the server. If there 
was a problem with any of the files, you will be notified on-screen. The 
selected files are left in the application.

Note: The files will appear in the EXFO Connect browser the next time the latter is 
refreshed.
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To view files in read-only mode:

1. In the EXFO Connect browser, select which files you want to 
download. You can select more than one file.

2. From the EXFO Connect menu, select View (Read Only).
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3. Once the download operation is complete, click Close to open the 
files.

You can see the progress as the files are copied to their local folder. If there 
was a problem with any of the files, you will be notified on-screen. The 
selected files are now identified as read-only in the browser and are added 
in the Files tab.
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To export a file:

1. In the EXFO Connect browser, select which files you want to copy. You 
can select more than one file.

2. From the EXFO Connect menu, select Export.
114 FastReporter 2



Using EXFO Connect with FastReporter 2 (FR2-FC Mode, PC Only)
Using the EXFO Connect Browser
3. If desired, select a location for your copy.
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4. Click Export to confirm the transfer.

You can see the progress as the files are copied to their local folder. If there 
was a problem with any of the files, you will be notified on-screen. The 
selected files are now identified as read-only in the browser and are added 
in the Files tab.
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5 Working with OTDR Files
The application shows the result of the OTDR analysis in the graph area. 
You can view the OTDR traces in two different manners:

 Graph view: This is the standard OTDR view. You can see the events 
along the trace marked by red vertical lines.

 Linear view: The linear view is a graphical representation of the link, 
where each event is displayed as a box containing the symbol 
corresponding to the event type.
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When you are working with more than one measurements in the Linear 
view, you can also display the Cable view at the top of the list. It shows all 
of the measurements grouped into one link, with the link overview. The 
total number of selected fibers is indicated on the left and each event has 
its own identification number. 

When matched events are of the same type, you can see how many there 
are on the upper left corner of the event icon. If the number is blue, all 
fibers contain this event. If the number is yellow, at least one fiber does not 
have this event. If events at the same position are not of the same type, a 
question mark icon replaces the event type.

Note: When viewing grouped fibers, the Span End event (B) is set according to 
the reference measurement if there is one; if there is no reference 
measurement, it is set according to the shortest fiber. The events located 
between the Span Start and Span End events (including both A and B) are 
numbered.

You can perform the same actions (adding, modifying and deleting events, 
setting span start and end) on single fiber and multiple fibers; the main 
difference is that if you perform the actions on the cable at the top of the 
linear view, all of the included fibers are modified accordingly.
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Total number 
of events
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detected Event ID 
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To select the viewing method:

1. Select the fibers that you want to view together in the Files or 
Measurement tabs.

2. Right-click in the graph area, then select either the Graph or Linear 
view. You can also select the view in the View > OTDR menu.

When you select a trace in either view, the corresponding data is also 
selected in the event table.

Note: When in linear view, the zoom and marker features are not available. 
However, you can add, delete, and change events from the linear view.

To display the Cable view:

Right-click in the linear view area, then select Display Cable View Section. 
You can also select the view in the View > OTDR menu.
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Depending on the file format, you can perform different operations. See 
the table below for details:

Action
EXFO 

Nativea,b 
(.trc, .bdr)

a. The native formats also include FTB-100 version 2.7 (.ftb100) and FTB-300 (.ftb300).
b. The 64-bit version of FastReporter 2 may not support all file formats. To view files that come from older

OTDR modules, save them first in a newer .trc format using the 32-bit version of the application.

Telcordia 
100

EXFO 
(.sor)

Telcordia 
200

EXFO 
(.sor)

Telcordia 
200

EXFO iOLM 
(.sor)

Telcordia 
100 

Non-EXFO 
(.sor)

Telcordia 
200 

Non-EXFO
c,d(.sor)

c. The actions are valid only if the event markers are properly saved. If not, the files are considered as the
same thing as viewing Telcordia 100 Non-EXFO files.

d. Providing that the manufacturer complies with the Bellcore standard.

Changing job 
information (such 
as Fiber ID, Job ID, 
Cable ID, and so 
on)

X X X X X X

Editing events X X X - - X

Inserting events X X X - - X

Deleting events X X X - - X

Managing span X X X - - X

RBS, event 
detection, 
thresholds

X X X - - -

Managing bidir X X X - - X

Managing 
templates

X X X - - X

IOR, Helix X X X - - X

Event Detection 
(reanalysis)

X X X - - -

Pass/Fail thresholds X X X X X X
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Changing OTDR Settings
When viewing your OTDR files, you can change general properties, 
pass/fail thresholds for selected wavelengths, event matching tolerances, 
and automatic file matching rules for the OTDR projects.

Changing General Settings

General options include items such as the pulse baseline, visual settings, 
and event calculation and threshold settings.

To change OTDR general settings:

1. On the Settings menu, select OTDR.

2. Click the General tab.

3. Select if you want the pulse baseline to be based on time or distance.

Note: The pulse baseline distance is always given in meters.
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4. Change the numeric value precision settings for distance and length, 
loss, reflectance, attenuation, or ORL, if desired.

These settings also affect span loss, average loss, average splice loss 
and maximum splice loss.

Note: The numeric precision in the linear view does not apply if the selected units 
are meters or feet.
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5. Indicate whether you want to display the error messages when 
creating virtual bidirectional files. This option will let FastReporter 2 
notify you when a bidirectional file cannot be created, and indicate the 
reason why.
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6. If you want the zoom area and marker positions to be saved in your 
OTDR file, enable the corresponding option. By default, this option is 
not selected.
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7. If you want the event calculations and pass/fail thresholds to be saved 
when they are not included in the original file, select the corresponding 
option. Otherwise, the default values are used.
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8. Select how the events will be matched, either using the position (the 
distance on the fiber), or the event number. The span start is 
considered as event number 1, or the start position.

Note: Some operations, such as delete, add, and add to other measurements are 
not available when the events are matched by number.

9. To apply the changes without closing the dialog box, click Apply. To 
return the general settings back to their original values, click Default 
Settings.
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Changing Pass/Fail Thresholds

You can change the pass/fail threshold values for one, or many 
wavelengths at a time.

You can also change the threshold values for the current measurement.

To change OTDR Pass/Fail Thresholds:

1. On the Settings menu, select OTDR.

2. Click the Pass/Fail Thresholds tab.
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3. Select how you want to set the thresholds:

 If you want to use the threshold values from the measurement file, 
select the corresponding option. However, if you are working with 
older file versions, the threshold values may not be available.

 If you want to use the threshold values from the application, 
proceed as follows:

Select one or several wavelengths to modify.

If you do not see a wavelength, you can add it by clicking the  
button, entering the wavelength value, and clicking OK.

Modify the thresholds associated with the wavelengths needed, by 
clicking in the desired threshold value and modifying it in the table. 
The Apply option must be enabled for the threshold to be active 
and modifiable.

Note: If you are using the fiber attenuation section threshold, you can specify the 
minimum section length at the bottom of the table. This can be useful 
when testing short links, as attenuation measurements on them can be 
unreliable. The fiber section threshold will not be applied to fiber sections 
shorter than the length you have set as a minimum value.
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If you have selected more than one wavelength, all of them will be 
modified at the same time.

Select whether you want to include the span start and end values 
in your threshold calculations.

Note: When the span start and span end values are included, the corresponding 
events are included in the ORL calculation. The span start and end loss 
values, and the span ORL values are updated when the span start and 
span end inclusion settings are modified. The maximum splice loss is also 
impacted by the fact that the span start and end values are included or not.

Note: When span start and span end values are excluded, pass/fail thresholds 
are no longer applied to the corresponding span start or span end events.

4. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the window, click OK.
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Note: If the measurement contains connector loss and splice loss for a merged 
event, the loss value status and measurement status is calculated on the 
basis of the selected thresholds. If thresholds are applied and the status is 
pass, the measurement status is indicated as pass. If thresholds are applied 
and the status is fail, the measurement status is indicated as unknown. If 
none of the thresholds are applied, the measurement status is indicated as 
unknown.

Note: When the span ORL value is preceded by a “<” and the ORL threshold is 
smaller than or equal to the value, the global pass/fail status for the 
measurement will be unknown or fail.

To view and modify a threshold value for the current 
measurement:

1. From the Files or Measurement tab, select the measurement or 
measurements as desired.

The current pass/fail threshold statuses are indicated in the list: green 
for pass, yellow for warning and red for fail.

2. In the Results window, select the Thresholds tab.
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3. If you want to modify a threshold at this point, double-click in the 
corresponding field, and enter the new value.

Note: If you are using the fiber attenuation section threshold, you can specify the 
minimum section length at the bottom of the table. This can be useful 
when testing short links, as attenuation measurements on them can be 
unreliable. The fiber section threshold will not be applied to fiber sections 
shorter than the length you have set as a minimum value.

Note: If there are more than one threshold value for a given wavelength, they are 
separated by a semicolon.
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4. If you are using the application’s event calculations and thresholds, you 
can also select whether you want to include the span start and end 
values.

Note: Some threshold values may not be available for older file versions.
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Setting Macrobend Tolerances

FastReporter 2 can locate macrobends by comparing the loss of events 
occurring at a certain wavelength (for example, 1310 nm) with the loss of 
the corresponding events at a greater wavelength (for example, 1550 nm).

FastReporter 2 will identify a macrobend when comparing two events if:

 Of the two events, the greater loss occurred at the greater wavelength.

AND

 The difference between the loss of two events exceed the defined 
delta loss value. The default delta loss value is 0.5 dB (which is suitable 
for most fibers), but you can modify it.

Changes made to event matching tolerances will affect macrobends.

To set macrobend tolerances:

1. On the Settings menu, select OTDR.

2. Click the Tolerances tab.
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3. Under Macrobend tolerances, change the tolerance value for 
wavelength pairs as needed.

 To add a wavelength pair, click the  button, enter the 
wavelength values, and click OK.

 To remove unwanted pairs, select the values in the Wavelength 
Pair list, and click the  button.

Note: If you select more than one wavelength in the list, any modification to the 
thresholds will apply to all of the selected wavelengths.

Note: To remove all added wavelength pairs and set all tolerance values back to 
their original settings, click Default Settings.

4. Click OK to exit the window.
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To view macrobends:

From the main window, make sure that the macrobends are displayed in 
the event table: on the View menu, select OTDR, select Event Table, and 
click Macrobends.

Macrobends are identified in the OTDR Event Table by the following 
symbol: .

In the case where you have multiple files with a single wavelength (this 
often occurs for Telcordia type files), you must first match those files in 
order to see the possible macrobends in the Matched Files tab, then select 
these matched files to view the macrobends in the event table.
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Setting Event Matching Tolerances

The OTDR Event Table is built by matching events from selected 
measurements according to the tolerance. To be matched, the distance 
between events from the different measurements must be within the 
tolerance.

You can force the matching of two events or separate them by changing 
the event matching tolerance accordingly. The tolerance is applied to all 
operations related to the event table including apply reference as template 
and macrobends.

ToleranceTolerance
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Although you can set the event matching tolerance to as little as 20 meters 
for each pulse width, the results may differ due to cursor aliasing. Cursor 
aliasing checks if markers A and B for two events overlap. These markers 
are set during analysis. Marker A represents the beginning of a measured 
event while marker B represents its end.

This means that two events could be matched in the event table even if 
their markers A are farther apart than the tolerance if there is an overlap 
between the spans created by their markers A and B. Cursor aliasing 
becomes more important with larger pulse widths since these traces have 
greater A-B spans.

To change OTDR event matching tolerances:

1. On the Settings menu, select OTDR.

2. Click the Tolerances tab.
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3. Under Event matching tolerances, change the tolerance value for 
pulses as needed.

 To add a pulse, click the  button, enter the pulse value, and click 
OK.

 To remove unwanted pulses, select the values in the Pulse list, and 
click the  button.

Note: If you select more than one pulse in the list, any modification to the 
thresholds will apply to all of the selected pulses.

Note: To remove all added pulses and set all tolerance values back to their 
original settings, click Default Settings.

4. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the dialog box, click OK.

See Setting Macrobend Tolerances on page 133 for instructions on using 
the Macrobend tolerances section on the Tolerances tab.
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Using the Auto Template (FR2-FC Mode)
The auto template lets you add and remove events on links based on their 
occurrence on the total group of selected links. You can set a percentage 
value that will indicate whether an event should be added or removed. The 
auto template is particularly useful for obtaining uniformity when testing 
many traces on a same fiber.

Once the auto template is used, you can analyze the results; if there are 
issues with some of the elements, you can view them in a descriptive 
summary.

To enable and use the auto template in your project:

1. On the Settings menu, select OTDR.

2. Click the Auto Template tab.

3. Enable the option to be able to set the preferences.
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4. If you want to add events, select the corresponding option and enter 
the minimum percentage value of occurrences required to add the 
event to the remaining links.

5. If you want to remove events, select the corresponding option and 
enter the percentage value of occurrences under which the event must 
fall to be remove it from the measurement.

6. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the window, click OK.
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To apply auto template settings to the current measurements:

1. Open the measurements you want to include in the auto template 
operation.

2. From the Measurement menu, select OTDR, then Event and Auto 
Template.

3. If you want to add events, select the corresponding option and enter 
the minimum value of occurrences required to add the event to the 
remaining links.

4. If you want to remove events, select the corresponding option and 
enter the value of occurrences under which the event must fall to be 
remove it from the measurement.

5. Click OK to confirm your choice and start the operation.

Note: The values modified in the window will not be kept for future applications 
of the auto template. They are for the current measurements only.
Post-Processing Software 141



Working with OTDR Files
Using the Auto Template (FR2-FC Mode)
The events will be added or deleted according to the Auto template 
settings. The results will be updated in the Event Table. If some issues 
occur during the process, a summary will indicate which event is 
concerned.
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Managing the OTDR Event Table View
The OTDR event table can be customized to show only the items that are 
relevant for your tests. The items you can display or hide include the 
following:

 Fiber ID

 Fiber Pass/Fail Status

 Wavelength

 Direction

 Event

 Section

 Event Loss

 Event/Section statistics

 Fiber statistics

 Bidir. details (direction, average)

 Reflectance

 Merge details
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 Macrobends

 Event position

 Span start/end events

 B -> A position from B (if the bidir details and event position are 
displayed in the window, this will display the event positions according 
to B, for example, the last event will be identified as the first event).

 Display the event type as text or as an image

 Section loss

 Attenuation

 Section length

 Values relative to the reference file

OTDR events can be edited if the file format supports modification.
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To customize the Event Table view:

1. On the View menu, select OTDR, then Event Table.

2. Select or clear any of the event or segment views as desired.

Note: You can also select the items by right-clicking into the event table itself. The 
available items depend on where you click in the table.

To edit OTDR events:

1. From the main window, select the Event Table tab in the Results 
window.

2. In the Event or Section column, click the right mouse button.

3. On the shortcut menu, click any of the following edit options:

Edit Option Description

Delete Displays a dialog box to confirm deletion of the 
selected event. Click Yes to delete or No to 
cancel. An event can be deleted only if the file 
format supports modification. You cannot delete 
the Span Start event if it is the same as the 
Launch level and you cannot delete the Span 
End event if it is also the End of fiber, End of 
analysis or if it is a Continuous fiber (no End of 
fiber event).

Set as Span Start Sets the selected event as the span start.

Set as Span End Sets the selected event as the span end..

Add to other 
measurements

Adds the selected event to other selected OTDR 
measurements. An event can be added to other 
measurements only if the file format supports 
modification.

Properties Displays the OTDR Event Properties dialog box, 
where you can edit properties for the selected 
events or sections.
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These edit options, with the exception of Delete, are also available on the 
Measurement menu (select OTDR, then Event). The Delete option is 
available on the Edit menu. The actions can be performed regardless of 
the direction.

You can edit the properties for OTDR events and sections. Event properties 
that cannot be edited are shaded.

To edit OTDR event properties:

1. In the Measurements window, select an OTDR measurement file.

2. In the Event table, select the events or sections to modify.
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3. On the Measurement menu, select OTDR, select Event, and click 
Properties.

4. Modify the properties as needed. The editable values are shown in a 
white background.

 You can change the event type from the list of available choices.

 To add information about the event, type in a comment in the 
corresponding location.

Note: The comment that you enter in the Comments field is displayed as a tooltip 
when you hover the mouse pointer over the event in the graph area and 
event table.

5. Click OK to confirm your changes.
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Changing the Main Measurement
FastReporter 2 allows you to select which wavelength is the main 
measurement for your files.

To change the main measurement:

1. In the Files window, select the file for which you want to change the 
measurement.

2. On the Measurement menu, click on Main.
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3. In the Main Measurement Selection window, select the required 
wavelength and click OK to set it as the main measurement.

Note: When you hover the mouse pointer over the selection area of a trace which 
is not the main measurement, a tooltip with the fiber ID and measurement 
wavelength is displayed.
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Setting the OTDR Graphic Display Options
You can change the display of graphics for OTDR measurements.

To change OTDR graphic display options:

1. On the View menu, select OTDR to display the OTDR graphic display 
options.

2. Select or clear any of the following OTDR graphic display options:

 Outside Spans to display or hide information outside the 
measurement spans on the graph, when the zoom level is set to 
100 % (1:1).

 Markers to display or hide markers on the graph.

 Invert B->A dB Axis to invert B to A along the dB axis on the 
graph.

Viewing Section Length for the Linear View
When in linear view, the application displays the section length between 
the events. You can also choose to hide it.

To view or hide the section length:

1. Select the Linear view for your files.

2. Right-click on the a link and select View Section Length.
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Using the Zoom Functions
Various zoom options can help you to view specific portion of the graph 
window.

To select the OTDR zoom options:

1. On the View menu, select Zoom to display the OTDR zoom options.

2. Select one of the following OTDR zoom options:

Icon Description  Shortcuts

100 % (1:1) to display the full graph for the 
measurement (default setting).

Ctrl + Home

Horizontal zoom to zoom and view the graph 
horizontally. You can do the horizontal zoom in 
the following ways.

 Press Ctrl + Alt, then scroll the mouse wheel 
forward or backward.

 Press Ctrl + Alt and drag the mouse over the 
part of the graph that you want to magnify, 
forming a rectangle. When you release the 
mouse button, the new zoomed area 
corresponds to the rectangle size and 
position.

Note: If you press Ctrl + Alt but do not 
select a rectangle size, the graph is 
zoomed by a 2X factor. 

Ctrl + Alt
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Vertical zoom to zoom and view the graph 
vertically.

 Press Ctrl + Shift, then scroll the mouse 
wheel forward or backward.

 Press Ctrl + Shift and drag the mouse over 
the part of the graph that you want to 
magnify, forming a rectangle. When you 
release the mouse button, the new zoomed 
area corresponds to the rectangle size and 
position.

Note: If you press Ctrl + Shift but do not 
select a rectangle size, the graph is 
zoomed by a 2X factor. 

 Ctrl + Shift

Horizontal + vertical zoom to zoom and view the 
horizontal as well as vertical details of the graph 
for the selected measurement.

 Pres Ctrl, then scroll the mouse wheel 
forward or backward.

 Press Ctrl and drag the mouse over the part 
of the graph that you want to magnify, 
forming a rectangle. When you release the 
mouse button, the new zoomed area 
corresponds to the rectangle size and 
position.

Note: If you press Ctrl but do not select a 
rectangle size, the graph is zoomed 
by a 2X factor.

Ctrl

Selected event from file to zoom to a selected 
event saved in the file, if present, auto zoom 
(event splice level) is applied.

None

Icon Description  Shortcuts
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Manual zoom from file to manually zoom using 
the information saved in the file. Once this 
option is selected, it displays the saved zoomed 
area even if you change the measurement 
selection.

None

Undo last zoom operation. None

Auto-zoom on Event Splice None

Auto-zoom on Event Reflectance None

Auto-zoom on the 4 markers to focus where the 
analysis was used to calculate the event loss. 
Submarkers a and b are placed where the 
analysis was used to calculate the event loss, 
and markers A and B are placed where the 
analysis was used to calculate the event section 
loss

None

Icon Description  Shortcuts
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Managing Markers
FastReporter 2 allows you to set four markers (A, a, B, and b) for manual 
measurement purposes. You can move the markers independently, or you 
can also lock or unlock the distance between the four markers and move 
them as a block. You can lock or unlock the distance between the A and a 
marker pair, as well as the B and b marker pair and move them. Below you 
can see the list of the lock options.

 Lock All: All the markers are locked and can be moved as a group.

 Lock a,A: The distance between marker a and A are locked and can be 
moved as a group.

 Lock b,B: The distance between ‘b’ and ‘B’ are locked and can be 
moved as a group.

Note: By default, the markers are activated. If you have deactivated them, they 
can be reactivated from the View menu, then OTDR > Markers.

To lock and unlock the marker position:

On the Measurement menu, from the OTDR option, select Markers then 
click on the required lock option.

Note: When none of the markers are in a locked mode, you can temporarily lock 
the distance between all markers and move them as a block by pressing 
the Shift key on the keyboard and dragging them around with your mouse.

To modify the marker position:

Select the marker from the graph area and drag it to the desired position to 
modify the marker position.

OR

Select the marker from the graph area and move the marker by scrolling 
the mouse wheel forward and backward.

OR
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Modify the marker position in the Markers table by entering a new marker 
position value direct input from the keyboard.

OR

Select the required marker(s) and move the selected marker(s) by clicking 
the left and right arrow keys of the keyboard.

Note: You can select the next visible marker by pressing the Ctrl + Tab keys.
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Performing Manual Measurements with Markers

The information related to the markers is displayed in the Markers and 
Manual measurement table under the Markers tab.

To display and hide the marker-related features:

The Manual Measurement table displays the information related to the 
markers, including their label. Right-click on the Manual Measurement 
table to select the required value option.
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Various options of the Manual Measurement table are described below.

Option Description

4 points 
event loss

In the 4 points event loss, four markers (a, A, b, and B) are visible. This 
least square approximation method is used to fit a straight line to the 
backscatter data within the two regions defined by markers a, A and b, 
B, that is over the regions to the left and to the right of the event 
bordered by markers A and B, respectively.

A-B LSA loss This loss of event bordered by the markers A and B is obtained by fitting 
a straight line to the backscatter data between these two markers. 

2 points 
section 
attenuation

In the 2 points section attenuation, two markers (A and B) are visible. 
This measurement gives the reduction in Rayleigh backscatter level as 
a function of distance (always expressed in dB/km to follow the 
standards of the fiber-optic industry) between two selected points. 
Only those two points are used to perform the calculation and there is 
no averaging. 

A-B LSA 
attenuation

This LSA attenuation is obtained by fitting a straight line between two 
points in the backscatter data between markers A and B. 

A-B ORL This displays the ORL between markers A and B. 

3 points 
reflectance

In the 3 points reflectance, three markers (a, A, and B) are visible. This 
measurement displays the reflectance pointed by marker a, A, and B.

3 points 
maximum 
reflectance

This measurement displays maximum reflectance for the selected 
event.
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Adding an OTDR Event with one Marker

FastReporter 2 allows you to add a new OTDR event according to the 
position of marker A. It automatically repositions the markers other than A 
at the best position to characterize the most probable event in the area. It 
automatically selects the appropriate event type according to the 
measurement characteristics such as reflective event, non-reflective event, 
or positive event.

To add an OTDR event with one marker:

1. On the graph, place marker A where you want to add an event.

2. On the Measurement menu, from the OTDR option, select Event then 
click Add Event with Marker A.

Note: You cannot perform this operation if the origin of the selected file does not 
allow modifications. For example, you cannot perform this operation on 
“Telcordia 100" files from other OTDR manufacturers.

Note: You cannot add an event using marker A on bidirectional OTDR files.

Note: The manually modified events are displayed with an asterisk (*) mark. For 
more information on changing display options, see Changing FastReporter 
2 Options on page 28.
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Adding an OTDR Event with all Markers

The application allows you to add a new OTDR event according to the 
position of all the markers. It selects the most appropriate event type 
according to the measurement characteristics such as reflective event, 
non-reflective event, or positive event.

To add an OTDR event with all markers:

1. On the graph, place all of the markers where you want to add an event.

2. On the Measurement menu, from the OTDR option, select Event, then 
click Add Event with All Markers.

Note: You cannot perform this operation if the origin of the selected file does not 
allow modifications. For example, you cannot perform this operation on 
“Telcordia 100" files from other OTDR manufacturers.

Note: You cannot add an event using all markers on bidirectional OTDR files.
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When an event cannot be created in the specified position, an error 
message is displayed. You cannot create any event in following conditions:

 If the marker from any event is present in between markers A and B.

For example: In the below image the gray markers indicate the position 
of the earlier event and the blue lines indicate the position where you 
are trying to add new event. In this condition the application displays 
an error message, to indicate that you cannot insert new event.

Markers of the
earlier event

Markers of the
new event
160 FastReporter 2



Working with OTDR Files
Managing Markers
 If any event is present between two markers.

For example: In the below image, the blue lines indicate the position of 
the marker for the new event which you are trying to add. Event 3 is 
shown between these two markers. In this condition the application 
displays an error message, to indicate that you cannot insert new 
event.

Note: The manually modified events are displayed with an asterisk (*) mark. For 
more information on changing display options, see Changing FastReporter 
2 Options on page 28.
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Modifying Event Marker Positions on Existing 
Events

FastReporter 2 allows you to reposition the existing events.

To modify the event markers position on an existing event:

1. On the graph, select the event for which you want to modify the 
marker position.

2. On the Measurement menu, from the OTDR option, select Event, then 
click Modify Event Markers.

3. Modify the marker position from the graph window.

Note: When the event marker repositioning operation is initiated, the four 
manual markers position are set to match the selected events own 
markers. Once the event marker’s new position is confirmed, then all the 
information related to the event is updated.
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4. Press Enter to confirm the repositioning or Esc to cancel the process.

Note: If marker repositioning is not possible in the particular position, a 
notification message is displayed.

Note: You cannot perform this operation if the origin of the selected file does not 
allow modifications. For example, you cannot perform this operation on 
“Telcordia 100" files from other OTDR manufacturers.

Note: You cannot modify event markers on bidirectional OTDR files.

Note: The manually modified events are displayed with an asterisk (*) mark. For 
more information on changing display options, see Changing FastReporter 
2 Options on page 28.
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Adding Event to Other Measurements

The application allows you to add the event position of the selected OTDR 
or bidirectional OTDR measurement to other selected measurements.

Note: You can add the event position in both actual and virtual bidirectional 
OTDR measurements.

Note: An event can be added to other measurements only if the file format 
supports modification.

To add event to other measurements:

1. On the graph, right-click on the event which you want to add on other 
measurements.

OR

In the Event Table tab, right-click on the event.

2. Select Add to Other Measurements. The selected event will be added 
to other selected measurements.
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Retrieving Marker Position from File

The application allows you to retrieve the marker position to the original 
values when the file was last opened or saved.

To retrieve the marker position from file:

1. On the Measurements window select the required measurement.

2. On the Measurement menu, from the OTDR option, select Marker 
then Markers From File.

Note: If there are no marker positions for the measurements, the application sets 
the marker position with a spacing value of 1/5 of the span length.
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Setting and Applying OTDR/OTDR Bidir 
Reference as Template (FR2-FC Mode)

The Apply Reference as Template tool allows you to analyze 
measurements and compare them to a reference file. The template 
concept is to set a reference file (template), add comments about the 
events, and compare each measurement to the reference file. FastReporter 
2 will mark and measure any missing event. Inserted events are indicated 
by an asterisk (*). Event matching tolerances will affect template results. 
Events not present in the reference appear as white columns. Comments 
for events in the reference file are automatically copied to the selected 
files.

Note: The measurement file format must support this feature.

Note: DWDM OTDR files cannot be used to set a reference as a template.

Singlemode measurements will be compared to singlemode 
measurements; multimode measurements will be compared to 
multimode measurements.

The measurement files must meet the following criteria:

 It must have at least two events.

 It must have a span start and a span end.

 It must have a fiber section.
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To set and apply OTDR and bidirectional OTDR files as a reference 
template:

1. In the Files tab, select the OTDR or bidirectional OTDR file that you 
want to use as the reference.

2. In the Files tab, select the OTDR file that will serve as the reference.

3. On the File menu, click Set as Reference File.

Note: You can also set the virtual OTDR bidirectional file as reference from the 
Measurements tab and Event Table.
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4. In the Files window, select the OTDR files to which you want to apply 
the reference file as a template.

5. On the Tools menu, point to OTDR, and click Apply Reference as 
Template.
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6. Set the parameters for the OTDR template.

 Use same wavelength for all measurements: to apply the same 
wavelength to all measurements. If a file with multiple wavelength 
files is used as a reference and the option is not selected, the 
measurements will be compared to the same wavelength 
(1310 nm with 1310 nm, 1550 nm with 1550 nm).

 Remove events not present in reference: to remove the events 
not present in the reference file from the selected files.

 Apply reference spans start/end: to apply the reference 
measurement’s spans to the selected files.

 Apply reference event types: to apply the events between the 
span start and span end events. This option is active for the current 
working session only and will be reset when the application is 
started again.

 Apply manual measurement markers and zoomed area: to apply 
the reference’s marker position and zoom to the selected files. If 
the marker positions is outside the range of the trace destination, 
the operation will be aborted and the destination trace keeps its 
original zoom factor.
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 Copy documentation from reference (except Fiber ID): to 
include all of the available documentation to the selected files. The 
fiber ID will not be copied.

 Copy reference event markers (a,A,B,b) position: to apply the 
reference file markers to the selected files.

Note: You are notified when the zoom is not applied.

Note: This option is available only if the Markers option is enabled from View > 
OTDR > Markers.

 Copy documentation from reference (except Fiber ID): to apply 
the documentation from the reference file to the selected files. The 
documentation includes job ID, customer, company, operator A, 
operator B, cable ID, location A, location B, and comments.

 Copy reference events markers (a,A,B,b) position: to copy the 
events markers (a, A, B, b) from the reference measurement to the 
selected files.

Note: When an event marker position from the reference measurement cannot 
be copied to the selected measurement due to length constrain or any other 
reason, the application does not display any error message.

7. Click OK.
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Analyzing Measurements
FastReporter 2 lets you analyze the unidirectional and bidirectional OTDR 
measurements at any time.

The bidirectional measurements are reanalyzed when A->B or B->A 
measurements are reanalyzed, and in case of the following modifications:

 Event addition

 Event deletion

 Change in event type

 Change in span start position

 Change in span end position

 IOR

 Helix Factor

 Splice Loss Threshold

 Reflectance Threshold

 End-of-Fiber Threshold

Analyzing measurements will:

 analyze measurements acquired from different sources or with other 
products.

 recreate the original event table if it was modified.

 reset the span start to zero and the span end to end-of-fiber, if desired.
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To analyze measurements:

1. In the Measurements tab, select the measurements to analyze.

Note: You can analyze the multiple measurements of the unidirectional and 
bidirectional OTDR file, only if the FR2-FC option or trial option is activated 
in the application.

2. On the Measurement menu, select OTDR, and click Analyze.

3. Select wether you want to keep the span start and end positions, or if 
you want to reset them to zero.

4. Click OK.

Once the analysis is performed, the window is refreshed automatically. 
Information such as IOR, Helix factor, splice loss threshold, reflectance 
threshold, end-of-fiber threshold are analyzed.

Note: A->B and B->A are re-analyzed when a real bidirectional file is 
re-analyzed.

Using the Failed Items Filter
In order to quickly see which events are faulty, you can apply a specific 
filter to show only the failed items.

To activate the failed item filter:

In the Event Table tab, right-click in the table, then select View Failed 
Items.
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Displaying Statistics for Measurements
When displaying matched measurements, it might be useful to view 
statistics for them. The statistics are displayed for:

 Fibers (includes loss for splices, connectors and sections, reflectance 
for connectors, and attenuation data for sections), which are displayed 
on the far right of the Events Table tab.

 Events and Sections (includes event position, loss and reflectance, 
section length, loss and attenuation), which are displayed at the 
bottom of the Events Table tab.

The statistics displayed are the minimum value, the maximum value, and 
an average for the selected files. If you click on the minimum and 
maximum values, the corresponding event is highlighted in the Graph or 
Linear views, and in the events table.

Note: You must have enabled the corresponding item for the statistic to appear. 
For example, if you chose not to display the positions, the corresponding 
statistic is also hidden.

To display the statistics:

1. Select the multiple measurements for which you want to view the 
statistics.

2. In the Events Table tab, right-click in one of the fixed columns, and 
select the type of statistics you want to view.
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Setting Span Positions with Absolute Lengths
The application allows you to set the span start and span end positions 
using definite values.

To set the span positions:

1. In the Measurements window, select the measurements for which you 
want to set the span.

2. On the Measurement menu, click OTDR and select Set Spans by 
Distance.

3. Set the launch fiber length as required. Once you set the launch fiber 
length, the application updates the span start position and span length 
value based on the new position of the span start. If no event is present 
at the new position of the span start, it automatically creates a new 
event.
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4. Select whether you want to enter the span length or the receive fiber 
length, then enter the appropriate value. The other value is updated 
automatically according to the value you have entered. If no event is 
present at the new position of the span end then, it automatically 
creates a new event.

5. Click OK to save the change or Cancel to discard it.

Note: When a new event is created, the exact event position, event type, and 
measured values are automatically determined to have the best 
characterization for the most probable event present in the area. When a 
new event is successfully created, the event is marked with an asterisk (*).

Note: If the origin of the selected file origin does not allow modification, an error 
message is displayed.
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Setting the IOR Value by Distance
The application allows you to modify the IOR value for each selected 
measurement by modifying the distance from span start to span end.

To modify the IOR value:

1. On the Measurements tab select the measurements you want to 
modify.

2. On the Measurement menu, click on OTDR and select Set IOR by 
Distance.

3. Enter the distance of span start to span end.

Note: When the distance values from the selected measurements are not the 
same, the values are displayed with a semicolon. Once the new IOR values 
are calculated, the values related to the position and distance and the 
OTDR graph are updated.

4. Click OK to save the changes or Cancel to discard them.
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Changing Fiber Core Size (FR2-FC Mode)
The FastReporter 2 application displays the core size of the fiber for the 
selected measurement in the Test Settings table of the Summary tab. 
When multiple measurements are selected and the fiber core sizes are not 
similar, they are separated with a semicolon.

Note: The application allows you to change the fiber core size only for the 
multimode files.

To change the fiber core size:

1. On the Measurements tab, select the multimode measurement for 
which you want to modify the fiber core size.

2. From the Summary tab, select the required fiber core size in the list of 
available values.

3. The application prompts you to confirm the change. Click Yes to set the 
default values for result and test settings. If you click No, the fiber core 
size value changes, but the default values are not applied for result and 
test settings.

Note: You cannot perform this operation if the origin of the selected file does not 
allow modifications. For example, you cannot perform this operation on 
“Telcordia 100" files from other OTDR manufacturers.
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Reverting to File Test Settings
The application allows you to revert the test settings parameters values to 
the file original values. The retrieved values are IOR, backscatter, Helix 
factor, splice loss threshold, reflectance threshold, end-of-fiber threshold 
and fiber core size. The result values are automatically updated to reflect 
the change.

Note: You can revert to file test settings for multiple files only if the FR2-FC option 
is activated.

Note: You cannot use this feature when you open a competitor’s .SOR files and 
iOLM generated .SOR files.

To revert to file test settings:

1. On the Files tab select the OTDR files you want to modify.

2. From the Summary tab, click the Revert to File Test Settings button, 
then confirm your choice.
178 FastReporter 2



Working with OTDR Files
Managing Bidirectional OTDR Files (FR2-FC Mode)
Managing Bidirectional OTDR Files (FR2-FC 
Mode)

FastReporter 2 can be used to analyze bidirectional OTDR files, and create 
them using unidirectional files and combining them.

Analyzing Bidirectional Measurements

If two OTDR measurements were acquired in opposite directions on the 
same fiber span, you can use the Create Bidirectional Files tool to match 
the corresponding events. FastReporter 2 performs a bidirectional analysis 
and generates an event table with the averaged loss for each event; that is, 
the average of the losses obtained from both directions.

Bidirectional analysis is the recommended method for splice loss 
measurements on singlemode fibers by the Telecommunications Industry 
Association (test procedure EIA/TIA FOTP-61 Measurement of Fiber or 
Cable Attenuation Using an OTDR).

This method removes the so-called “gainers” (increase in the optical 
power) and exaggerated losses and provides accurate measurements. This 
analysis is particularly useful to test the quality of a link, especially if it 
comprises several sections with different types of fibers or fiber from 
different manufacturers.

Gainers and exaggerated losses result from the joining of two fibers of 
different mode-field diameters (MFD). The mode-field diameter of a fiber 
corresponds to the size of the area where light is dispersed across its core 
and cladding.

Mismatch of MFDs will contribute to differences in backreflected signals 
that are not related to the loss at the splice point, that is to the true loss 
seen in transmission. In this case, a unidirectional OTDR measurement will 
show an apparent increase (gainer) or decrease (exaggerated loss) in 
signal, depending on the direction of measurement.

Bidirectional averaging of OTDR splice loss measurements provides the 
most accurate splice loss results.
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Creating Bidirectional Measurement Files

You can combine unidirectional measurements into a bidirectional 
measurement file. It is possible to use both single-wavelength and 
multiwavelength measurements. FastReporter 2 matches the wavelengths.

The A->B and B->A measurement files must respect the following criteria:

To create bidirectional files in FastReporter 2, you must first match A->B 
files with B->A files. For information on file matching, see Matching Files 
on page 51. Changes made to event matching tolerances will affect 
bidirectional event table results.

Item To be valid

Pulse width Must be identical for both measurement files.

Fiber types Use only measurements acquired using 
singlemode fibers.

Wavelengths Must be identical for both measurements.

Measurement file Both must be unidirectional files.
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To create a bidirectional file:

1. Select two matched OTDR files of opposite directions.

2. Click on Tools > OTDR > Create Bidirectional Files.

3. Select the location where you want to save the bidirectional file.

4. Select the desired file naming options.

 Select A->B filename or B->A filename to use the selected A->B 
or B->A file name.

 Select Autonaming to enter a prefix and a suffix to create the file 
name.
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5. Select which documentation will be used for the bidirectional 
measurement.

6. Select whether you want to keep the original unidirectional files in your 
project once the bidirectional files are created.

7. Click OK.

Note: Bidirectional (.bdr) files do not support multiple wavelengths in the same 
file. When you save the bidirectional files, separate files will be created for 
each wavelength. The wavelengths are automatically added.
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Creating Unidirectional Files From a Bidirectional 
File

Using FastReporter 2, you can take a bidirectional file and extract the two 
unidirectional files that were originally used to create it. The resulting files 
will have the same name as the bidirectional one, but with the direction 
automatically added.

To extract the unidirectional files:

1. From the main window, select the File menu, then Export, and Create 
OTDR Unidir Files.

2. If desired, select the location where you want to save the extracted 
files. The default location is where the original bidirectional file is 
located.

3. Select the format for the extracted files.
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4. Select whether you want to open the files in the application.

5. Select whether you want to keep the original bidirectional files in your 
project.

6. Click OK to extract the files and return to the main window.

Managing Unidirectional Markers Within a 
Bidirectional File

Bidirectional files are made of two separate traces in opposite directions. 
In FastReporter 2, you can see and manage the markers for each A->B and 
B->A traces. This allows you to calculate loss, ORL and other values for 
each unidirectional trace.

To access the unidirectional markers for a bidirectional file:

1. Open the desired bidirectional file.

2. If required, switch to the Graph display, as explained in To select the 
viewing method: on page 119.
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3. In the Event Table tab, right-click in the table to display the Bidir. 
Details.

4. Select the A->B or B->A event for which you want to manage the 
markers.

5. In the Markers tab, modify the marker as needed. For more 
information, see Managing Markers on page 154.
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Working with Virtual Bidirectional Files

Virtual bidirectional files are a way to preview the resulting measurement 
when you select two matching unidirectional measurements without going 
through the process of fully creating the bidirectional file. The display in the 
graph and linear views, and the Event Table tab are the same as they 
would if you are viewing an actual bidirectional measurement. The order 
of display for the events depend of the A -> B measurement.

To activate the virtual bidirectional file mode:

From the View menu, select OTDR, then Display Virtual OTDR Bidir.
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Creating Batch Documentation
FastReporter 2 includes a tool that can be used to batch document or 
analyze large numbers of OTDR test files. All identification information, 
with the exception of fiber ID, is copied from the reference file to the 
selected files. The automated documentation tool can also be used to 
automatically assign fiber IDs to selected files.

For details on using the automated documentation tool, see Adding and 
Removing Measurement Files on page 43.
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Saving an OTDR File in a New File Format
You can save OTDR measurement files in a new file format.

To save OTDR files in a new file format:

1. In the Measurement or Files window, select the OTDR file or files that 
you want to save.

2. On the File menu, click Save Selected Files As.

3. When saving a single file, type a name for the file in the File name box.

OR

When saving multiple files, click  on the Save As dialog box and 
select an output folder on the Browse for Folder dialog box.

4. In the Save as type list, select the appropriate file format.

5. Click Save.

Note: Some file formats (for example, Telcordia and FTB-300) do not support 
multiple wavelengths in the same file. When saving to those formats, 
separate files will be created for each wavelength.

IMPORTANT
If you save an OTDR file in an older format than it was originally in, 
you will lose the type of data that is not supported by the older file 
format.
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Generating Text Files From OTDR 
Measurements (FR2-FC Mode)

FastReporter 2 allows you to export the unidirectional or bidirectional 
OTDR files to a text file format. When one OTDR file is selected, the 
filename corresponds to the selected OTDR file, with a “.txt” extension. 
If multiple OTDR files are selected, you have to specify the file name.

Note: This feature is only supported in OTDR files.

To export the OTDR file to a text file:

1. Select single or multiple OTDR files from the Files tab.

2. From the File menu, click on Export, and select To TXT measurement 
report.

Select a desired location and enter the desired file name and click on Save 
to generate the text file.
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Modifying Space Between Traces on the Graph
For easier viewing of the traces appearing on the graph, you can increase 
or decrease the vertical space between each of them.

To increase or decrease the space between the traces:

1. On the toolbar, select the  button.

2. Use the buttons in the toolbar or menu to increase or decrease the 
space between the traces.

An indicator on the left of the graph shows that an offset is applied.

If you are using a keyboard and mouse, you can press and hold the Shift 
key to select the trace, then use the arrow buttons, or the mouse to drag it 
to the desired location.

Reset spacing

Decrease spacing

Increase spacing

Activate Y spacing
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Accepted File Formats

FastReporter 2 lets you work with measurement files saved in different 
formats, but does not necessarily permit all operations on them.

Note: The .oltsx format includes both single- and multi-wavelength 
measurements.

Note: The 64-bit version of FastReporter 2 may not support all file formats. To 
view .olts files that come from FOT-930s or FTB-3930 modules, save them 
first in a newer .olts format using the 32-bit version of the application.

File format File extension Display Modification

FOT-920, FOT-930, 
FTB-3930

.olts X X

.olts2 X X

.dat X X

.oltsx X X

MAX-900 .olts X X

ConnectorMax 2 .cmax2 X X
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Changing OLTS Settings
Depending on the type of files you are working with (whether they come 
from FTB-3930 and FOT-930 units, or the MAX-900 series), some settings 
can be modified.

You can change the identification settings for your FTB-3930 and FOT-930 
files, as well as the pass/fail threshold values, which can come from 
different sources:

 From the measurement file

 From the application

In the case of files coming from the MAX-900 series, you can select the unit 
to display the reference value.

To change OLTS threshold settings:

1. On the Settings menu, select OLTS.

2. Select the Pass/Fail Thresholds tab.

3. Select the type of threshold to use for your analysis.
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4. Set the wavelength list as needed if you are using the thresholds from 
the application:

 To add a wavelength, click the  button, enter the wavelength 
value, and click OK.

 To remove one or more wavelengths, select the values in the 
Wavelength list and click the  button.

Each wavelength can have different thresholds. If you have selected 
the custom thresholds, you can modify the values. The Apply option 
must be enabled for the values to be active and modifiable.

If you select more than one wavelength in the list, any modification to 
the thresholds will apply to all of the selected wavelengths.

5. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the dialog box, click OK.
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You can view the results in the OLTS Table tab in the main window.

Note: In the case of multi-wavelength files, the reference unit may show dB 
and/or dBm depending on the measurement.
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To select the display unit for the reference value on MAX-900 
files:

1. On the Settings menu, select OLTS.

2. Select the General tab.

3. Select the desired unit.

The reference unit will be displayed in the FasTesT Table tab between 
parentheses.

4. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the dialog box, click OK.
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Applying a Configuration File to Selected OLTS 
Files

You can select OLTS files and apply preset configuration data that you have 
in a configuration file. You can use a configuration file you have on your 
unit, or import it from another location.

Note: This feature is available for MAX-900 files only.

To import a set configuration and apply it to your files:

1. From the main window, select the Tools > OLTS, then Apply 
Configuration.

2. Select which configuration you want to use in the list of available 
choices. If you want to import a configuration file from another 
location, use the Import button.

3. Click OK to confirm your choice.
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Using Custom Identifiers
You can add up to five custom identifiers for your OLTS files. The custom 
identifiers are displayed in the Identification tab, in the Identifiers table.

You can find more information on how to manage custom identifiers in 
Matching Files Based on Information on page 51.

To use a custom identifier:

1. Select the measurement for which you want to change the identifier.

2. From the Identifiers table of the Identification tab, use the drop-down 
list to select the identifier type.

OR

Type the new type directly on-screen.
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Changing the OLTS Fiber Type
When working with OLTS files, you can select a specific fiber type. 
Different fiber types are available depending on the type of mode you are 
working with (singlemode or multimode).

To change the fiber type:

1. Open the file or files you want to modify.

Note: You can only change the fiber type of multiple files if they are of the same 
mode.

2. In the Summary tab, under Link Definition, use the corresponding 
drop-down list to select the desired fiber type.
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Changing the Number of Connections in the 
Link Definition

You can modify the number of connections in the link to see the impact of 
adding or removing connections on the dynamic loss budget thresholds. 
The threshold status and link view will be modified accordingly.

To change the number of connections:

1. Open the file or files you want to modify.

2. In the Summary tab, under Link Definition, click into the 
corresponding box to enter the desired value.

Note: When you change the link definition parameters, the pass/fail thresholds 
will be recalculated.
Post-Processing Software 199



Working with OLTS Files
Changing the Number of Splices in the Link Definition
Changing the Number of Splices in the Link 
Definition

You can modify the number of splices in the link to see the impact of 
adding or removing splices on the dynamic loss budget thresholds. The 
threshold status and link view will be modified accordingly.

To change the number of splices:

1. Open the file or files you want to modify.

2. In the Summary tab, under Link Definition, double-click into the 
corresponding box to enter the desired value.
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Changing the Loss Calculation Method for 
Bidirectional Files

If you select at least one direction of a bidirectional file, the application will 
show you the calculation method used to calculate loss:

 Average

 Worst value

 Average; Worst (when at least one value in the selected files is of each 
type)

You can change this value for the selected files.

To change the loss calculation method:

1. Open the file or files you want to modify.

2. In the Summary tab, under Test Settings, click into the Bidirectional 
Loss box to select the desired value.

The changes will be automatically reflected in the FasTesT tab and the 
cable view.
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Setting FasTesT Pass/Fail Thresholds
Depending on the type of threshold you have selected for your files, you 
can adjust some of the values on the current measurements to better fit 
your needs.

Note: You can use one or several of the types at a same time.

Note: If you set a maximum ORL threshold value, it will apply to all wavelengths. 

 Fixed link thresholds: this setting will use the link pass/fail threshold 
value, the maximum link length and link loss value as the thresholds.

 Dynamic loss budget: this setting will use the link pass/fail threshold 
value, and the fiber attenuation, as well as the splice loss and 
connector loss values as the thresholds. The first and last connectors 
will also be used in the calculation.

 Certification standards: this setting allows you to determine which 
certification standards will be taken into account for the cabling or the 
application.
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Working with OLTS Files
Setting FasTesT Pass/Fail Thresholds
To apply specific certification standards:

1. Select the file or files for which you want to change the threshold type.

2. Select the Thresholds tab, then click Select Standards.

3. Navigate in the application and cabling standard lists to select the 
items you need. Use the + button to show the detailed available 
choices.
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Working with OLTS Files
Setting FasTesT Pass/Fail Thresholds
4. If you want to see the threshold details for a specific standard, select it, 
then use the View Threshold Details button at the bottom of the 
window.

The maximum and minimum link loss, as well as the maximum 
attenuation values will depend on the wavelength you select on the 
left. The fiber type selected will also display different values. Click OK 
when you are done to return to the list of standards.

5. Once you are done, click OK to confirm the addition of the standards. 
The tab is updated accordingly.
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Working with OLTS Files
Setting FasTesT Pass/Fail Thresholds
To select and modify the custom thresholds:

1. Select the file or files for which you want to change the threshold type.

2. Select the Thresholds tab, then the custom thresholds option.

3. Select whether you want to set fixed link loss thresholds, or a dynamic 
loss budget, then modify the values as needed.

Note: If the unit used to take the measurements was not a Fiber Certifier (iCERT 
model), you cannot select the dynamic loss budget option or any of the 
certification standards and the maximum dynamic loss value is not 
displayed in the tab.
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Working with OLTS Files
Viewing FasTesT Results
Viewing FasTesT Results
When you display FasTesT result files, you can see the details in the 
FasTesT Table. Click on the loss value of any result (in the table, link view 
or Measurement tab) to see detailed information about the margin, test 
configuration used, wavelength, limit and result.

When working with bidirectional files, the loss will be indicated as the 
average or worst value, depending on what setting is selected.

Note: The Summary, Threshold and FasTesT tables are displayed if the 
measurements are of the same type (duplex, FasTesT, etc.).

Note: For a quick general overview of the pass/fail statuses of your 
measurements according to the certification standards, you can select the 
Certification view in the Measurement tab.
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Working with OLTS Files
Viewing Link View Results
Viewing Link View Results
You can view the results for MAX-900 series OLTS files in the graph 
view.

Click on any result to
see detailed

information about
the margin, test

configuration used,
wavelength, limit and

result.
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Working with OLTS Files
Viewing Link View Results
In the case of bidirectional measurements, if you select both 
measurements from the same file, the link view displays both connections 
between the main and remote units
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Viewing Pass/Fail Status Information
Viewing Pass/Fail Status Information
When working with MAX-900 series files, you can see the detailed pass/fail 
information for all standards used during the FasTesT. 

To view the global pass/fail information:

1. From the Files or Measurements tabs, select the file or files for which 
you want to see the status.

2. Right-click the selected files, then select Global Pass/Fail Status.

3. The information appears in a tooltip window. Click anywhere to exit.
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Understanding Diagnostics
Understanding Diagnostics
OLTS result files made with the MAX-900 series provide you with 
diagnostics to help you with detected problems or ambiguous 
measurement situations. You can see the diagnostics in the Measurements 
tab, the FasTesT Table tab, and in the link view.

To display the diagnostics in the Measurement tab:

1. Right-click in the column headers to make the Diagnostics column 
appear.

2. Click on the icon of the diagnostic that you want to view.

To view diagnostics in the FasTesT Table tab and Link View:

Click on the corresponding icon.
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7 Working with CD Files
Accepted File Formats

FastReporter 2 lets you work with measurement files saved in different 
formats, but does not necessarily permit all operations on them.

Note: The .cdpmd file may also contain fiber length and PMD information.

Note: When you modify information or data that is common to both CD and PMD 
formats in .cdpmd files, the contents is automatically updated in both 
measurement types.

File format File extension Display Modification

EXFO CD
(FTB-5800 modules)

.exfocd X X

CDPMD
(FTB-5700 modules)

.cdpmd X X
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Changing CD Settings
Changing CD Settings
The pass/fail thresholds that you set for CD projects are displayed on the 
Summary tab in the Results window. Should you need to change the 
wavelength measurement range for analysis purposes, this is also done in 
the Summary tab.

The dispersion thresholds are applied on the maximum dispersion for the 
measurement file and on each dispersion value of the CD table.

To change CD settings:

1. On the Settings menu, select CD.

2. Select the type of threshold to use for your analysis, either from the 
measurement file itself or from a list of predetermined thresholds.

 The threshold from the measurement file is the one that was used 
during the actual CD test. When you select this threshold, you 
cannot modify the values in the threshold table.

 The threshold from the application is a threshold set by 
FastReporter 2, which you can select and modify.

3. Modify the displayed values as needed. The Apply option must be 
enabled for the values to be active and modifiable.
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Working with CD Files
Changing CD Settings
4. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the dialog box, click OK.

The thresholds are displayed in the main window, in the Summary tab, 
under Results. If some values failed the test, they will appear clearly in red.

Note: The first figure illustrates the display for a .cdpmd file, and the second for an 
.exfocd file.
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Working with CD Files
Changing CD Settings
You can view the details for your measurement file in the CD Table tab. 
Depending on the type of CD measurement file you are viewing (.exfocd or 
.cdpmd), the available information differs. Any failed measurement will 
also show in this tab.

Note: RGD measurements are only available in .exfocd files.

Note: If you do not see the CD Table tab, make sure you have selected only one 
measurement in the list.

.cdpmd file

.exfocd file
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Working with CD Files
Changing CD Settings
It is possible for you to change the table wavelength, that is the way to 
calculate the table according to the Results from and Results to values. You 
can select from the table wavelength values below.

 1 nm (Results range with a step of 1 nm in-between values)

 50 GHz

 100 GHz

 200 GHz

 From the acquisition

To change the wavelength table:

From the main window, select the View menu, then CD > Table 
Wavelength and select the value you want to use.

If a file is open already, the values are automatically updated.
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Changing CD Fiber Type
Changing CD Fiber Type
FastReporter 2 allows you to analyze various fiber types for chromatic 
dispersion.

To change the CD fiber type:

1. Open a CD measurement file.

2. Select the measurement or measurements for which you want to 
change the fiber type.

3. In the main window, select the Summary tab.
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Working with CD Files
Changing CD Fiber Type
4. Select the fiber type according to your needs in the Fiber Type box:

 G.652 NDSF (3-term Sellmeier fit)

 G.653 DSF (quadratic fit)

 G.655 NZDSF (quadratic fit)

 G.656 Wideband NZDSF (quadratic fit)

 Compensating (quadratic fit)

 Flattened (cubic fit)

 Amplified Links (cubic fit)

 Custom (default cubic fit)

Note: When you select a different fiber type, the fit is automatically changed to 
match the default fit value for this new fiber type. However, you can change 
this new fit type as desired in the corresponding list.
Post-Processing Software 217



Working with CD Files
Changing Analysis Range
Changing Analysis Range
The range used for taking the measurement and the range used for 
analyzing the results can be different if you want to concentrate your 
analysis on a specific area. You can change it for both types of CD files.

To change the analysis range (results from and results to values):

1. Open a CD measurement file.

2. Select the measurement or measurements for which you want to 
change the analysis range.

3. In the main window, select the Summary tab.

4. In the Results from and Results to boxes, change the wavelength 
range values as needed for your analysis.
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Changing the Fiber Length
Changing the Fiber Length
If you are working with an .exfocd format file, you can change the fiber 
length to obtain more precision in your analysis.

To change the fiber length:

1. Open a CD measurement file.

2. Select the measurement or measurements for which you want to 
change the fiber length.

3. In the main window, select the Summary tab.

4. In the Fiber Length box, enter a new value for the analysis.

Note: If your file is in .cdpmd format, the fiber length was measured 
automatically during the measurement and cannot be edited.
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Switching Between Curve Types
Switching Between Curve Types
If you have a specified fiber length in your CD file, you can view either the 
chromatic dispersion or the chromatic dispersion coefficient curves.

To switch between the coefficient and dispersion curves:

From the main window, select View > CD > Coefficient.

The table values in the Summary tab are updated automatically.
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8 Working with PMD Files
Accepted File Formats

FastReporter 2 lets you work with measurement files saved in different 
formats, but does not necessarily permit all operations on them.

Note: The 64-bit version of FastReporter 2 does not support the .pmd and .pmdb 
file formats. Install the 32-bit version to view and process those files.

Note: The .cdpmd file may also contain fiber length and CD information.

Note: When you modify information or data that is common to both CD and PMD 
formats in .cdpmd files, the contents is automatically updated in both 
measurement types.

File format File extension Display Modification

PMD
(FTB-5500 modules)

.pmd X X

PMDB
(FTB-5500 modules)

.pmdb X X

CDPMD
(FTB-5700 modules)

.cdpmd X X
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Changing PMD Settings
Changing PMD Settings
You can change the thresholds you want to use for the analysis:

 The threshold from the measurement file is the one that was used 
during the actual PMD test. When you select this threshold, you cannot 
modify the values in the threshold table.

 The threshold from the application is a threshold set by FastReporter 2, 
which you can select and modify.

To change PMD settings:

1. On the Settings menu, select PMD.

2. Select the type of threshold to use for your analysis.
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Working with PMD Files
Changing PMD Settings
3. Modify the displayed values as needed if you selected to use a 
threshold from the application. The Apply option must be enabled for 
the values to be active and modifiable.

4. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the dialog box, click OK.
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Working with PMD Files
Changing PMD Settings
The thresholds are displayed in the main window, in the Summary tab, 
under Results. If some values failed the test, they will appear clearly in red.

Note: The .cdpmd files do not display a graph for the PMD measurement.
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Changing Fiber Length
Changing Fiber Length
If you are working with .pmd or .pmdb files, you can change the fiber 
length to obtain more precision in your analysis.

To change the fiber length:

1. Open a PMD measurement file.

2. Select the measurement or measurements for which you want to 
change the fiber length.

3. In the main window, select the Summary tab.

4. Locate the fiber length value under Test Settings and modify it as 
needed.

Note: If your file is in .cdpmd format, the fiber length was measured 
automatically during the measurement and cannot be edited.
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Working with PMD Statistic Measurements
Working with PMD Statistic Measurements
When selecting more than one PMD measurements on a same file, the 
Statistics tab appears. This tab can be used to see average values for the 
measurements.

To exclude a measurement from the statistic values:

1. Open a PMD measurement file.

2. Select the measurement or measurements that you want to exclude 
from the statistics values.

3. In the main window, select the Summary tab.
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Working with PMD Statistic Measurements
4. Set the measurements as not used for the statistics under Test 
Settings.

To view PMD measurement statistics:

1. Open a .pmdb measurement file.

2. Select more than one measurement to make the tab appear.

3. In the main window, select the Statistics tab.
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9 Working with OPM/PPM 
Measurements
Accepted File Formats

FastReporter 2 lets you work with measurement files saved in the following 
formats, but does not necessarily permit all operations on them.

File format File extension Display Modification

PPM-350 C .ppm X X

iOLM .iolm X X

OPM .oltsx X X

ConnectorMax 2 .cmax2 X X

MAX-900 Series .olts X X
Post-Processing Software 229



Working with OPM/PPM Measurements
Selecting the Absolute Power Unit
Selecting the Absolute Power Unit
You can set FastReporter 2 to use either dBm, watts, or use the power unit 
used in the measurement you are viewing.

To select the power unit:

1. From the main window, select the Settings menu, then OPM/PPM.

2. In the General tab, select which unit to use.

3. Click OK to confirm your choice and close the window.
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Working with OPM/PPM Measurements
Changing OPM/PPM Settings
Changing OPM/PPM Settings
The pass/fail thresholds that you set for PON Power Meter (PPM) or Optical 
Power Meter (OPM) projects and the predefined thresholds are applied on 
the corresponding table tabs in the Results window. If you need to change 
the threshold for analysis purposes, it can be done in the Thresholds tab.

To select which thresholds to use for the measurements:

1. From the main window, select the Settings menu, then OPM/PPM.

2. In the Pass/Fail Thresholds tab, select whether the thresholds to use 
are those from the measurement file, or those from the application.

Note: In the case of FTTx measurements, you can only use the thresholds from 
the measurement files.

3. Click OK to confirm your choice and close the window.
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Working with OPM/PPM Measurements
Changing OPM/PPM Settings
To change OPM/PPM settings:

1. Open the file which contains OPM/PPM measurements.

2. On the Results window, click the Thresholds tab.

3. Select a wavelength or wavelengths to modify.

4. Modify the thresholds associated with the wavelengths needed by 
clicking in the desired threshold value and modifying it in the table. If 
you have selected more than one wavelength, all of them will be 
modified at the same time.

Measurement: 
OPM

Measurement: 
PPM
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Working with OPM/PPM Measurements
Viewing Power Meter Results
Viewing Power Meter Results
Power meter results are displayed in the OPM and PPM tables.

To view the Power meter results for OPM measurements:

1. Select OPM measurements.

2. From the Results window, select OPM Table.

To view the Power meter results for PPM measurements:

1. Select the file which contains PPM measurements.

2. From the Results window, select PPM Table.
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Working with OPM/PPM Measurements
Changing the Correction Factor (FR2-FC Mode)
Changing the Correction Factor (FR2-FC Mode)
Correction factors are used to adjust the OPM and PPM measurements. 
The correction factor is specified by wavelength only, and the fiber core 
size is not taken into account. FastReporter 2 allows you to change the 
correction factor for PPM file types. These corrections should be made 
before the measurement is taken and should be stored with each 
measurement. A correction factor of 1.0 has no effect on the 
measurement.

Note: The correction factor is not available for measurements from iOLM files.

To change the correction factor:

1. Open an OPM or a PPM measurement file.

2. Select the measurements for which you want to change the correction 
factor.

3. In the Results window, select the Summary tab.

4. Modify the correction factors associated with the wavelengths as 
needed. Click the desired correction factor value under Test Settings 
column and modify it.
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10 Working with Fiber Inspection 
Probe (FIP) files
Accepted File Formats

FastReporter 2 lets you work with measurement files saved in different 
formats, but does not necessarily permit all operations on them.

Theses file formats include:

 Inspection of single-fiber connectors

 Analysis of single-fiber connectors

 Inspection of multiple-fiber connectors

File format File extension Display Modification

FIP (ConnectorMax) .cmax X Xa

a. Modified .cmax files can only be saved again in .cmax2 format.

FIP (ConnectorMax2) .cmax2 X X
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Working with Fiber Inspection Probe (FIP) files
Modifying Unit Model and Serial Number
Modifying Unit Model and Serial Number
The application allows you to change the unit model as well as the unit 
serial number for your FIP measurements on .cmax format files. You can 
change the unit model and unit serial number of multiple measurements at 
a time. The entered unit model and unit serial number are also displayed in 
the FIP report.

Note: In .cmax2 format files, the unit model and serial number cannot be 
modified.

To change the unit model:

1. Open the FIP measurements to change.

2. On the Results window, in the Identification tab, double-click on the 
Unit model field and enter the required unit model number.

Note: You cannot enter special characters (?,/,<,>,",:,*, |,\).

Note: You can enter a maximum of twenty five characters.
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Working with Fiber Inspection Probe (FIP) files
Modifying Unit Model and Serial Number
To change the unit serial number:

1. Open the FIP measurements to change.

2. On the Results window, in the Identification tab, double-click on the 
Unit serial number filed and enter the required unit serial number.

Note: You cannot enter special characters (?,/,<,>,",:,*, |,\).

Note: You can enter a maximum of twenty five characters.
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Working with Fiber Inspection Probe (FIP) files
Showing or Hiding Threshold and Result Information
Showing or Hiding Threshold and Result 
Information

You can hide threshold and result information for zones that are not useful 
for your analysis.

Note: You cannot modify the information. This is for viewing purposes only.

To select the zones to display:

On the main window, in the Thresholds or FIP Result tab of the Results 
window, click the right mouse button, then select or clear any of the zones:

 Zone A: Core

 Zone B: Cladding

 Zone C: Adhesive

 Zone D: Contact

Note: Changes done in either tab is reflected in the other and are immediate.
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Working with Fiber Inspection Probe (FIP) files
Applying a Configuration File to Selected FIP Files
Applying a Configuration File to Selected FIP 
Files

You can select FIP files, and apply preset configuration data that you have 
in a configuration file. You can use a configuration file you have on your 
unit, or import it from another location.

To import a set configuration and apply it to your FIP files:

1. From the main window, select the Tools > FIP, then Apply 
Configuration.

2. Select which configuration you want to use in the list of available 
choices. If you want to import a configuration file from another 
location, use the Import button.

3. Click OK to confirm your choice.
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Working with Fiber Inspection Probe (FIP) files
FIP Graphic Display Options
FIP Graphic Display Options
The FastReporter 2 application displays the FIP overlay in the graph 
window along with the FIP Image. An overlay highlights the inconsistencies 
in your FIP with different colors described below.

 FAIL Anomaly: the presence of this anomaly implies automatically a 
FAIL result.

 PASS Scratch: the presence of this anomaly is not sufficient to confirm 
a FAIL, the anomaly count in this case is relevant.

If you select more than one FIP files and enable the appropriate viewing 
option, you can have the corresponding graphic displays appear all at once 
on-screen. This feature is available for both single fibers and multiple 
fibers.

You can also select to see the images according to the cable connector 
view. The fibers included in a same cable are grouped, and the cable is 
identified in the graph view.

You can copy the FIP images and/or overlays and paste them to the 
clipboard. You can also change the display setting of the graph for FIP 
measurements so that you can see both the overlay and the graph side by 
side.

Color Legend Analysis Anomaly Highlighting

Aqua PASS Scratch

Green PASS Defect

Red FAIL Anomaly
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Working with Fiber Inspection Probe (FIP) files
FIP Graphic Display Options
To change FIP graphic display options:

1. On the View menu, select FIP to display the FIP graphic display 
options.

2. Select Multi-Fiber View to display an image for all of your selected files 
or Cable Connector View to display the corresponding mode. The 
order of the images is the same as the order of the files in the Matched 
Files tab.

If you want to select a specific item, you can use the drop-down the list 
in the measurement toolbar.
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Using Custom Identifiers
Using Custom Identifiers
You can add up to five custom identifiers for your FIP files. The custom 
identifiers are displayed in the Identification tab, in the Identifiers table.

You can find more information on how to manage custom identifiers in 
Matching Files Based on Information on page 51.

To use a custom identifier:

1. Select the measurement for which you want to change the identifier.

2. From the Identifiers table of the Identification tab, use the drop-down 
list to select the identifier type.

OR

Type the new type directly on-screen.

The Frame identifier type cannot be modified. Enter the information that 
describes the groups of connectors included in the frames, as needed.
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Saving Legacy FIP Files in .cmax2 File Format
Saving Legacy FIP Files in .cmax2 File Format
You can import and view legacy image files (.jpg, .jpeg and .bmp formats) 
using FastReporter 2. Once the image file is open, it is displayed in the 
graphic window. and is converted and saved in .cmax2 format.

Note: When opening .cmax legacy files (ConnectorMax format), they will also be 
automatically converted to the .cmax 2 format and can only be saved as 
such if you modify them.

To import an image file:

1. From the Files menu, click on Import > Image File.

2. Select the required image and click Open.

Note: Under the Identification tab, the application displays the file name, test 
date, and the test time of the image. The rest of the fields remains empty 
but is editable.
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Viewing Power Meter and OLTS Results
Viewing Power Meter and OLTS Results
Your .cmax2 file could contain both FIP and power meter data, or FIP and 
loss data in a single file. Power meter and OLTS results are displayed in 
their respective tables. For more details, see Viewing Power Meter Results 
on page 233 and Working with OLTS Files on page 191.

Viewing Geolocation Information
Your fiber inspection probe files can include GPS coordinate data that 
pinpoints where the test was performed. This information is displayed in 
the Identification tab when you open your file.

The information is the latitude, a separator character, and the longitude. If 
you have more than one locations, they will be separated by a semi-colon.

Note: If you are using FastReporter 2 on a computer and have selected a single 
file, the geolocation information becomes a hyperlink that will take you to 
the corresponding location on Google Maps, using the default Web 
browser.
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11 Working with iOLM files
Accepted File Formats

FastReporter 2 lets you work with measurement files saved in the following 
formats, but does not necessarily permit all operations on them.

Understanding the Link View
The iOLM Link View is an intuitive representation, which combines several 
measurement results and values into a single view.

The link view is divided into two different regions.

 Link overview

 Link composition

In the link overview, you can quickly see the status for each element with 
the corresponding color code:

 Red: The element is fail.

 Green: The element is pass.

 Blue: The element is not tested for Pass/Fail.

File format File extension Display Modification Reanalysis

iOLM .iolm X X X

.iolmcfg X X 

.iolmbdr X X X

Link Overview

Link
Composition
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Understanding the Link View
The pass/fail status also depends on the threshold values specified. The 
link overview representing all the elements discovered on the link is 
described below.

 Length of the measured link: Length of the measured link excluding 
the launch and receive fibers.

 Selected element: Rectangle representing the selected element.

 Visible region: The colored background represent the visible region in 
the link composition view.

 Beginning of the link: Beginning of the link under test.

 End of the link: End of the link under test.

Elements before A and after B are referred to as out-of-span elements. 
Elements out of the span are not tested for pass/fail status, but can have 
diagnostics on them. If the launch fiber is not defined, the element marked 
as "A" will not be tested for pass/fail and if the receive fiber is not defined, 
the element marked as "B" will not be tested for pass/fail.

Visible regionBeginning of 
the link

Selected 
element

Length of the 
measured link

End of the Link
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Working with iOLM files
Understanding the Link View
The link composition is described below.

 Element position: The distance of the element from the beginning of 
the link under test.

 Navigation arrow: The navigation arrow is only displayed when more 
items are available on the particular side. It indicates that the you have 
to scroll to view those items. This arrow can also appear on the left 
side.

 Selected element: The gray background represents the currently 
selected element.

 Letter A: The beginning of the link under test.

 Letter B: The end of the link under test.

Note: An arrow ( ) icon is displayed on the element if the start and the end of 
the link is represented by the same element.

 Element Pass/Fail: The status of the element whether it is pass ( ), fail 
( ), or unknown. If you are viewing multiple measurements in Cable 
view (see Managing Multiple Measurements on page 249 for details), 
the status depends on the statuses of the corresponding matched 
elements. If at least one of the elements has a fail status, then the cable 
combined element status is also fail.

Selected 
Element

Diagnostics Icon

Element 
Pass/Fail

Splitter ratio

Element 
Fail Icon

Distance Unit

Navigation 
Arrow

Element Position

Pass/Fail 
not tested
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Understanding the Link View
 Pass/Fail not tested: A gray background indicates that the element is 
unknown. If there is no icon at the right side corner, it indicates that 
thresholds are not applied on the element and the element is not 
tested for Pass/Fail. If you are viewing multiple measurements in Cable 
view (see Managing Multiple Measurements on page 249 for details), 
the status depends on the statuses of the corresponding matched 
elements. If at least one of the elements has a status of fail, then the 
combined element status is also fail. If the statuses are a combination 
of pass and unknown, then the cable combined element status is set to 
unknown.

 Diagnostics  icon: This icon specifies that some diagnostic is present 
on the element. See Understanding Diagnostics on page 309 for more 
details.

 Distance Unit: The distance unit you have selected.

 Splitter Ratio: The splitter ratio is displayed on the element, if the 
element type is splitter.

Note: The number of elements displayed in the composition view varies 
according to the available space, number of elements, and section size.

Note: When the link length is large, not all of the elements are visible; you may 
need to scroll on the link using the navigation arrow.

Note: The distance between the elements is not 100 % proportional. To have a 
proportional representation of the element, look at the link overview.
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Managing Multiple Measurements
Managing Multiple Measurements
When you are working with more than one measurements, you can view 
the links in two different manners:

 The Cable view shows all of the measurements grouped into one link, 
with the link overview. The total number of selected fibers is indicated 
on the left, and each element has its own identification number. When 
matched elements are of the same type, you can see how many there 
are on the upper left corner of the element icon. If the number is blue, 
all fibers contain this element. If the number is yellow, at least one fiber 
does not have this element. If elements at the same position are not of 
the same type, a question mark icon replaces the element type.

 The Fiber view shows the grouped links at the top of the window, then 
details each fiber with its corresponding elements. You can perform 
changes to individual fibers in this view.
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Note: When viewing grouped fibers, the End of fiber element (B) is set according 
to the reference measurement if there is one; if there is no reference 
measurement it is set according to the shortest fiber. The elements located 
between the grouped A and B positions (including both A and B) are 
numbered.

You can perform the same actions (adding, modifying and deleting 
elements, setting span start and end) on single fiber and multiple fibers; 
the main difference is that if you perform the actions in the cable view or 
on the cable at the top of the Fiber view, all of the included fibers are 
modified accordingly.

To select the viewing method for multiple fibers:

1. Select the fibers that you want to view together in the Files or 
Measurement tabs.

2. Right-click in the Link view, then select either the Cable or Fiber view. 
You can also select the view in the View > iOLM menu.
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Selecting Element Alignment Type
Elements can be matched either using the position (the distance on the 
fiber), or the element number. The span start is considered as element 
number 1, or the start position.

Note: Some operations, such as delete, add, and add to other measurements are 
not available when the elements are matched by number.

To select the element alignment type:

1. On the Settings menu, click iOLM and then the General tab.

2. Select how the elements will be matched.

3. Click OK.
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Modifying Tolerance and Bidirectional 
Settings

You can allow the creation of iOLM bidirectional files for your analyses.

You can also set the extended element matching tolerance. The main 
purpose to edit the tolerance is to match two elements that are not 
matching with the intrinsic element tolerance value fixed by signal 
processing.

To enable the iOLM bidirectional file creation:

1. On the Settings menu, click iOLM and then the General tab.

2. Enable the Display iOLM bidirectional file creation dialog option.

3. Click OK.
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To change the extended element matching tolerance:

1. On the Settings menu, click iOLM, and then the Tolerance tab.

2. Enter the tolerance value to match the element.

3. To save your settings, click OK.

Note: If you want to apply the default settings, click Default Settings.
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Modifying iOLM Thresholds
The types of thresholds that you can view and modify are link and element.

Note: Since you cannot have splitters in multimode measurements and 
bidirectional measurements, the corresponding threshold table will not 
appear in the tab if you are working with this type of file. This also applies if 
you have selected both monomode and multimode files.

Changing Pass/Fail Thresholds

You can change the pass/fail threshold values for one, or many 
wavelengths at a time.

You can also change the threshold values for the current measurement.

To change iOLM Pass/Fail Thresholds:

1. On the Settings menu, select iOLM.

2. Click the Pass/Fail Thresholds tab.
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3. Select how you want to set the thresholds:

 If you want to use the threshold values from the measurement file, 
select the corresponding option.
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 If you want to use the threshold values from the application, 
proceed as follows:

Select if you want to use thresholds associated with specific 
certification standards, or you can set a custom configuration.

Note: You can use both certification standards and custom configurations at the 
same time.
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If you are using a custom configuration, select how you want to set 
the thresholds:

Select if you will use fixed link loss thresholds or a dynamic loss 
budget (in the case of iCERT files) or both. The threshold values 
that you can modify will change accordingly in the table. If the 
measurements include a dynamic loss value, it will appear in the 
table.
Post-Processing Software 257



Working with iOLM files
Modifying iOLM Thresholds
In the case of iCERT files, select the fiber type used in the setting. If 
you have selected a specific fiber type, not all fiber types may be 
available.

Select one or several wavelengths to modify. If you do not see the 
wavelength you want to use, you can add it by clicking the  
button, entering the wavelength value, and clicking OK.
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Modify the thresholds associated with the wavelengths needed, by 
clicking in the desired threshold value and modifying it in the table. 
The Apply option must be enabled for the threshold to be active 
and modifiable.

If you have selected more than one wavelength, their maximum 
and minimum link loss, as well as maximum attenuation will be 
modified at the same time.

4. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the window, click OK.

Note: When the span ORL value is preceded by a “<” and the ORL threshold is 
smaller than or equal to the value, the global pass/fail status for the 
measurement will be unknown or fail.
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Setting Pass/Fail Thresholds for the Current 
Measurements

Depending on the type of threshold you have selected for your files, you 
can adjust some of the values on the current measurements to better fit 
your needs.

Note: You can use one or several of the types at a same time.

 Fixed link thresholds: this setting will use the link pass/fail threshold 
value, the maximum link length and link loss value as the thresholds.

 Dynamic loss budget: this setting will use the link pass/fail threshold 
value, and the fiber attenuation, as well as the splice loss and 
connector loss values as the thresholds. The first and last connectors 
will also be used in the calculation.

 Certification standards: this setting allows you to determine which 
certification standards will be taken into account for the cabling or the 
application.

To modify the iOLM thresholds for the current measurement:

1. Open an iOLM file.

2. Select the measurements for which you want to view or modify the 
thresholds.

The current pass/fail threshold statuses are indicated in the list: green 
for pass and red for fail.
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3. In the Results window, select the Thresholds tab.

4. Select the type of budget you want to use for the results.

5. Select the wavelengths for which you want to view or modify the 
maximum and minimum loss, and maximum attenuation loss values, 
then change the values as needed.
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6. Enable the element pass/fail thresholds option to be able to modify 
them and apply them, then change the values as needed.

7. If the files are iCERT, you can select one or more certifications, as 
explained in the procedures following this one. This will display the 
threshold values associated with this particular type of certification. 
You cannot modify the thresholds displayed for them.

If no certification are available, the certification configuration name is 
set to Custom, and you can modify the thresholds as needed by 
clicking the corresponding Apply box, then modifying the value in the 
table.

Note: If you have selected more than one wavelength, all of them will be 
modified at the same time.

8. If you want to change the splitter loss ratio values, proceed in the same 
manner as you have for the thresholds.

9. If you want to apply the default values for all thresholds and standards, 
click Default Settings.
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To apply specific certification standards:

1. Select the file or files for which you want to apply standards.

2. Select the Thresholds tab, then click Select Standards.

3. Navigate in the application and cabling standard lists to select the 
items you need. Use the + button to show the detailed available 
choices.
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4. If you want to see the threshold details for a specific standard, select it, 
then use the Details button at the bottom of the window.

Click OK when you are done to return to the list of standards.

5. Once you are done, click OK to confirm the addition of the standards. 
The tab is updated accordingly.
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To select and modify the custom thresholds:

1. Select the file or files for which you want to change the threshold type.

2. Select the Thresholds tab, then the custom thresholds option.

3. Select the wavelengths for which you want to modify threshold values.

4. Change the threshold values as needed.
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Note: If the unit used to take the measurements was not a Fiber Certifier (iCERT 
model), you cannot select the dynamic loss budget option or any of the 
certification standards and the maximum dynamic loss value is not 
displayed in the tab.

To show the certification standards applied to a specific 
measurement file:

In the Files tab, right-click on the measurement or measurements for 
which you want to view the standard, and select Global Pass/Fail Status.

The result will appear in a tooltip. If you have selected more than one 
measurements, the standards will be applied to all of them.

Using the Auto Template (FR2-FC Mode)
The auto template lets you add and remove elements on links based on 
their occurrence on the total group of selected links. You can set a 
percentage value that will indicate whether an element should be added 
or removed.

Once the auto template is used, you can analyze the results; if there are 
issues with some of the elements, you can view them in a descriptive 
summary.The auto template is particularly useful for obtaining uniformity 
when testing many traces on a same fiber.

To enable and use the auto template in your project:

1. On the Settings menu, select iOLM.

2. Click the Auto Template tab.
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3. Enable the option to be able to set the preferences.

4. If you want to add elements, select the corresponding option and enter 
the minimum percentage value of occurrences required to add the 
element to the remaining links.
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5. If you want to remove elements, select the corresponding option and 
enter the percentage value of occurrences under which the element 
must fall to be remove it from the measurement.

6. To apply the changes without closing the dialog box, click Apply. To 
apply the changes and close the window, click OK.
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To apply auto template settings to the current measurements:

1. Open the measurements you want to include in the auto template 
operation.

2. From the Measurement menu, select iOLM, then Auto Template.

3. If you want to add elements, select the corresponding option and enter 
the minimum value of occurrences required to add the element to the 
remaining links.

4. If you want to remove elements, select the corresponding option and 
enter the value of occurrences under which the element must fall to be 
remove it from the measurement.

5. Click OK to confirm your choice and start the operation.

Note: The values modified in the window will not be kept for future applications 
of the auto template. They are for the current measurements only.
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The elements will be added or deleted according to the Auto template 
settings. The results will be updated in the Element Table. If some issues 
occur during the process, a summary will indicate which element is 
concerned.
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Modifying iOLM Settings (FR2-FC Mode)
In the Summary tab you can view and modify the IOR and backscatter 
value for your iOLM measurements.

To modify iOLM settings in the Summary tab:

1. Open an iOLM file.

2. Select the measurement for which you want to view or modify the 
iOLM settings.

3. In the Results window, select the Summary tab.
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4. In the Results table you can see all the result components:

 Link length: Displays the Link length.

 Acquisition Status: Displays the status of the acquisition (taken 
normally or interrupted).

 Link loss: Displays the Link loss for the indicated wavelength.

 Link ORL: Displays the Link ORL value for the indicated 
wavelength.

 Analysis version: Displays the version of the application used to 
analyze the link. If the measurement is analyzed with FastReporter 
2, the analysis version is replaced by the FastReporter 2 version 
number. This version is saved only if the file is saved. If the version 
is not available, the field remains empty.

 Prop. Delay: Displays the propagation delay for the indication 
wavelength.

Note: If the link ORL value is saturated (displayed with a < symbol), the test is 
still performed to obtain a pass/fail status. However, you can only 
determine that the status is fail and the pass status cannot be specified.
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5. In the Test Settings table, modify the IOR and the Backscatter values 
as needed.

Note: The values set for 1550 nm are automatically computed for other 
wavelengths. You can only edit the IOR and backscatter values for the 
1550 nm wavelength, even if other wavelengths are available in the 
selected iOLM measurement.

Note: When the IOR value is changed, the position and length of the section will 
be updated, and when the backscatter value is changed it triggers a 
reanalysis of the whole link.
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Modifying the Splitter Ratio Information
The Link Definition table displays the information about the expected 
number of splitters on the link and their respective splitter ratio. You can 
modify the splitter ratios so that they are no longer included in the pass/fail 
calculation and have the application discover the ratios automatically.

The splint ratios are sequential, in the sense that if you set the first in 
sequence to None, any subsequent splitter ratio is automatically set to 
None as well.

Note: Link definition on an iOLM measurement is available for display, but it is in 
read-only mode.

To modify the splitter ratio information:

1. Open an iOLM configuration file.

2. In the Results window, select the Summary tab.

3. You can view and modify the splitter ratio stage 1, 2, and 3 fields in the 
Link Definition table.

4. Select 1:? if you know that a splitter is present, but you do not know its 
splitter ratio. The iOLM discovers the splitter ratio automatically and the 
element will not be tested for pass/fail.

Note: The splitter ratios are defined stage wise, depending on how they are 
defined in the network.
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Modifying Identifier Labels (FR2-FC Mode)
You can view and modify the identifier labels for your iOLM measurement 
files.

Note: When multiple iOLM measurements are selected, you will see the 
information for all selected measurements. If the values are the same, they 
are displayed once; if not, they are separated by semicolons.

To modify the identifier labels:

1. Open an iOLM file.

2. Select the measurements for which you want to view or modify the 
Identifier labels.

3. In the Results window, select the Identification tab.

4. Select the identifier from the list of available choices in the Identifiers 
table to modify it. You can also rename the identifier by selecting it. As 
needed, you can change the corresponding value.

Note: The identifiers label is not editable if the iOLM measurements are selected 
with any other type of measurements such as CD or OTDR.

Note: When the Identifier label is selected as None, the values are not editable.
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Changing Fiber Core Size (FR2-FC Mode)
The FastReporter 2 application displays the core size of the fiber for the 
selected measurement in the Test Settings table of the Summary tab. 
When multiple measurements are selected and the fiber core sizes are not 
similar, they are separated with a semicolon.

Note: The application allows you to change the fiber core size only for the 
multimode files.

To change the fiber core size:

1. On the Measurements tab, select the multimode measurement for 
which you want to modify the fiber core size.

2. From the Summary tab, select the required fiber core size in the list of 
available values.

3. The application prompts you to confirm the change. Click Yes to set the 
default values for result and test settings. If you click No, the fiber core 
size value changes, but the default values are not applied for result and 
test settings.
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Changing the iOLM Fiber Type
When working with iOLM files, you can select a specific fiber type. 
Different fiber types are available depending on the type of mode you are 
working with (singlemode or multimode).

To change the fiber type:

1. Open the file or files you want to modify.

Note: You can only change the fiber type of multiple files if they are of the same 
mode.

2. In the Summary tab, under Link Definition, use the corresponding 
drop-down list to select the desired fiber type.
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Changing the Number of Connections in the 
Link Definition

You can modify the number of connections in the link to see the impact of 
adding or removing connections on the dynamic loss budget thresholds. 
The threshold status will be modified accordingly.

To change the number of connections:

1. Open the file or files you want to modify.

2. In the Summary tab, under Link Definition, click into the 
corresponding box to enter the desired value.

Note: When you change the link definition parameters, the pass/fail thresholds 
will be recalculated.
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Changing the Number of Splices in the Link 
Definition

You can modify the number of splices in the link to see the impact of 
adding or removing splices on the dynamic loss budget thresholds. The 
threshold status will be modified accordingly.

If you are working with iCERT files, you can change the number used to 
calculate the dynamic loss budget. If you have selected multiple iCERT files 
or if there are more than one custom elements, you will see how many of 
each are in the links.

To change the number of splices:

1. Open the file or files you want to modify.

2. In the Summary tab, under Link Definition, double-click into the 
corresponding box to enter the desired value.
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To change the number used to calculate the dynamic loss budget:

1. Open an iOLM file.

2. Under the Summary tab, select which custom element you want to 
modify.

3. Change the value as needed.
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Managing Elements
When an element or a section is selected from the link view, the details of 
the corresponding element or section are displayed in Elements Table tab. 
The loss, reflectance, wavelength, and corresponding pass/fail status for 
loss and reflectance will be displayed.

When you hover the mouse over any element, the application displays the 
corresponding details of the element, such as: type, wavelengths, loss, and 
reflectance.

Note: Inversely, if you select an item in the Elements Table tab, the corresponding 
item is highlighted in the link view.

Note: Reflectance is not displayed if you hover the mouse over a non-reflective 
element.
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When you hover the mouse over any element groups, the application 
displays the group details separated by semicolons.

When you hover the mouse over any element with a diagnostic label, the 
application displays the description.

Note: It is possible to underestimate the loss or reflectance value if the noise level 
is too high (for instance, after a lot of loss on the link, the noise levels 
increase). In that case, it is possible for the signal processing algorithms to 
detect an element, and to estimate the loss/reflectance values, but since the 
measured signal does not completely clear the noise floor, the loss or 
reflectance values are likely to be underestimated. If the loss or reflectance 
value is underestimated, the value is displayed with a > symbol.
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The elements that you could see on the link are described in the table 
below:

Element Name Element Icon Element Description

Macrobend Displayed in the link view when more than 
one wavelength is present in the 
measurement.

The macrobend will always be displayed 
as a failed element.

Out of Range Displayed when the end of fiber could not 
be detected by the module because the 
dynamic range is not large enough.

Splitter Passive fiber optic coupler that divides 
light from a single fiber into two or more 
fiber channels. The splitter ratio is 
displayed above the icon.

(Splitters are not available on multimode 
or bidirectional files.)

Splice Indicates the junction of two fiber sections 
having different fiber backscatter 
characteristics.

Connector  Used to join two fibers.

Mismatch The elements on a matching location in 
the link are not of the same type.

Fault No splitter was detected on the fiber. This 
element type is always considered as a 
fault.

Switch The switch element is used for multifiber 
MPO switch automated acquisitions.
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Customizing the Elements Table Tab
When viewing measurements, you can customize what is displayed in the 
Elements Table tab to better reflect what you want to see about the 
elements, the sections, or both.

To customize the Elements Table tab:

From the View menu, click on iOLM, and then Element Table to select the 
desired items.

 Element: to view the element details.

 Section: to view the section details.

 Element/Section Statistics: to view the statistics for the elements and 
sections

 Fiber Statistics: to view the statistics pertaining to the fibers.

 Group Details: to view detailed information for the grouped items.

 Position: to view the position details of the elements.

 Element Loss: to view the loss details of the elements.

 Reflectance: to view the reflectance details of the elements.

 Display Element Type as Text: to view the element type in written form.

 Display Element Type as Icon: to view the element type as an icon.

 Length: to display the section lengths.

 Section Loss: To display the loss for the section.

 Attenuation: to display the section attenuation.

Note: You can also right-click on the fixed column of the Elements/Section 
Details tab and customize the view.
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The corresponding view is displayed in the Elements Table tab.

You can see the attributes below in the tab:

 Type: The type of element selected in the link view. You can modify the 
element type by selecting it from the drop-down menu. If an element is 
modified as a custom element, the name of the custom element 
shows in the tool tip.

You can also change the splitter ratio if the selected element is a 
splitter, including 2:N splitters if the measurement supports them.

Note: The items available in the list depend on the characteristics of the selected 
element. It may not be possible to change the element type.

Note: If the type of an element is modified, an asterisk (*) is displayed in the Type 
column.

 Position/Length: The position of the element on the link and section 
length. Position 0.00 is set on the first element after the launch fiber.

 Loss (dB): The loss at different wavelengths.

 Reflectance (dB): The reflectance at different wavelengths.

 Attenuation (dB/km): The attenuation value for each wavelength.

Note: The attenuation detail is displayed for the section and the field is displayed 
only when View Section Details is selected.
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Viewing Grouped Elements

Link elements will be displayed as groups when the iOLM analysis detects 
that several elements are too close to be independently characterized. 
When this occurs, as much information as possible is displayed for each 
individual sub-element. The pass/fail status is applied to each sub-element 
whenever possible, and a global status is also displayed for the group.

Groups can also be displayed when a link element (such as a splitter) is 
found to have wavelength dependant loss. In that case, the link element is 
grouped with a macrobend element. In this particular case, there might not 
be a physical macrobend next to the link element, but the macrobend icon 
is used to highlight the presence of the wavelength dependant loss. When 
elements are grouped, the group loss and group reflectance value is also 
displayed in the Element tab.

Each sub-element is directly displayed as if they were normal elements.

Note: For grouped elements, some values may not be available individually but 
are available at the group level, such as loss and reflectance.

Note: If elements are grouped, the total group loss value is compared with the 
addition of the thresholds defined for each element in the group. If the total 
group loss value is greater than the addition of the thresholds defined for 
each element in group, the grouped element will show a fail status. You 
can individually select grouped elements as any other standalone element. 
When elements are grouped at the beginning of the link, icon A is displayed 
on one of the sub-elements. When elements are grouped at the end of the 
link, icon B is displayed on one of the sub-elements.

Group
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Adding Elements

The application allows you to add elements in iOLM and iOLM Bidir files in 
the link view by selecting any element or section.

You can add elements in both the Fiber and Cable views as well as the 
Elements Table tab. Adding an element to the cable (whether you do it in 
Cable view, or on the cable at the top of the Fiber view) adds it to all of the 
fibers. You can also take one element from one fiber and add it to the other 
fibers.

The added element supports the following scenarios depending on the 
distance or position of the element:

 The new element is added in a section of the link between two existing 
elements.

 The new element is added as a sub element in existing element group.

 The new element is added as a sub element to a single element to 
create a new element group.

Note: You cannot add any element before Element A or after Element B.

Note: You cannot add splitters on multimode or bidirectional measurements.
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To add an element:

1. Open an iOLM or iOLM bidir file.

2. Select the section or existing element where you want to add the new 
element, then from the Measurement menu, select iOLM, and Add 
Element.

3. Select whether the new element will be located before or after the 
element you have selected. If you are adding an element to a section, 
indicate the position of the element.

4. Select the type of the new element as required.

Note: You can change the splitter ratio to 2:N, if the measurement supports it.

Note: The splitter element type is not available for iOLM bidirectional files.

5. Click OK to apply the changes or Cancel to discard them.

Note: If an element is added, an asterisk (*) is displayed in the Position and Type 
columns.

Element Section

Element Section
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To add an element to a group of elements:

1. Open an iOLM file.

2. Select an element from an existing group of elements where you want 
to add the new element, then from the Measurement menu, select 
iOLM, and Add Element.

3. Select whether the new element will be located before or after the 
element you have selected.

4. Select the type of the new element as required.

5. Click OK to apply the changes or Cancel to discard them.

Note: When an element is added to another element with no sub-elements, the 
current element will become a merged/group element. You can view the 
details in the Elements Table tab.

Note: When you add an element to a group of elements, it impacts the pass/fail 
status of the grouped elements.
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To add an existing element to other fibers:

1. Select the element you want to add.

2. From the Measurement menu, click iOLM, and then select Add to 
Other Measurements.

Note: The application displays a warning message when the element cannot be 
inserted at the specified location.

Note: The Add to Other Measurement feature is not available if you cannot use 
it (for example, if you are trying to use it while being in Cable view, and that 
the element is already present in all of the fibers).

Modifying Element Types

You can view and modify element types that you see in the link view. You 
can change the type while being in either Fiber view or Cable view, as well 
as the Elements Table tab. Changes done in the Cable view or on the cable 
at the top of the Fiber view are done on each fiber included in the cable.

Note: For iOLM bidirectional files and multimode files, the splitter element type is 
not available.

Note: You cannot modify the type of the element if they are out of range or if they 
are macrobends.

Note: If an element type is changed, an asterisk (*) is displayed in the Type 
column.

Note: The items available in the list depend on the characteristics of the selected 
element. It may not be possible to change the element type.
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You can edit the properties for iOLM elements and sections. Event 
properties that cannot be edited are shaded.

To edit iOLM element properties:

1. Click on the element or section for which you want to change the 
properties.

2. On the Measurement menu, select iOLM, select Element, and click 
Properties.

3. Modify the properties as needed. The editable values are shown in a 
white background.

Note: The comment that you enter in the Comments field is displayed as a tooltip 
when you hover the mouse pointer over the element in the graph area and 
element table.

4. Click OK to confirm your changes.
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Deleting Elements

The application allows you to delete the manually added elements as well 
as the elements found by analysis. You can delete the elements either the 
Fiber view, the Cable view, or the Element Table tab, the procedure is the 
same. An element removed from the Cable or on the cable at the top of the 
Fiber view view is removed from all fibers included in the cable.

The application does not allow you to delete the following type of 
elements:

 Splitters 1:N and 2:N

 First connector

 End of fiber

 Out of range

 Link start element

 Link end element

To delete an element:

1. Open an iOLM file.

2. Select the element or elements which you want to delete.

3. Right-click on the link view, and click Delete Element.

4. A confirmation message is displayed. Click Yes to continue or No to 
cancel it.
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Managing Custom Elements

On a given link topology, it is possible to have different types of splices, 
connectors, and other kinds of elements. For this reason FastReporter 2 lets 
you create custom elements as per your requirements. You can also 
configure the details such as pass/fail thresholds.

The application allows you to add, modify or delete custom elements in 
the test configuration. You can also add the custom element in the iOLM 
configuration file and apply it to the selected measurement.

You can add custom elements of two types: splice or connector. Each 
custom element must have its unique name.

Note: When more than one iOLM measurements are selected, the new custom 
element will be added to the test configuration in all selected 
measurements.

Note: When more than one iOLM measurements are selected, the application 
displays all custom elements included in the test configuration for each 
iOLM measurement selected.
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To add a custom element:

1. Open an iOLM file.

2. Click on Custom Elements under the Summary tab.

3. Click  in to add a new custom element.

4. Enter a name for the element.
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5. Select the custom element type.

6. Press OK to save the changes and close the dialog box, or press Cancel 
to exit without saving.

Once your custom elements are added, they become available in the list of 
available element types. You can find information about changing the 
element type in Modifying Element Types on page 290.

The application allows you to view the pass/fail threshold for each custom 
element of the test configuration even if the FR2-FC option is not activated. 
If multiple iOLM measurements are selected, the application displays the 
pass/fail threshold for each custom element included in each test 
configuration of the selected iOLM measurements.

If the same custom element is included in more than one iOLM 
measurements and the threshold values are different, the application 
displays all different threshold values separated with a semicolon.

Note: You can edit the loss pass/fail thresholds for each custom element only 
when the FR2-FC option or the trial is activated.
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To modify a custom element:

1. Open an iOLM file.

2. Click on Custom Elements under the Summary tab.

3. Click on the custom element name under the Element Name column 
and modify it as needed.

Note: If the element is in use, you cannot modify it.

4. Press OK to save the changes and close the dialog box, or press Cancel 
to exit without saving
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To delete the custom element:

1. Open an iOLM file.

2. Click on Custom Elements under the Summary tab.

3. Select the custom element that you want to delete.

4. Press  to delete the custom element.

Note: If the element is in use, you cannot modify it.
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Enabling 2:N Splitters

2:N splitters can be used to create network redundancy. If a network break 
occurs, you can still connect through the other network branch. This 
ensures active communication while the repairing of the broken network 
is in progress.

Note: The application allows you to use the 2:N splitter feature in the iOLM 
configuration file and you can only use the 2:N splitter feature for splitter 
ratio stage 1.

In the splitter ratio stage 1 field, if 1:? or None is selected and you enabled 
the 2:N splitter option, the 1:? and None are replaced by a 2:2 splitter value.
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To enable a 2:N splitter:

1. Open the iOLM configuration file.

2. From the Summary tab, enable the 2:N Splitter option.

3. Select the desired ratio for stages 1, 2 and 3.

In the iOLM file, you can view the 2:N splitter value in the Link composition, 
and select the element type as 2:N splitter if the selected measurement 
supports the 2:N splitter values.
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Setting Launch and Receive Fibers on Elements

You can change Link Start Element (A) and Link End Element (B) on the 
link. The application also allows you to change the launch fiber length and 
receive fiber length on both new and existing elements. If no element is 
located in this position, a new element is created.

You can set the launch and receive fibers in both Fiber and Cable views, as 
well as the Elements Table tab. However, if you are setting them in Cable 
view, or on the cable at the top of the Fiber view, the operation must be 
possible on all of the fibers included in the cable.

To set the Launch fiber and Receive fiber on an existing element:

1. Open the iOLM file.

2. Select the element that you want to set as the launch/receive fiber 
element from the link or fiber views. Right-click on the element, and 
select Set Element as Link Start or Set Element as Link End.
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To change the launch fiber and receive fiber positions:

1. Open the iOLM file.

2. Enter the launch fiber length and receive fiber length in the Test 
Settings table under the Summary tab.

When the launch fiber length and receive fiber length are changed, a 
partial analysis is performed. In this partial analysis, the values for link 
length, link loss, link ORL, element position, element section length, and 
diagnostics are recalculated. This partial analysis does not change the 
elements you have added or the elements you have changed in the link.

Note: If the entered launch fiber length and receive fiber length are not valid, the 
application prompts an error message. If no element is present at the 
position, then a new element is automatically inserted in that place.

Note: If a macrobend is set either as link start or link end, a new connector is 
added and that element will be set as link start or link end.
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Analyzing Measurements (FR2-FC Mode)
You can recalculate the acquisition results. However, when the trace is 
analyzed, the manually added elements will be removed from the link and 
the element details table is refreshed accordingly.

Note: You cannot analyze the unidirectional files created by the loopback process.

To analyze measurements:

1. In the Measurements tab, select the measurements to analyze.

2. In the Measurement menu, select iOLM, and click Analyze.

Using the Failed Element Filter
In order to quickly see which measurements are faulty, you can apply a 
specific filter to show only the failed element.

To activate the failed elements filter:

In the Element Table tab, right-click in the table, then select View Failed 
Items.
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Generating a .sor File From iOLM 
Measurements (FR2-FC Mode)

With FastReporter 2, you can generate OTDR .sor files from iOLM files for 
each measurement.

To generate an OTDR .sor file:

1. Select single or multiple iOLM files from the Files Window.

2. From the File menu, click on Export, and select To OTDR SOR file.

3. Select what you want to do with the resulting file:

 Export it to the desired location and open it.

 Export it to the desired location only.

 Create a temporary file, kept in memory only. This is useful if you 
want to create reports, for example.

4. If you choose to export the file, select a location for it.
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5. Select the type of file you want to as the result of the export.

6. Click OK.

Note: If a .sor file with the same name already exists on disk, a confirmation 
message is displayed to overwrite the existing file.

Note: The wavelength is automatically appended to the file name when the iOLM 
measurement contains more than one wavelength.

Note: When you attempt to generate a .sor file and the iOLM measurement does 
not contain the necessary intermediate OTDR measurement, the .sor file is 
not generated.

When an attempt to generate the .sor file is done and the iOLM acquisition 
state is not completed or interrupted, the application prompts an error 
message explaining the origin of the problem and the solution to avoid it.
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Managing Configuration Files (FR2-FC Mode)
You can create a new configuration file as well as apply configuration 
settings to existing measurement files.

Creating Configuration File

The File menu allows you to create a configuration file and the created file 
is saved in the configuration file list. You can customize this configuration 
to fit your needs.

To create a configuration file:

1. From the File menu, select New, and iOLM Configuration.

2. Enter the desired file name in the Save As dialogue box and click Save.
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3. In the Identification tab, enter the desired identifiers for your files, as 
well as the auto-incrementation scheme you want to use.

4. In the Summary tab, select the various information for your test 
settings and link information. If your files were acquired using an 
iCERT-enabled unit, you can select the fiber type here. If your files 
were acquired with an Optimode, you can select it here as well.
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If you want to change the SOR pulse and acquisition time, click SOR 
Pulse Editor, then enter the new pulse and time values to use.

Note: If no pulse value is available, the pulse and acquisition time are set to 
“none”.

5. In the Thresholds tab, enter the threshold values according to your 
needs. If you want to include specific certification standards for your 
iCERT files, you can do it here.

6. Save your changes once you are done.
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Applying Configuration Settings

You can use the settings of a configuration file, such as identifier labels and 
thresholds, and apply them to a file you select in the list.

The configuration files are saved in the following location in your 
computer:
C:\ProgramData\Exfo\FastReporter2\Standard\Configuration Files

To apply the configuration settings:

1. Select an iOLM file from the Files tab.

2. From the Tools menu, select iOLM, and Apply Configuration.

3. Select the desired configuration file, click Apply, and OK.

Note: If the configuration you want to use is not in the list, you can use the Import 
button to add it.

Note: If the configuration file is TIA certification compliant, it will be indicated at 
the beginning of the row.
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Understanding Diagnostics
This section explains the diagnostics feature available in the intelligent 
Optical Link Mapper application.

Diagnostics are used to provide additional information about detected 
problems or ambiguous measurement situations, such as root cause 
possibilities for the fail status of a link element. The diagnostics provide 
help to troubleshoot faulty connectors, understand why link elements are 
tagged as fail or unknown, indicate unexpected instrument or test 
conditions and so forth.

Link elements with an associated diagnostic are marked with an  icon, 
and the diagnostics are displayed in the Element tab. More than one 
diagnostic can be associated with any given element.

If you are viewing multiple measurements in the Cable view and the 
elements present an anomaly (for example, the elements are not of the 
same type or do not have the same threshold values), you will notice an  
icon on the upper right-hand corner of the element instead.

Element diagnostics are associated with specific link elements issues. 
Each failed link element will have associated diagnostics to assist in 
troubleshooting. Some elements, such as macrobends, will have 
associated diagnostics even with a pass status.

You can see the details about the diagnostics in the Elements Table tab.
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Viewing Power Meter Results
Power meter results are displayed in the OPM and PPM table. For more 
details, see Viewing Power Meter Results on page 233.

Managing Bidirectional iOLM Files
FastReporter 2 allows you to view and create bidirectional iOLM files. 
Selecting each unidirectional file or the resulting bidirectional file displays 
the corresponding data in the Results window.

Creating a Bidirectional iOLM File

The application allows you to create a bidirectional iOLM file from two 
matched iOLM measurements of opposite directions. You can create more 
than one file at once, providing that each have their matching file.

The measurement files must meet the following criteria:

 The measurement lengths in both direction are the same.

 There are no splitters in the link elements.
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To create a bidirectional iOLM file:

1. If you have not done so already, activate the iOLM bidirectional file 
creation option, as explained in Modifying Tolerance and Bidirectional 
Settings on page 252.

2. Select two matched iOLM files of opposite directions.

3. Click on Tools > iOLM > Create Bidirectional Files.

4. Select the location where you want to save the bidirectional file.
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5. Select the desired file naming options.

 Select A->B filename or B->A filename to use the selected A->B 
or B->A file name.

 Select Identifiers to save the bidirectional file as per the matched 
identifiers. The identifiers name is formed from the identifiers 
order displayed in the Matched Files tab, separated by the 
separating character you have selected.

 Select Autonaming to enter a prefix and a suffix to create the file 
name.
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6. Select which documentation will be used for the bidirectional 
measurement.
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7. Select which thresholds you will use in the bidirectional measurement.
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8. If you want to keep the original unidirectional files open after creating 
the bidirectional file, select the corresponding option.
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9. If you want bidirectional files created automatically using the current 
settings, select Do not display the dialog. Any future bidirectional file 
creation will use these settings.

Note: To enable the iOLM Bidirectional File Creation window again, follow the 
instructions in Modifying Tolerance and Bidirectional Settings on page 252.

10. Click OK to save your settings.
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Working with Virtual Bidirectional Files

Virtual bidirectional files are a way to preview the resulting measurement 
when you select two matching unidirectional measurements without going 
through the process of fully creating the bidirectional file. The display in the 
link view, Threshold, Elements and Results tables are the same as they 
would if you are viewing an actual bidirectional measurement. The order 
of display for the elements depend of the A -> B measurement. Since this 
is a viewing option only, you cannot perform operations such as adding or 
removing elements when the virtual bidirectional mode is active.

Note: You cannot create bidirectional files with multimode measurements.

To activate the virtual bidirectional file mode:

From the View menu, select iOLM, then Display Virtual Bidir.
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Viewing Section Length for Multiple 
Measurements

When multiple measurements are opened, the application displays the 
section length on the graph. You can also choose to hide it.

To view or hide the section length:

1. Open multiple iOLM measurements.

2. Right-click on the Fibers view and select View section Length.
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Matching Link Elements with a Reference
When any measurement is selected as reference measurement, all 
elements of the reference measurement are considered as reference 
elements. The application uses an algorithm with tolerance to match these 
elements. For more information of setting the tolerance, see Modifying 
iOLM Settings (FR2-FC Mode) on page 271.

Note: If you have selected a reference measurement, the link length displayed is 
that of the reference measurement.

To set a reference measurement:

In the Elements Table tab, right-click on the measurement that you want to 
use as the reference, then select Set as Reference. The measurement 
changes color in the table to indicate its new status and the corresponding 
row is blocked at the top of the table so that you always see it even when 
scrolling down the list of other measurements.
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Matching Link Elements Without a Reference
When multiple measurements are selected, the elements from different 
measurements are matched according to their position (the position of the 
elements can be slightly different). The application uses a algorithm with 
tolerances to match these elements. For more information of setting the 
tolerance, see Modifying iOLM Settings (FR2-FC Mode) on page 271.

When no reference measurement is selected, all elements of the first 
measurement are considered as the reference elements. In the remaining 
traces, if some elements are not matching, they are also included as 
reference elements.

Matching is always done from left to right in accordance with the element 
location. If elements are present before the link start (A), the matching will 
be done from right to left.
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Displaying Statistics for Matched 
Measurements

When displaying matched measurements, it might be useful to view 
statistics for them. The statistics are displayed for:

 Fibers (includes loss, reflection and attenuation data for splices, 
connectors and sections), which are displayed on the far right of the 
Elements Table tab.

 Elements and Sections (includes for loss, reflection and attenuation 
data for each wavelength for each event and sections), which are 
displayed at the bottom of the Elements Table tab.

The statistics displayed are the minimum value, the maximum value, and 
an average for the selected files. If you click on the minimum and 
maximum values, the corresponding element is highlighted in the Fiber or 
Cable views.

Note: In the case of Fiber statistics, the highlighted element is based on the loss 
value.

Note: You must have enabled the corresponding item for the statistic to appear. 
For example, if you chose not to display the positions, the corresponding 
statistic is also hidden.

To display the statistics:

1. Select the multiple measurements for which you want to view the 
statistics.

2. In the Elements Table tab, right-click in one of the columns, and select 
the type of statistics you want to view.
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Using the FTTx Mode
If you are working with files that include splitter elements, the FTTx view 
can help you better visualize your results. This type of view will invert the 
links so that the results are displayed from event B to event A, that is, from 
the optical network terminal (ONT) to the central office (CO).

In the Measurements tab, measurement files containing at least one 
splitter element are identified by a mark in the FTTx column.

Note: While in FTTx mode, you cannot create bidirectional files, loopback files, or 
generate application-based reports.
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To enable the FTTx mode:

1. On the Settings menu, click iOLM and then the General tab.

2. Enable the mode.

3. Click OK.
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To display the FTTx view:

Right-click in the Link view, then select the FTTx view. 

OR

Select the view in the View > iOLM menu.

The FTTx links will be identified with specific icons in the Link view, and 
has its own tab in the result table.

Note: The FTTx Results table appears only if you select FTTx measurements. As 
soon as you include a regular iOLM measurement, the tab will be hidden.
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Measurements

Once you have added files to your list, you can view the results for the 
measurements they contain in the Results window, as well as 
identification information about them.

The tabs available depend on the measurement type selected. For 
example, for OTDR measurements, in addition to the Identification and 
Summary tabs, there is also the Event Table tab, and the Markers tab, if 
available for the selected measurement.

Editing Measurement Identification 
Information

You can edit several of the fields on the Identification tab in the Results 
pane. Other fields are populated from information in the measurement file, 
if present, and will appear shaded.

Your FastReporter 2 application allows you to edit the general identification 
information for single-fiber as well as multiple-fiber connector FIP files.

To edit the identification information:

1. Open the required file.

2. Select the measurements for which you want to view or modify the 
identifier labels.

3. In the Results window, select the Identification tab.
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4. Click in the white section to the right of a field label to select it, then 
enter the desired value.

Note: The identifier labels are not editable if iOLM measurements are selected 
with any other type of measurement (for example, OTDR).

Note: When the identifier label is selected as None, the values are not editable.

Modifying Auto-Increment Values for iOLM 
Configuration Files

You can set auto-increment values for several items in your iOLM 
measurement files.

To modify the auto-Increment values:

1. Open an iOLM configuration file.

2. Select the measurements for which you want to modify the auto 
increment values.

3. In the Results window, select the Identification tab.
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4. For each item that you want to include in the auto-increment process, 
enable the Auto-Increment option.

5. Modify the start, stop, and step values for the items as needed.

Note: The step value must be smaller than the difference between the start and 
stop values. If the start is greater than the stop, then the identifier value 
begins decrementing by the specified step.
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Modifying the Calibration Date for OTDRs

Sometimes, older OTDR models do not provide the right calibration date 
required to view the data and perform your analysis. You may need to 
change it.

In your OTDR result display, you can see the calibration dates for units A 
and B, if there are any. You can modify the calibration date of the OTDR file; 
the updated calibration date is saved in corresponding OTDR file.

The application allows you to edit the calibration date for the OTDR 
measurements based on the following conditions:

 If the file direction is A->B, you can change the date of location A.

 If the file direction is B->A, you can change the date of location B.

 If the file is in OTDR Bidir format, you can change the date of both 
locations A and B

Note: The application displays the date range for up to the last ten years for the 
calibration date. If no date is indicated, and you want to edit the calibration 
date, the application displays the date range up to the previous month.
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To edit the calibration date:

1. Select one or several OTDR measurements.

2. Change the calibration date in the appropriate location.

Note: An asterisk (*) will indicate that the date was changed.
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Modifying Additional Information

You can modify additional information for OLTS and OPM/PPM 
measurements, such as comments relating to the cables or fibers.

Note: If a cable comment is present, the application merges this comment with 
the comment of each fiber measurement of this cable. The cable comment 
and the fiber comment are separated by a hyphen (-).

To modify the additional information:

1. Open the required file.

2. Select the Identification tab.

3. Click on the Comments field under the Additional Information 
section to modify the additional information.
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Modifying Summary Information (FR2-FC 
Mode)

When viewing your test results, you can quickly find a summary of the 
information, and modify the related test settings as needed to view the 
impact on the measurement.

Note: The items displayed in the Summary tab will depend on the type of file you 
are viewing.

To edit the summary information:

1. Open the desired file.

2. Select the measurement for which you want to view or modify the 
summary information.

3. Click in the field to the right of the field label.

4. Enter a value.
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Viewing and Sorting Files or Measurements
You can view and sort files and measurements according various criteria, 
depending on the type of file or measurements you are viewing. You can 
sort the files according the header, or you can do manual sorting.

The available file types at the top window will determine which items 
displayed:

 CD

 FIP

 iOLM

 Instruments

 Operators

 Job

 Locations

 OTDR

 OTDR (DWDM)

 PMD

 OPM

 PPM

 OLTS (Loss)

 OLTS (ORL)

 Certification
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Note: During manual sorting, if the files are not adjacent, you need to group them 
by pressing Ctrl+G.

When you have sorted one of the tabs, you can apply the same sorting 
criteria to the two other tabs. This is particularly useful to send your criteria 
to the Matched Files tab, since it is used to determine the order in which 
the files appear in your reports.

Right-click to select 
columns to display. 
Change the order 
by dragging the 
column to a new 
location (available 
for OTDR, iOLM and 
OLTS only).

In the Files tab, you 
can select to display 
the Identifiers 
column.

Select which items to
view from the list.

Depending on which
types of files are

displayed, the available
items will differ.

Right-click to
select other

sorting criteria.

Click to sort according
to a specific column.

Click and drag to change
position manually.
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To apply sorting to other windows:

1. Select the files in the Files window or measurements in the 
Measurements window.

2. Right-click and select Apply sort to other windows.

If you have sorted the files, click  to apply the sorting to the 
Measurements and Matched Files tab. If you have sorted the 
measurements, click  to apply the sorting to the Files and Matched 
Files tab.

Note: When files in the Matched Files tab are not of the same type and the 
sorting is based on the Files or Measurements tabs, it may be possible that 
the sorting is not exactly the same, as priority is granted to file type and 
priority.
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Saving Measurement Files
You can save the changes you make to selected measurement files or to all 
measurement files in the current project.

When saving several files at a time, you can set an automated naming 
pattern so that they all follow the same naming scheme. Depending on the 
type of files you are saving, different items will be available in the window.

To save selected measurement files:

1. In the Files tab, select the file or files that you want to save.

2. On the File menu, click Save Selected Files.

To save selected measurement files under a different name:

1. In the Files tab, select the files that you want to save.

2. On the File menu, click Save Selected Files As.

3. Select the location for your files.
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4. Select whether you want to use the original file names, or if you want 
to use the file documentation elements. If you are using the original file 
names, go to step 9. Otherwise, proceed as instructed below.

5. If your files are in OTDR format, you can select a different format to 
which to save the files.
336 FastReporter 2



Viewing and Editing Measurements
Saving Measurement Files
6. Select which items you want to include in the name. You can change 
the order of the items using the arrow buttons.

7. Select the type of character you want to use as a separator between 
the items.
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8. If you have selected to add a custom field to the file name, you can 
enter the value you want in the corresponding box.

9. Click Save to confirm your action.

Note: PMD files will be saved with the .pmdb extension, ConnectorMax files will 
be saved with the .cmax2 extension, and OLTS files will be saved with the 
.oltsx extension.

To save all files:

On the File menu, click Save All. All measurement files in the current 
project and the project file are saved.
338 FastReporter 2



Viewing and Editing Measurements
Using the Identifiers View
Using the Identifiers View
Another way to filter and sort your measurements can be according to the 
identifiers included in them. These identifiers are displayed in a tree view 
where you can expand or collapse results for easier management and 
viewing purposes. When you click on a specific part of the tree view, the 
resulting files are displayed in a table on the right of the tree. This table 
behaves like the Measurement tab and allows you to perform the same 
actions regarding sorting and selection.

The identifier information used to sort the measurements are found under 
their respective Identification tabs. Each identifier down the list in the 
table creates a node in the tree. The identifiers used for matching the files 
are those you have selected as active in your project settings. See Matching 
Files on page 51 for more information.

Pass/fail
status

Parent
node

Child
node
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The items in the tree view also show pass/fail icons so that you can quickly 
see if there are problems for specific measurements.

You can regroup identifiers, rename them, and move the measurements 
within the tree to assign new identifiers to them. The identifiers used in the 
list

To show and select measurements:

1. From the main window, select the Identifiers tab.

2. Select the item you wish to view in the tree. All measurements on this 
node, as well as those in the children nodes are displayed in the table 
on the right. The identifiers used in the tree view are shown in a 
column, you can therefore sort the results using this criterion.

You can select more than one node using the Ctrl key. The multiple 
selection will work for nodes at the same level, with the same parent.

Note: You can sort the measurements in the table as you would in the 
Measurements tab. See Viewing and Sorting Files or Measurements on 
page 332.

To move measurements within a same branch:

1. Click on the node or measurements to select them.

2. Drag them to the desired node. The information will be updated 
automatically.

3. Confirm the move.

IMPORTANT
The identifier information previously contained in the files you are 
moving will be replaced with the identifier information of the new 
node.
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To change the identifiers of all measurements in a specific node:

1. In the tree, select the node that you want to change by right-clicking on 
it.

2. Select Rename.

3. Enter the desired new name. 

The values in the Identification tab are changed for each 
measurements and the nodes are updated according to the new 
name.
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13 Generating, Previewing and 
Printing Reports

FastReporter 2 can print and generate thee types of reports:

 Measurement report: This type of report contains one measurement 
type and one measurement at a time.

 Summary report: This type of report combines different measurements 
or several measurements of the same type.

 Reports as they are presented when using the OTDR, iOLM, OLTS and 
FIP applications.

The following options are included in measurement and summary reports:

If you want to include other options in a report, you must modify the 
associated report template using Crystal Reports. For more details, 
see Creating and Modifying Report Templates on page 358. You can modify 
the report using Excel template. For more details, see Using Excel Report 
Templates on page 361.

For examples of the reports that you can generate with FastReporter 2, see 
Report Samples on page 431.

Property or Element Option

Tools properties Distance units

OTDR properties Pulse baseline

Events calculation and thresholds

Numeric values precision

Pass/Fail thresholds

Macrobend tolerances

OPM, PPM, iOLM, OLTS, FIP, CD, and 
PMD properties

Pass/Fail thresholds

Data graph Zoom
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Generating Measurement or Summary 
Reports (FR2-FC Mode)

You can easily generate a variety of reports in either electronic format or 
print them out for later consultation (see Printing Sumary or Measurement 
Reports on page 350 for details on printing).

FastReporter 2 can generate reports in the following formats:

Note: The Crystal Reports (PDF format) have a limited the number of 
measurements that you can include which changes depending on the files 
you are including. For reports including larger amounts of files, use an Excel 
template. You will be notified if the number of files in the report exceeds 
what the format (or FastReporter 2 itself) can handle.

File Type Application

*.xls, *.xlsx Microsoft Excel

*.pdf Adobe Reader

*.html Any Web browser
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To generate a report:

1. Select measurements or files in the Measurements or Files tabs.

2. On the Tools menu, click Report.

3. If needed, select the location where to save the report.

4. In the Template list, select a report template.
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5. You can have the report generated in one file, or multiple files 
depending on the number of rows or matched groups present in the 
window. To separate the report into multiple files, select the 
corresponding option.

6. If you select a multiple-file report, select how the files are named:

 Identifiers: the identifier present in the measurement

 Original Measurement Filename: the measurement file name.

Note: If you clear the Generate individual report files option, the Launch 
report viewer option is automatically selected.

Note: If you want to generate the report for more than one measurement files, the 
list of measurement files involved in the group of matched measurements 
is displayed in the Select Report Filename window.

7. Select whether you want to generated the file name based on the 
measurement, or if you want to enter a customized name.
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8. Depending on your choice, select the file name from the list, or enter it 
directly.

9. Click OK to close the window.

10. Enter a name for the report.
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11. In the File Type list, select whether you want to save the report as a 
PDF, html, or Excel file.

Note: By default, the file type is selected as Excel (*.xls) when you run the 
application for the first time. The templates displayed on-screen depend on 
the file type you have selected.

12. Click OK.

Note: The application retains the last selected used file type and report template 
when you restart the application.

IMPORTANT
You should always enable macros in Microsoft Excel before 
generating the report in that format. Refer to the Excel help for 
information on how to enable macros.
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Previewing Summary or Measurement Reports
You can view your reports on-screen before you print them.

Note: The print preview function is only applied on the reports created using the 
Crystal Report templates.

To preview a report:

1. Select measurements or files in the Measurements or Files tab.

2. On the File menu, click Print Preview.

3. In the Select Template File dialog box, select a report template.

4. Click OK.

In the print preview window, click , and select a zoom option from 
the list, if desired.

To select a different summary report template, click , and select a 
template in the Select Template File dialog box.

5. To close the Print Preview window, click Close.

Note: Only the Crystal report templates are visible during print preview and print.
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Printing Sumary or Measurement Reports
FastReporter 2 allows you to print your reports for future consultation.

To print a measurement report:

1. Select measurements or files in the Measurements or Files tab.

2. On the File menu, select Print.

3. If needed, change the printer or printer settings.

4. Select a measurement report template.

5. Click OK.
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Generating Application-Related Reports
Generating reports such as you would see on the OTDR, iOLM, OLTS and 
FIP applications is done in a similar manner. The reports can be generated 
in PDF, XML or Mhtml formats.

Note: OLTS reports are available in PDF format only.

To generate an application-related report:

1. From the main window, select the Tools menu, then OTDR, iOLM, 
OLTS or FIP.

2. Select the corresponding Generate Application Report in the 
sub-menu.

3. Select whether you want to put the report in the same location as the 
source files, or select a new location.
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4. Select the format you want to use to generate the report.

5. Select the items to include in the report. The list of available items will 
vary depending on the application you have selected.

6. Click OK to generate the report.
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Using the Clipboard (FR2-FC Mode)
You can copy and paste the measurement graph from FastReporter 2 into 
other applications. For example, you can paste a graph into an e-mail 
message, or applications such as Microsoft Excel for use in existing 
measurement reports.

To use the clipboard:

1. Click on the graph in FastReporter 2.

2. On the Edit menu, click Copy.

3. Switch to the application you want to paste the graph into (e-mail 
client, spreadsheet, word processing application, etc.).

4. Place the mouse pointer where you want to insert the graph and, on 
the application’s Edit menu, click Paste.
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Importing and Exporting Templates
You can import existing templates you have elsewhere, or export them to 
other locations easily.

To import a template:

1. From the Tools menu, select Reports.

2. Navigate to the desired location, then click Import.

3. Click  to access the file location.
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4. Browse to the current location of the template, then select it. You may 
have to change the file filter at the bottom of the window to see the 
appropriate format.

5. Click Open.

6. If desired, rename the template. If you want to add a specific folder 
name for your report, use the corresponding button.

7. Click Import. The new template is now available.
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To export a template to another location:

1. From the Tools menu, select Reports.

2. Select which report you want to export, then click Export.

Note: The name of the report automatically bears the word Copy to prevent 
unintentional overwrites.
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3. Select the location where you want to export the file. If needed, you 
can use the New Folder button to add a folder to suit your needs.

4. Click Save.
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Creating and Modifying Report Templates
You can create a new report template, or to modify an existing report 
template using the Crystal Reports application. Excel reports are also 
customizable. For details on using Crystal Reports, refer to your Crystal 
Reports product documentation. For details on using Excel template, 
see Using Excel Report Templates on page 361.

To create a new report template, EXFO recommends that you start with an 
existing FastReporter 2 report template and modify it as required. This way 
you will have access to the database fields for populating the report with 
measurement data. Once you are done, save it using a different name that 
suits your testing needs.

To access the available report templates:

Select the File menu, then Print Preview.

OR

Select the File menu, then Print.

OR

Select the Tools menu, then Report.
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Using Crystal Report Templates
Using Crystal report templates you can modify the PDF and HTML report 
templates.

You can access the Crystal report template from 
C:\ProgramData\EXFO\FastReporter 2\<version>\English\ReportTemplate.

To modify a PDF or HTML report template:

1. Start Crystal Reports.

2. On the File menu, click Open.

3. On the Open dialog box, select and open the folder containing the 
report template you wish to modify.

4. Select a report template and click Open.

5. On the File menu, click Save As.

6. Type a new name for the report. This will preserve the original 
FastReporter 2 report templates.

7. Modify the template by modifying or adding labels, header and footer 
information, company logo, etc.

8. Add fields to the report as needed by selecting them from the Field 
Explorer window.

9. Once you have finished modifying the report, click Save on the File 
menu.
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To add a report template to the list of available templates:

Save the template directly in the appropriate folder within the Report 
Template folder after you have modified it in Crystal Reports.

OR

Move the template into the appropriate folder within the Report Template 
folder so that it will be available on the Select Template File dialog box.

You can also create your own folders and subfolders within the Report 
Template folder to organize your report templates.

To remove a report template from the list of available templates:

In Windows Explorer, remove the files from the folder where it is located, 
either by copying it elsewhere, or by deleting it.
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Using Excel Report Templates
The default templates installed in FastReporter 2 are stored in 
C:\ProgramData\Exfo\FastReporter 2\<Version>\English\ReportTemplate

Each template has two sheets:

 A configuration sheet where you can select different tag settings for the 
report.

 A sheet with the actual report with all the “tags” that are used to 
generate the required report.

Configuration
selection Report selection
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Using the Configuration Sheet

The configuration sheet contains three parts.

 Flags

 Sheet Details

 Filter Details

Flags are used to specify to Excel how to handle specific behavior as well 
as data display. By default, you have access to two different flag settings, 
Apply Thresholds and Cell Merging. These flag settings are visible in the 
Configuration sheet. The table below contains details for each flag setting.

Setting Purpose Note

Apply Thresholds Apply pass/fail thresholds 
from FastReporter 2, that is 
change font and 
background color used in 
the application.

True = will use threshold 
from FastReporter 2

False = no threshold 
applied. It can use 
conditional formatting from 
Excel.

 Cell Merging Merges cells with matched 
records. For example, if the 
FiberID is the same for 3 
measurements, they are 
merged into a single cell.

To improve the 
performance, this option is 
always set to "False" in all 
the report templates, except 
in the FiberCharacteration 
template. This should be set 
to "True" when extra 
processing is done with 
Excel's Pivot table.
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Some non-mandatory, or supportive flags, are hidden. One or more can be 
added as needed.

Note: If the Excel sheet contains only an Image tag in cell A1, and that cell is 
merged with other cell, then the image will not be displayed in the report.

Note: The setting name should be written in one block without spaces. They have 
been separated on more than one text line in the table below for readability 
purposes only.

Setting Purpose Default 
Value

DisplayOnlyMatched
Measurements

To specify if only the data common to both matched 
measurements is to be displayed.

For example, if you match two measurements 
containing common and different wavelengths 
(measurement one has 1310, 1550 and 1625, while 
measurement two has 1310, 1410 and 1625), and the 
setting is set to true, the report data is displayed for 
every distinct wavelength.

FALSE

DisplayGraphPer
Measurement

To specify if a graph should be displayed for each 
trace in the measurement, or if all measurements are 
to be displayed in a single graph.

FALSE

MeasurementPerSheet Maximum number of measurements allowed per 
sheet. A blank value indicates that there is no limit.

Blank

WavelengthPerSheet Maximum number of wavelengths allowed per 
sheet. A blank value indicates that there is no limit.

Blank

MeasurementTypes To specify which measurement type should be 
supported. A blank value indicates that it supports all 
measurement types.

Blank
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The sheet details are used to specify if multiple sheets should be inserted. 
This table is not mandatory and is hidden by default.

Once the SheetDetails table is displayed, you need to specify the fields 
below to insert multiple sheets:

 SheetName: to specify the name of the sheet for which multiple sheets 
are inserted. If you rename a sheet, you must also change it in the 
sheet details to make sure that you generate multiple sheets in the 
report.

 AddMultipleSheets: to specify if multiple sheets should be inserted.

 Tables (optional): to specify which tables are used in a particular sheet.

 PrimaryTable: to specify the table from which you have to use distinct 
values and add multiple sheets for each value.

 PrimaryColumn: to specify the column name from the Primary table. A 
new sheet is inserted for each distinct value of the PrimaryColumn.

FillOnlyMatched
Wavelengths

To display data of common wavelengths. Used when 
data is coming from different origins and common 
wavelengths needs to be displayed.

For example, if your report includes iOLM, OTDR and 
FIP files, The iOLM wavelengths are treated first, then 
only the OTDR files with matching wavelengths.

FALSE

FillMatchedOLM
Measurements
InSingleRow

To display the details from two different iOLM files 
with different directions in a single row.(Used in 
iOLM cable summary reports).

FALSE

MergeAllSheets
InSingleSheet

To merge all sheets into the first sheet. FALSE

MergeSheets
ByIdentifier

To merge sheets with the same identifiers. FALSE

Setting Purpose Default 
Value
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Filter details are used to specify filter criteria. This is not mandatory, and 
should be used when filters are required. Filter details are not hard coded. 
You can specify the required filters; to do so the FilterDetails table must be 
present in the report template.

The FilterDetails table is divided into three columns:

 SheetName

 Range

 Filters

The sheet name is used to specify the sheet name for which you want to 
apply a filter. If you rename the sheet, you must change the name 
accordingly in the FilterDetails table for it to be identified correctly and 
apply the filters.

Note: It is not mandatory to specify sheet names if no filters are applied on that 
sheet.
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One sheet can have multiple filters.

The range indicates the address of the first cell and last cell for which you 
want to apply the filter, separated by a colon. The range must exactly 
match the range in the sheet; if you specify a filter range of $A$3:$C$3 and 
the actual range in the FilterDetails table is $A$3:$F$3, the formula is not 
applied because they are not considered as matching.

The filters are to specify conditions and support the AND and OR operators. 
You need to provide TableName.FieldName as a field. For example, 
OTDREventTable.IsEvent=true AND OTDREventTable.IsEventReflective 
=true AND OTDREventTable.EventLossAtoBPassFailStatus='Fail'.

An additional sheet is available, the Table sheet. The Table sheet is 
generated by a macro when a template is saved. It contains information on 
different tags present in the template and it will be used to generate the 
appropriate data set (result values) needed for the report.
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By default, this sheet is hidden. To view it, right-click on the name of the 
active sheet and select Unhide, then select Table and click OK.

Note: To create a new template, you must start from an existing template. 
Otherwise the Table sheet will not be created and the template will not 
work, as FastReporter 2 will not be able to generate the dataset needed.

Note: Since the Table sheet is be generated using a macro, you must enable 
macros to modify it.

The Report sheet is where you can define how you want the output (the 
report) to look like. The report sheet will contain different FieldName tags.

Field Name tags are the combination of TableName and ColumnName. 
(TableName.ColumnName), for example, Identification.FiberID. You 
should use the field names from the Universal sheet. For more information, 
see Using the Universal Sheet on page 374.
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You have to provide special prefixes and suffixes to the field name while 
designing templates. These prefixes and suffixes are used to perform the 
data insertion, and determine whether data should be filled in a single cell, 
if multiple rows should be inserted, or a block should be repeated.

Tags are categorized in five groups:

 Single Cell

 Multi Row

 Multi Column

 Block

 Image

The single cell tag organizes data in a single cell.If multiple values are 
available, they are separated by a semicolon. The prefix for this tag is <<, 
and the suffix is >>.

Example: <<Identification.TestDate>>

Excel 
template

Output in 
the report
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The multi-row tag inserts multiple rows in Excel. For example, if one file 
has three measurements, three rows are inserted. The prefix for this tag is 
$$, and the suffix is $$.

Example: $$OTDRSummary.Wavelength$$

The multi-column tag is used to process one single tag at a time. It does 
NOT insert new columns, but rather uses the existing columns. While 
designing the template, you should make sure that there are enough empty 
columns available after the Multi Column tag. If not, it will overwrite 
existing data.

The prefix for this tag is {{ and the suffix is }}.

Example, {{OTDRSummary.Wavelength_FiberSize}}

Excel 
template

Output in 
the report

Excel 
template

Output in 
the Report
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The Block tag contains several other tags. It indicates a structure such as 
that of the Event table, where you insert rows and columns. Only one block 
tag group should be specified per sheet.

Note: These tags are supported for the OTDR Event table and iOLM Element and 
Section tables.

The prefix for the block tag is ##, and the suffix is ##.

The prefix for inserting rows is [[, and the suffix is ]].

The prefix to insert column blocks is [[##, the suffix is ##]].

To add multiple blocks, such as for the iOLM element and section table, 
add a + sign between the prefix/suffix and the tag.

For example, adding a second block would look like this: [[+##tag##+]]

Adding a third block would look like this: [[++##tag##++]]

You do not need to add a + sign to add a row, as the number of rows will 
remain the same in the case of multiple blocks.

[[prefix and]] suffix to specify 
field for which column should 
be inserted.

[[##prefix and ##]] suffix to 
specify fields for which values 
should be filled for multiple 
rows and columns.

Required Report 
format
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To add blocks for loss, reflectance and attenuation, you have to add blocks 
for each wavelength. Fill the loss values first (insert a separate column for 
each wavelength), then reflectance and then attenuation.

As mentioned in the figure above, for loss the tag is

 [[iOLMElementsSectionDetails.Wavelength]] - To add columns

 [[##iOLMElementsSectionDetails.ElementLoss##]] - To add data row 
and column wise.

For the next block, you have to use the + sign. The next block tag will look 
like:

 [[+iOLMElementsSectionDetails.Wavelength+]]

 [[+##iOLMElementsSectionDetails.ElementReflectance##+]]

To add one more block for attenuation, you have to add two + signs. The 
next block tags will look like:

 [[++iOLMElementsSectionDetails.Wavelength++]]

 [[++##iOLMElementsSectionDetails. SectionAttenuation##++]]
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In the case of multiple tags in a single cell, since the tag related to the loss 
of an event/element or a section are not the same, you need to put the two 
possibilities.
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Since there is only one possibility for the reflectance, you simply have to 
put the corresponding tag.

The image tag uses (( as a prefix, and )) as a suffix.

Example: ((iOLMGraph.GraphFromApplication))

To modify an Excel report template:

1. Access the Excel report templates folder.

2. Create a copy of the report template that you want to modify.

3. Open the duplicate report template with Microsoft Excel.

4. Add new column information using the {{Tag}}. Refer to the Universal 
sheet for the list of supported tags. You can remove a column by 
deleting the cell contents.

5. Add new row information using the $$Tag$$. Refer to the Universal 
sheet for the list of supported tags. You can remove the row 
information by deleting the cell contents.

6. Change the logo using the header/footer option in Microsoft Excel.

Note: For more information on the Universal sheet, see Using the Universal Sheet 
on page 374.
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Using the Universal Sheet

The universal sheet provides the list of tags for different fields used in 
FastReporter 2. You can use these tags to create custom report templates 
for the fields such as GeneralSettings, MatchedFilesDetails, 
CustomIdentifier, Identification etc. related to the OTDR, iOLM, OLTS, CD, 
PMD, OPM/PPM, and FIP measurements. You can copy the supported tags, 
which are highlighted in green, to customize your Excel report template.

You can access the universal sheet from C:\ProgramData\Exfo\FastReporter 
2\<version>\ReportTemplate.
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Tools are available to help you better manage your data:

 Data transfer tools

 Related analysis tools

To start a data transfer application:

On the Tools menu, select Data Transfer, and select the application 
associated with the handheld unit to or from which you want to send or 
receive data.

Note: Data transferred from a handheld unit is not automatically added to your 
FastReporter 2 project. The files will be stored on your computer and you 
need to add them to your project using one of the methods described in 
Adding and Removing Measurement Files on page 43.

The corresponding application opens. Refer to the user documentation 
corresponding to the selected data transfer application for details.

To start an analysis tool:

1. Select the measurement in the Measurements tab.

2. On the Tools menu, click Start Related Analysis Tool.

Note: If you modify the measurement file in the related analysis tool, 
FastReporter 2 will ask you if you want to reload the file.

The corresponding application opens. Refer to the user documentation 
corresponding to the data analysis application you have selected for more 
details.
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Setting a Reference File or Measurement 
(FR2-FC Mode)

A reference file is used to compare fibers within the same cable, monitor 
fiber deterioration or compare fibers before and after installation. Once a 
measurement file has been added to a project, you can set it as a reference 
file. The reference file can then be used to automatically document other 
measurement files (see Automatically Documenting Measurement Files 
(FR2-FC Mode) on page 378).

For supported OTDR file formats, FastReporter 2 will display the reference 
measurement, in red, in the Event Table. The reference measurement can 
then be applied as a template (see Setting and Applying OTDR/OTDR Bidir 
Reference as Template (FR2-FC Mode) on page 166). You can set a file as a 
reference if the file format supports applying a reference as a template.
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To set a reference measurement:

1. In the Measurement window, select the file.

2. In the event table, right-click on the measurement in the Fiber ID, P/F, 
Wavelength or Dir. column, and select Set as Reference on the 
shortcut menu.

To set a reference file:

1. In the Files window, select the file.

2. On the Files menu, click Set as Reference File.
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Automatically Documenting Measurement 
Files (FR2-FC Mode)

The auto documentation feature can be used to copy selected 
identification information from a reference file to selected files. You can 
also use this feature to automatically assign fiber IDs to selected files.

Note: The auto documentation tool is available even if no reference file is 
defined; in that case, you cannot copy reference file information to files, but 
you can assign fiber IDs automatically if your selected files contain at least 
one fiber ID identifier.
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To use the auto documentation feature:

1. In the Files window, select the file that will serve as the reference file.

2. From the File menu, click Set as Reference File.

3. In the Files window, select the files to which you want to export the 
information.

4. From the Tools menu, click Auto Documentation.
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5. To copy items from the reference trace to your selected file, enable the 
corresponding option, then select the desired items.

The file information options listed are the identifiers included in the 
reference file and will differ depending on the file type.
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Using FastReporter 2 Tools
Automatically Documenting Measurement Files (FR2-FC Mode)
6. Select whether you want to copy the fiber IDs or all of the identifiers for 
all the files.

 If you are copying the fiber IDs, enter a prefix and suffix, and select 
the number of digits and increment value to use.
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Using FastReporter 2 Tools
Automatically Documenting Measurement Files (FR2-FC Mode)
 If you are using all of the identifiers, select which values to use in 
the list. You can modify the ID or start and stop values, indicate 
whether they will be incremented automatically, and what step 
value to use if that is the case.

The start and stop values can be either numeric or alphabetic

If you enter items separated by semicolons in the Values cell, this 
is the sequence that will be used for incrementation.

If your selection includes PPM files, OLT, ONT and location 
identifiers are displayed

If your selection includes OTDR, CD, PMD or OLTS files, Cable ID, 
Fiber ID, Location and Location B identifiers are displayed.

If your selection includes only iOLM and FIP files, custom 
identifiers are displayed; you will be able to change their names as 
needed.

Note: The information is copied to the selected files only if they contain the 
corresponding field.

7. Click OK.
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Using FastReporter 2 Tools
Using the Duplicated Measurements Tool (FR2-FC Mode)
Using the Duplicated Measurements Tool 
(FR2-FC Mode)

Sometimes, you might need to verify if tests were actually performed on 
fibers and that the analysis or results were not just copied and pasted there 
for speedy execution purposes. The duplicated measurements tool can 
help you to quickly locate such files.

When you select at least two measurement files, you can have 
FastReporter 2 automatically compare them and indicate which files show 
the same acquisition time, measurement wavelength and module serial 
number. These files can then be selected automatically so you do not have 
to look for them through your list, and batch processed.

Note: For the FIP, the application will match the fiber ID, test configuration name 
and test date/time of the measurement to mark the measurements as 
duplicated.

Note: In the case of bidirectional OTDR files, both directions are analyzed 
separately.
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Using FastReporter 2 Tools
Using the Duplicated Measurements Tool (FR2-FC Mode)
To search for duplicated information in files:

1. Open the files on which you want to use the tool.

2. Select the desired measurements.
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Using FastReporter 2 Tools
Using the Duplicated Measurements Tool (FR2-FC Mode)
3. Select the Tools menu, then Duplicate Measurements Tool.

The files are analyzed and the result appears on-screen. The duplicate 
measurement tool will display the unit serial number, test date/time, 
identifiers, and filename details.

4. By clicking Select Duplicate Measurements, you will automatically 
pick the detected files in the Measurements tab.

5. Proceed with any batch operation you want to perform for those files.
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15 Exporting Data for 
Postprocessing (FR2-FC Mode)

FastReporter 2 can issue data files in a simplified, raw format for further 
data processing purposes. The data is put in a Microsoft Excel (.xls) format.

To export data:

1. Select measurements or files in the Measurements or Files tab.

2. On the Tools menu, click Report.

3. If needed, select the location where to save the data.
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Exporting Data for Postprocessing (FR2-FC Mode)
4. In the Template list, select a data export template.

5. In the File Name box, type a name for the data file.
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Exporting Data for Postprocessing (FR2-FC Mode)
6. In the File Type list, select .xls.

7. Click OK.
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16 FastReporter 2 Examples
This chapter walks you through the tasks required to create and modify 
projects, reports, and templates. Detailed procedures are provided for 
creating the following examples:

 Creating an OTDR Bidirectional project: Create an OTDR project with 
OTDR traces going in both directions (that is, from A to B and from B 
to A).

 Creating a fiber characterization report: Create a printed or electronic 
fiber characterization report based on selected measurements.

 Creating a project template: Create a project template containing the 
properties and settings that you often use in your projects.
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Creating an OTDR Bidirectional Project
Creating an OTDR Bidirectional Project
You can change the directions of the OTDR files and create bidirectional 
projects.

To create an OTDR Bidirectional project:

1. On the File menu, point to New, and click Project.

2. In the list, click the template you want to use.

3. Click OK.

4. On the File menu, click Open File.

5. Select the OTDR files to be added to the project. The selected files are 
highlighted.

6. Click Open.

7. In the Files window, select the file or files for which you want to 
change the direction.

8. On the File menu, point to Direction, and click A->B or B->A.
392 FastReporter 2



FastReporter 2 Examples
Creating a Fiber Characterization Report
Creating a Fiber Characterization Report
Throughout the network life cycle, fiber characterization reports are 
essential for avoiding delays in service provisioning before system 
component installation, in results comparison for post-installation 
troubleshooting, and in ongoing network analysis and trending.

To create a fiber characterization report:

1. On the File menu, point to New, and click Project.

2. In the list, click the template you want to use.

3. Click OK.

4. On the File menu, click Open File.

5. Select multiple CD, OLTS, PMD, iOLM or OTDR files.

Note: You must select files with matching fiber IDs and Cable IDs.

6. Click Open to add the selected files to the project.

7. On the Settings menu, click Project Settings.

8. Click the File Matching tab.
Post-Processing Software 393



FastReporter 2 Examples
Creating a Fiber Characterization Report
9. Click By information present in the file.

10. Click OK.

11. In the Measurements window, select the measurements you want to 
include in the report.

12. To print or create an electronic version of the report, follow the 
appropriate procedure below.
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Creating a Fiber Characterization Report
To print the report:

1. On the File menu, click Print.

2. If needed, change the printer settings.

3. In the Template list, select Fiber Characterization.

4. Click OK.
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Creating a Fiber Characterization Report
To create an electronic version of the report:

1. On the Tools menu, click Report.

2. To change the destination folder, click , select a folder on the 
Browse for Folder dialog box, and click OK.

3. Select a file type for your report. You can select between Excel, PDF 
and HTML.
396 FastReporter 2



FastReporter 2 Examples
Creating a Fiber Characterization Report
4. In the Template list, click Fiber Characterization.

5. In the File Name box, type a name for the report.

(Example shown for 
Excel format)
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Creating a Project Template
Creating a Project Template
You can save the properties and settings you often use when creating 
projects in a project template. For example, you can save the pass/fail 
thresholds that you often use in your OTDR projects in an OTDR project 
template.

To create a project template:

1. On the File menu, point to New, and click Project.

2. In the list, click a template. Use an existing template that already 
contains some of the properties and settings that you want to use as a 
starting point, if applicable.

3. Click OK.
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Creating a Project Template
4. On the Settings menu, click Project Settings.

5. Under the Identification tab, enter the information to identify your 
template. Click into each item to activate it, then type in the 
information.

6. When you have finished making changes to the project properties, 
click OK.

7. On the File menu, click Save Project As Template.
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Creating a Project Template
8. In the File name box, type a name for the project template file.

9. Click Save.

10. On the File menu, point to New, and click Project.

IMPORTANT
FastReporter 2 automatically saves project templates in the Project 
Template folder. If you change the location, the template will not be 
available for selection in the New Project dialog box when you start 
a new project.
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Creating a Project Template
11. To set the new project template as the default template, click the file 
name, and click Set as Default.

12. Click OK to start a new project or Cancel if you do not wish to start a 
new project at this time.
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17 Troubleshooting
The table below presents common problems and their solutions.

Consulting the Online Help
Help for FastReporter 2 is available directly in your application.

To display online help:

On the Help menu, click Help on FastReporter 2.

OR

Press the F1 key.

Problem Solution

I have trouble installing 
the application

 Remove the old version before installing the new version.

 Turn off your anti-virus program and try to install the 
application again.

I cannot see my files in 
the application

Some file formats, such as CD and PMD, or older OTDR files, 
cannot be viewed in the 64-bit version of the application. Try 
to open them in the 32-bit version of the application.

In the case of the older OTDR files, you can try to save them in 
a newer format in the 32-bit version of the application, then 
open them in the 64-bit version of the application.
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Troubleshooting
Contacting the Technical Support Group
Contacting the Technical Support Group
To obtain after-sales service or technical support for this product, contact 
EXFO at one of the following numbers. The Technical Support Group is 
available to take your calls from Monday to Friday, 8:00 a.m. to 7:00 p.m. 
(Eastern Time in North America).

 

For detailed information about technical support, and for a list of other 
worldwide locations, visit the EXFO Web site at www.exfo.com.

If you have comments or suggestions about this user documentation, you 
can send them to customer.feedback.manual@exfo.com.

Technical Support Group
400 Godin Avenue
Quebec (Quebec) G1M 2K2
CANADA

1 866 683-0155 (USA and Canada)
Tel.: 1 418 683-5498
Fax: 1 418 683-9224
support@exfo.com
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A Description of Event Types
This section describes all types of events that may appear in the events 
table generated by the application. Here is a guide to the descriptions:

 Each type of event has its own symbol.

 Each type of event is represented by a graph of a fiber trace, which 
illustrates the power reflected back toward the source as a function of 
distance.

 An arrow points to the location of the event type in the trace.

 Most graphs show one complete trace; that is, an entire acquisition 
range.

 Some graphs show only a portion of the entire range to view events of 
interest more closely.
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Description of Event Types
Span Start
Span Start 
The Span Start of a trace is the event that marks the beginning of the fiber 
span. By default, the Span Start is placed on the first event of a tested fiber 
(typically the first connector of the OTDR itself).

You can make another event the start of the span you want to focus your 
analysis on. This will set the beginning of the events table at a specific 
event along the trace.

Span End 
The Span End of a trace is the event that marks the end of the fiber span. By 
default, the Span End is placed on the last event of a tested fiber, and is 
called the end-of-fiber event.

You can also make another event the end of the span you want to focus 
your analysis on. This will set the end of the events table at a specific event 
along the trace.

Short Fibers 
You can test short fibers with the application. You can even define a fiber 
span for short fibers by placing the span start and the span end on the same 
event.
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Description of Event Types
Continuous Fiber
Continuous Fiber 

This event indicates that the selected acquisition range was shorter than 
the fiber length.

 The fiber end was not detected because the analysis process ended 
before reaching the end of the fiber.

 The acquisition distance range should therefore be increased to a 
value greater than the fiber length.

 There is no loss or reflectance specified for continuous fiber events.

Reflected power 
(dB)

Continuous 
fiber

Distance
(km)
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Description of Event Types
End of Analysis
End of Analysis 

This event indicates that the pulse width used did not provide enough 
dynamic range to get to the end of the fiber.

 The analysis ended before reaching the end of the fiber because the 
signal-to-noise ratio was too low.

 The pulse width should therefore be increased so the signal reaches 
the end of the fiber with a sufficient signal-to-noise ratio.

 There is no loss or reflectance specified for end-of-analysis events.

Reflected power 
(dB)

Distance
(km)
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Description of Event Types
Non-Reflective Event
Non-Reflective Event 

This event is characterized by a sudden decrease in the Rayleigh 
backscatter signal level. It appears as a discontinuity in the downward 
slope of the trace signal.

 This event is often caused by splices, macrobends, or microbends in 
the fiber.

 A loss value is specified for non-reflective events. There is no 
reflectance specified for this type of event.

 If you set thresholds, the application indicates a non-reflective fault in 
the events table, whenever a value exceeds the loss threshold.

Reflected power 
(dB)

Distance
(km)

Non-reflective 
event

Linear downward slope 
due to Rayleigh 
backscatter
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Description of Event Types
Reflective Event
Reflective Event

Reflective events appear as spikes in the fiber trace. They are caused by an 
abrupt discontinuity in the index of refraction.

 Reflective events cause a significant portion of the energy initially 
launched into the fiber to be reflected back toward the source.

 Reflective events may indicate the presence of connectors, 
mechanical splices, or even poor-quality fusion splices or cracks.

 Normally, loss and reflectance values are specified for reflective 
events.

 When the reflective spike reaches the maximum level, its top may be 
clipped due to the saturation of the detector. As a result, the dead zone 
(minimum distance for making a detection or attenuation 
measurement between this event and a second nearby) may be 
increased.

 If you set thresholds, the application indicates a reflective fault in the 
events table, whenever a value exceeds reflectance or connector loss 
thresholds.

Reflected 
power (dB)

Distance
(km)

Reflective events

Clipped level
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Description of Event Types
Positive Event
Positive Event 

This event indicates a splice with an apparent gain, due to the junction of 
two fiber sections having different fiber backscatter characteristics 
(backscatter and backscatter capture coefficients).

Reflected power 
(dB)

Distance
(km)

Positive event
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Description of Event Types
Launch Level
Launch Level

This event indicates the level of the signal launched into the fiber.

 The figure above shows how the launch level is measured.

A straight line is plotted using least-square approximation to fit all trace 
points in the linear area between the first and second detected events.

The straight line is projected toward the Y-axis (dB) until it crosses the 
axis.

The crossing point indicates the launch level.

 <<<< in the events table indicates that the launch level is too low.

Reflected power 
(dB)

Distance
(km)

Launch level 
event position Second event

Launch
level

Linear area
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Description of Event Types
Fiber Section
Fiber Section

This symbol denotes a fiber section with no event.

 The sum of all fiber sections contained in an entire fiber trace equals 
the total fiber length. Detected events are distinct even if they cover 
more than one point on the trace.

 A loss value is specified for fiber section events. No reflectance is 
specified for this type of event.

 The attenuation (dB/distance in kilometers) is obtained by dividing the 
loss by the fiber section length.

Reflected power 
(dB)

Distance
(km)

Fiber 
section

Fiber 
section
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Description of Event Types
Merged Event
Merged Event

This symbol denotes an event combined with one or more other events. It 
also indicates the total loss produced by the merged events following it in 
the events table.

 A Merged Event is composed of subevents. Only the Merged Event is 
attributed a number in the events table, not the subevents composing 
it, if they are displayed.

 Reflective events may indicate the presence of connectors, mechanical 
splices, or poor-quality fusion splices or cracks.

 Non-reflective events may indicate the presence of splices, splitters or 
bendings. 

 A reflectance value is specified for all merged events and indicates the 
maximum reflectance for the merged event. A reflectance value is also 
displayed for each reflective subevent composing the Merged Event.

Reflective events

Point A

Point B
Merged Reflective event position

Total loss ( dB)

Reflected power 
(dB)

Distance
(km)
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Description of Event Types
Merged Event
 The total loss ( dB) produced by the events is measured by plotting 
two straight lines.

 The first line is plotted by fitting, through least-square 
approximation, trace points in the linear area preceding the first 
event.

 The second line is plotted by fitting, through least-square 
approximation, trace points in the linear area following the second 
event. If there were more than two merged events, this line would 
be plotted in the linear area following the last merged event. This 
line is then projected toward the first merged event.

 The total loss ( dB) equals the power difference between the 
point where the first event begins (point A) and the point on the 
projected straight line located just below the first event (point B).

 No loss value can be specified for the subevents.
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Description of Event Types
Merged Event
Pass/Fail Tests

As an example about pass/fail tests, let us consider the situation below:

For a merged event, it is possible to determine the global event loss, but not 
the contribution of each sub-event. This is why the pass/fail test may 
sometimes lead to “false positive” or “false negative” results.

When evaluating event status against thresholds, we are faced with two 
possible conditions:

 All event types are tested (reflective, non-reflective)

 Only some event types are selected (for example, you could decide not 
to test reflective loss)

The third case would be to test none of the event types, which means the 
same as not wanting to know the status of the events.

Merged sub-events:

2 reflective losses

1 non-reflective loss

Thresholds:

Reflective loss: 0.5 dB

Non-reflective Loss: 0.2 dB

Merged event

Event loss
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Description of Event Types
Merged Event
All Event Types Are Tested

In the first case, where all event types are tested, the pass/fail conditions 
are as follows:

 If the event loss is less than or equal to the smallest threshold value, 
then the event status is Pass.

 If the event loss is greater than the sum of the number of sub-events of 
a type, multiplied by the threshold value for this event type, then the 
event status is Fail.

 If the event loss is “in between”, since it is not possible to know exactly 
the weight of a sub-event in the merged event, the global event is 
considered to have a status of Pass.

If the merged event loss is smaller than or equal to 1.2, then the status is 
Pass. Otherwise, it is Fail.

Pass/Fail Analysis Fail Level

=(Nsub x Thsub)

= (2 x 0.5) + (1 x 0.2)

= 1.2

Pass

Pass

Fail

0

0.2

1.2
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Description of Event Types
Merged Event
Not All Event Types Are Tested

In this situation, the only thing that we can clearly know is when the loss 
has a Pass status. If the global event loss is less than or equal to the 
smallest threshold value (a value that is tested, of course), we are sure that 
the merged event status is Pass. Otherwise, we cannot know, so the status 
of the event is Unknown.

In our example, if we suppose that you chose not to test non-reflective 
losses, then the analysis would be done as shown below:

Pass

Unknown

0

0.5

1.2

Pass

Unknown
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Description of Event Types
Merged Event
Effect of Event Status in the Global Trace Status

 A trace status is, by default, set to Unknown.

 If a trace is set to Fail once, it remains with that status (it cannot be set 
back to Pass or Unknown).

 Whenever an event status is Fail, so is the trace status.

 If an event status is Pass, the trace status can change from Unknown to 
Pass.

 If an event status is Unknown, the trace status remains the same. In 
other words, the event, in this case, has no influence on the trace 
status.

To avoid Unknown statuses, do not unselect loss thresholds individually.
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Description of Event Types
Echo
Echo

This symbol indicates that a reflective event has been detected after the 
end of the fiber.

 In the example above, the launched pulse travels up to the end 
connector and is reflected back toward the OTDR. Then, it reaches the 
second connector and is reflected again toward the end connector. It is 
then reflected back to the OTDR.

 The application interprets this new reflection as an echo because of its 
characteristics (reflectance and particular position with respect to 
other reflections).

 The distance between the second connector reflection and the end 
connector reflection is equal to the distance between the end 
connector reflection and the echo.

 There is no loss specified for echo events.

Reflected power 
(dB)

Distance
(km)

OTDR connector

Second connector

End connector

Echo

Lightwave travel
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Description of Event Types
Reflective Event (Possible Echo)
Reflective Event (Possible Echo)

This symbol indicates a reflective event that can be a real reflection or an 
echo produced by another stronger reflection located closer to the source.

 In the example above, the launched pulse hits the third connector, is 
reflected back to the OTDR and reflected again into the fiber. It then 
reaches the third connector a second time and is reflected once more 
to the OTDR. 

The application would therefore detect a reflective event located at 
twice the distance of the third connector. Since this event is almost null 
(no loss), and since its distance is a multiple of the third connector 
distance, The application would interpret it as a possible echo.

 A reflectance value is specified for reflective events (possible echo).

Reflected power 
(dB)

Distance
(km)

OTDR connector

Second connector

Third connector

Reflective event (possible echo)
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Description of Event Types
Coupler
Coupler
This symbol indicates that the event is a coupler port.

A coupler port is an optical fiber device with one or more input fibers and 
one or several output fibers. This device is associated with a minimum loss 
value; for example, a 1 1x2 coupler has a loss of 3 dB.

Any event can be set as a coupler port in the application. However, once an 
event is set as a coupler port, its loss threshold cannot be applied anymore, 
but its loss is taken into account in the total loss value.

If you are using a tunable OTDR, the OTDR analysis automatically sets the 
span start and span end events as coupler ports if their losses are greater 
than 1.5 dB.
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B Measuring Chromatic 
Dispersion: Theory

EXFO’s Chromatic Dispersion Analyzer applies the phase-shift method, 
which consists of measuring the phase variation of a sinusoidal intensity 
modulated signal at a specific wavelength to obtain the relative group 
delay of a fiber. The derivative of the relative group delay calculated from 
fitted equations on computed results gives the dispersion, the 
zero-dispersion wavelength and the dispersion slope.

Method behind the Chromatic Dispersion 
Analyzer

In EXFO’s Chromatic Dispersion Analyzer, the light source is a broadband 
source, which is intensity modulated at a high frequency. This light is 
injected into the fiber under test and the modulated light travels along the 
fiber. The high-frequency intensity modulation propagates at a speed that 
depends on wavelength and polarization. Values are obtained for the 
differences in travel time between modulations at different wavelengths. 
The higher the number of wavelengths at which this is done, the more 
accurate the chromatic dispersion results will be.

The first fixed filter in the receiver extracts the portion of the light that will 
follow an optical path. A second filter, which is a time-tunable filter, will 
extract a second part of the original signal and then follow a different 
optical path.

Different path combinations are added using a chopper. The amplitude of 
the high-frequency signals are measured and digitized. The phase 
difference is then computed using the different amplitudes. This value is 
stored along with the tunable filters position and a new measurement 
cycle begins. A new time delay is computed and stored with wavelength 
data. When sufficient data is accumulated, chromatic dispersion can be 
computed.
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Measuring Chromatic Dispersion: Theory
Using Data Fits to Obtain Dispersion
Using Data Fits to Obtain Dispersion
This section gives you details about the way EXFO uses the data fits to 
obtain dispersion. Once group delays are computed, equations are fitted in 
order to obtain dispersion, dispersion slope and zero-dispersion 
wavelengths. The dispersion curve of typical singlemode fibers follows 
certain equations used to interpolate zero-dispersion wavelength and 
slope. The following table graph shows the equations applied to 
singlemode fibers in specific wavelength ranges.

Fiber Type and
Wavelength Range Expression for D

G.652 NDSF

G.653 DSF

1500 nm-1600 nm

G.655 NZDSF

up to 1560 nm

G.655 NZDSF

1530 nm-1565 nm (C Band)

1565 nm-1625 nm (L Band)

1200 nm  1600 nm 

   A B2
C 2–

+ +=

D   2 B C 3–
– =

   A B2
C+ +=

D   2B C+=

D   D 1560  D 1530 –
30

-------------------------------------------------


 1560– 
 
 
 

D 1560 +=

D   D 1565  D 1530 –
35

-------------------------------------------------


 1565– 
 
 
 

D 1565 +=

D   D 1625  D 1565 –
60

-------------------------------------------------


 1625– 
 
 
 

D 1625 +=
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Measuring Chromatic Dispersion: Theory
Using Data Fits to Obtain Dispersion
G.653 DSF

50/125

62.5/125

G.655 NZDSF

1530 nm-1565 nm

Fiber Type and
Wavelength Range Expression for D

1200 nm  1600 nm 

   A B C  ln+ +=

D   B C C  ln+ +=

50nm  1450nm 

   A B2
C 2–

+ +=

D   2 B C 3–
– =

750nm  1450nm 

   A B2
C 2–

+ +=

D   2 B C 3–
– =

D   D 1565  D 1530 –
35

-------------------------------------------------


 1565– 
 
 
 

D 1565 +=
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Measuring Chromatic Dispersion: Theory
Helping You Manage Chromatic Dispersion
As the previous table demonstrates, specific fits are recommended for 
specific types of fiber and specific wavelength ranges. Fits should be used 
carefully when extrapolating parameters to obtain maximum precision.

 The 3-Term Sellmeier applies mostly to standard fibers with single zero 
dispersion at 1300 nm.

 The 5-Term Sellmeier has five zero crossings. Since it is extremely 
elastic, it should be used with caution when extrapolating because the 
fit may curve away from the true results beyond fitted points.

 The same warning applies to the cubic fit.

 The lambda-log-lambda fit is applicable to dispersion-shifted fibers 
with a zero dispersion wavelength in the 1550 nm wavelength region.

 The linear fit is useful when there are too few measurements for 
multiple parameter fits to be used. It is applicable to all fibers if the 
range is sufficiently small.

The fits will give you a tool to obtain the dispersion slope and zero- 
dispersion point.

Helping You Manage Chromatic Dispersion
The zero-dispersion wavelength (where dispersion is at zero) corresponds 
to the wavelength point at which the fiber under test reaches its maximum 
bandwidth.The slope from this zero-dispersion point indicates how fast 
dispersion rises as wavelength increases. Key chromatic dispersion 
parameters are the dispersion zero and the slope at zero dispersion.

Getting precise chromatic dispersion parameters helps you choose the 
right dispersion-compensated fiber or material in order to reverse the 
dispersion and dispersion slope before the data is interpreted by the 
receiver at the other end of the line.

The effects of chromatic dispersion decrease with a reduction in the 
absolute value of the fiber chromatic dispersion or with dispersion 
compensation.
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C Measuring Polarization Mode 
Dispersion: Theory

The dispersion phenomenon is described as a number of 
non-intensity-dependant physical occurrences resulting directly in signal 
loss (pulse spreading or time jitter in a digital system; distortion in an 
analog system). PMD is an important type of signal dispersion. As 
unrepeated link distances are increased and transmission rates pushed 
upwards, PMD can significantly reduce system performance.

To better understand the impact of PMD, consider the example of a pulse 
passing through a wave plate. Upon entering the wave plate, the pulse is 
decomposed into polarization components aligned with each of the two 
birefringent axes of the plate (known as the fast and slow axes). The 
components propagating independently through the wave plate at different 
group velocities will recombine at the end of the wave plate as a 
superposition of two pulses split in time.

The delay between those pulses is designated as the differential group 
delay (DGD) and is written as . For a Gaussian, unchirped input pulse 
of rms width , the rms width at the output is given by

where r is the fraction of the input-pulse energy launched into one of the 
birefringence axes.

Worst-case spreading occurs when the signal is perfectly split in two 
(r = 1/2), while no spreading occurs if the input state of polarization 
(SOP) of the launched signal is aligned with one of the birefringence axes.

To generalize this example, consider a long, weakly birefringent 
telecommunications fiber as a concatenation of many, randomly 
orientated birefringent wave plates. Each interface between two wave 
plates redistributes the optical energy along both axes of the subsequent 
wave plate. This transfer of energy is called mode coupling.

2 0
2

r0 1 r0–  2+=
Post-Processing Software 427



Measuring Polarization Mode Dispersion: Theory
In a long fiber, numerous mode-coupling events occur along the fiber 
length, so that light emerging from the output end is the superposition of a 
number of pulses with different delays. Nonetheless, it turns out that for 
any given optical frequency, , one can always find two orthogonal input 
principal states of polarization (PSPs) such that a light pulse with the same 
input SOP as the input PSP, undergoes no spreading. For a single wave 
plate, the PSPs are the two birefringent axes, whereas for a concatenation 
of wave plates, neither the input nor the output PSPs correspond to the 
alignment of the birefringent axes anywhere.

Contrary to the case of a wave plate, the DGD and PSPs of a long fiber are 
dependent on wavelength and fluctuate in time as a result of 
environmental variations such as temperature, external mechanical 
constraints, etc. Their behavior is random, both as a function of wavelength 
at a given time and as a function of time at a given wavelength. Fortunately, 
this behavior can be characterized statistically. It can be demonstrated that 
the probability density function of  is Maxwellian and, by definition, PMD 
is its rms value, that is:

Note: PMD is sometimes defined as the mean value of the DGD, which for a 
Maxwellian distribution yields a value 17 % lower than the rms definition.

If the average is calculated over , PMD is stable in time, provided that the 
averaging window is sufficiently large (Dwdt >> 1).

PMD DGD
2

=
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Measuring Polarization Mode Dispersion: Theory
It is essential to keep in mind that DGD fluctuates in time and can be either 
smaller or larger than its rms value or PMD. This results in a statistical 
probability that a pulse (information bit) is broadened, and leads to the 
eventual impaired ability of the receiver to efficiently decode the 
information. This adverse PMD effect makes it a critical phenomenon in 
limiting transmission of high-bit-rate information.

In the case of PMD in a long fiber, there is a specific state called input PSP. 
In this state, when the input SOP of the signal is aligned with one of its 
axes, it will propagate through the fiber without any spreading or distortion 
of the signal. This phenomenon is defined as this specific input SOP such 
that the output SOP is independent of optical frequency. Again, the worst 
case occurs when the signal is equally split between both input PSPs.

For long telecom fibers with random coupling of energy between modes 
(that is. L >> h, where h is the coupling length), PMD grows as the square 
root of the distance, whereas PMD of strong HiBi fiber (negligible mode 
coupling) is directly proportional to the distance. Therefore, the PMD 
coefficient for negligible mode coupling is expressed as ps/km, while 
the PMD coefficient for random mode coupling is defined as ps/km1/2.
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D Report Samples
This section presents samples of some reports you can generate using 
FastReporter 2. Keep in mind that those reports are samples and your final 
results may differ depending on the options and number of files you have 
selected. Various other report types are also available for your other testing 
needs.
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Report Samples
Bidirectional OTDR
Bidirectional OTDR
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Report Samples
OTDR
OTDR
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Report Samples
Fiber Characterization
Fiber Characterization
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Report Samples
Fiber Inspection Probe
Fiber Inspection Probe
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Report Samples
iOLM
iOLM
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Report Samples
OTDR Advanced Cable (Excel Template)
OTDR Advanced Cable (Excel Template)
This report displays various information related to the OTDR Advance 
cable, such as: Cable information, Measurement information, Fail report, 
Length, Reflectance, Splice and reflectance, Splice loss, Attenuation, and 
Loss.
Post-Processing Software 437



Report Samples
iOLM + FIP (Excel Template)
iOLM + FIP (Excel Template)
This report displays the iOLMandFIP measurement values in single report 
based on matching.If multiple measurements are selected, the report 
displays multiple worksheets for the each of the selected measurements. 
The worksheets are labeled as iOLM + FIP (n). Where, (n) represents the 
measurement number.
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Report Samples
iOLM Bidirectional (Excel Template)
iOLM Bidirectional (Excel Template)
This report displays the Bidirectional measurement with corresponding 
unidirectional measurements A-B and B-A.
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Report Samples
iOLM Advanced Cable Report (Excel Report)
iOLM Advanced Cable Report (Excel Report)
This report shows detailed information for your cables. Each category of 
the report (cable information, measurement information, fail report, 
summary results, link elements, splice elements, connector elements, 
A & B elements, and attenuation section) is on a separate sheet.
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